2 Replies Latest reply: Feb 20, 2013 7:05 AM by MikkyX
MikkyX Level 1 Level 1 (0 points)

Before I moved house my AppleTV worked perfectly. I was running iTunes 11, ATV 3 OS 5.1 and everything just worked, as Apple like to say.

 

One house move later and everything seems to have gone wrong. It's been out of action for a couple of months because of delays with the move and not having proper internet where we were staying, but anyway....

 

The first sign of trouble came when we plugged it all back in - said there was an update available, so I allowed it to download. However it then failed to install it - three times. I read on here that unplugging the Ethernet and running the update over WiFi might work.... and it did. So now I'm running AppleTV OS 5.2.

 

Since the 5.2 update:

I've got no sound at all. Not even the menu beeps and boops. YouTube videos play silently, so does music, so does everything. I've tried the suggested workaround of turning off Dolby Digital instead of leaving it at automatic - still nothing

 

Home Sharing is screwed. Initially it couldn't see a new TV episode I'd added to my library, but then, bit by bit, every time I looked at my library through the Computers option it would shrink. The TV series where I couldn't see the new episode suddenly lost two more - then it was random episodes. Another show, which I have two six-episode series for, only showed two episodes in one of those series. The next time I looked at it, it displayed an error about there being no content for this show (or something like that). If I try to PLAY something from my Home Sharing library, I get the spinner followed by "there was an error playing this content" or whatever the message says. I have 30 movies in my HS library - my Apple TV thinks I have 6.

 

These episodes / movies are .m4v h264 files correctly tagged and grouped by TV show. Again, this is the same library in the same iTunes (well, it's 11.1 now) that HAD been working flawlessly. While I haven't tried music, I can play video and audio podcasts from my Library but see problem 1 - I can't hear them.

 

I've tried everything I can think of to solve each problem, right down to a full unplug, plug it back in again and do a full factory reset. Even after all this, my Apple TV silently sits back and watches my Home Sharing library gradually dwindle away to nothing.

 

Any suggestions before I drive to my nearest Apple store and throw it at the nearest Genius?

  • MikkyX Level 1 Level 1 (0 points)

    Just to add to this, I've been checking my Home Sharing on my iPhone 4S (iOS 6.1.1) and the library on there is as screwed as it appears on the Apple TV. Maybe my iTunes Library is somehow corrupted?

  • MikkyX Level 1 Level 1 (0 points)

    Problems seem to be solved now - a combination of the latest iTunes update (which, of course, required an iTunes restart) and reseating the HDMI cable at both ends seems to have sorted everything out - Home Sharing library plays again and I can hear it too.