2 Replies Latest reply: Oct 26, 2014 6:48 PM by cathair
BungyCase Level 1 (0 points)

Blocked plug-in appeared so did the update, not matter what effort, remove, reinstall, reboot, stills says blocked plug-in.

Anyone else,

Using MountainLion on 2011 MacMini. All software up to date.

Safari Flash, OS X Mountain Lion (10.8.2)
  • Linc Davis Level 10 (192,709 points)

    If you're sure you've installed the latest version of Flash, take each of the following steps that you haven't already tried. After each step, relaunch Safari and test. For a "missing plug-in" error, start with Step 4.

    1. If you're getting a "blocked plug-in" error, then from the menu bar select


     ▹ System Preferences… ▹ Flash Player Advanced

    and click Check Now. Quit and relaunch your browser.


    2. Triple-click the line below to select it:

    /Library/Internet Plug-Ins
    Right-click or control-click the highlighted text and select
    Services ▹ Open
    from the contextual menu. A folder should open. If there is more than one item in the folder with the words "Flash Player" (not "flashplayer") in the name, open the respective Info windows, check the version numbers, and delete all except the latest. You may be prompted for your login password.
    3. Re-download and reinstall Flash. Download it from this page:
    Never download a Flash update from anywhere else.
    4. If you get a "missing plug-in" error, select
    Safari Preferences... Security
    from the Safari menu bar and check the box marked Enable plug-ins.


    5. Select

    Safari Preferences... Extensions

    from the Safari menu bar. If any extensions are installed, disable them.

    6. In the Safari preference window, select

    Privacy Remove All Website Data

    Close the window. Then select

     ▹ System Preferences… ▹ Flash Player Advanced

    and click Delete All. Close the preference pane.

  • cathair Level 1 (0 points)

    I have the same problem as BungyCase, as of yesterday.  I've followed all the instructions you laid out, Linc, but to no avail.  Still get the blocked plug in message.  I also get it when trying to listen to BBC4 extra programs... not video. (This is where I noticed the problem first.)

    Since I'm not getting the "missing plug in" I didn't follow those instructions, but did explore them.

    I went to the Flash site and it says the latest version I should have is 15.0,0.189, but when I checked my system preferences, after installing the latest version 5 times and relaunching Safari, it says I have installed.  So... does that mean anything?