12 Replies Latest reply: Mar 1, 2013 4:08 PM by pupvolunteer
ChimaE24 Level 1 Level 1 (0 points)

I have an iPhone 4S, 16GB with Virgin Mobile, and my data isn't working. The phone displays 3G, and I get between 3-5 bars, but every time I attempt to use an app that uses data or when I load a web page, it displays "Could not activate cellular data network. You are not subscribed to a cellular data service". Placing/receiving calls and texting still work, however. This isn't a location specific issue either.

 

*I've tried dialing ##UPDATE# to activate "Starting Service Update" probably hundreds of times, unfortunately it always comes back as "Service Update Failed".

 

*I've also reset Network Settings, and this did nothing for my iPhone.

 

*I've called Apple and Virgin Mobile but they couldn't fix this issue. Virgin Mobile doesn't have an outage at the moment. Some of my friends have VM, and their phones work just fine.

 

The phone works flawlessly when connected to WiFi.

 

VM iPhones do not use SIM cards.


iPhone 4S, iOS 6.1.1
  • archijit Level 1 Level 1 (0 points)

    Same issue with me . I also did everything possible in last 3 days. One new thing come to me is never seen data symbol 'o' before. It only seen on my 4s after this 6.1.1 update. As i use 2G data plan of Airtel, my symbol had been always 'E'.

  • comeaugm Level 1 Level 1 (15 points)

    I contacted Virgin on February 15.  The support person told me that the problem will be fixed on February 19th, but did not elaborate on this.  Not sure if this means a release of 6.1.2 or an update to their network... we'll see.

  • BobHarris Level 6 Level 6 (15,665 points)

    I have an Virgin Mobile USA iPhone 4s and my data works fine.

     

    NOTE: Virgin Mobile USA was sold to Sprint, and is not the same as Virgin Mobile in other parts of the world.  So it is important to identify which country you are living in.

     

    Anyway, to use my Virgin Mobile USA iPhone, I needed to sign up for the "Beyond Talk" $35/month plan.  And of course follow the instructions for activating the phone.

     

    I had service with iOS 5.1, iOS 6.0, iOS 6.0.1, and iOS 6.0.2.  If you are having data problems with Virgin Mobile it is not related to the iOS software version.

     

    Most likely there is an issue at the Virgin Mobile end.  archijit and ChimaE24, I suggest contacting Virgin Mobile and having them diagnose your issues, just like comeaugm did.

  • ChimaE24 Level 1 Level 1 (0 points)

    I contacted VM multiple times via email and phone, and they were completely helpless! This issue is driving me insane! They keep saying that it's a "system update" and that the problem will be resolved within 24-72 hours. They've been giving me the same lies since Feb 9th.

  • TechExpress Level 1 Level 1 (0 points)

    Its now Feb 21st - I'm using a iphone 4s and running 6.1.2 and have updated and reset the phone several times as described in earlier posts. Of course I'm still getting "Could not activate cellular data network". VM tech support is useless so far. They are supposedely looking into it and will call me back. Any help?

    Network: Virgin

    Version: 6.1.2 (10B146)

    Carrier: Virgin 14.0

    Model: MD865LL/A

    Modem Firmware: 3.4.02

  • ChimaE24 Level 1 Level 1 (0 points)

    No help at all! I've spent several hours on the phone with Apple, and we've done a factory reset, so we've concluded that it's a Virgin Mobile issue... But VM, offers horrible technical support, so I think I'm out of $450

  • comeaugm Level 1 Level 1 (15 points)

    Finally!  My problem has just been resolved.  I called Virgin Mobile again and asked for their "Level 3" support.  They put me through to a technician who did some resets on my account.  After doing the ##UPDATE#, 3g was back and working fine.  I asked her what she did to resolve it.  She said that my account still had some old data from before they updated their system over a week ago...she just needed to reset it.  Good luck!

  • ChimaE24 Level 1 Level 1 (0 points)

    No way!!!! Did you lose any files on your phone?! I'm so happy for you!!!

  • comeaugm Level 1 Level 1 (15 points)

    Nothing was lost on my phone.  I did not do any factory reset prior to fixing this problem...just UPDATE and Reset Network Settings...of course these didn't work until VM's Level 3 support (or Tier 3...can't recall) went into my account and reset some information that was there from their old system.  Insist on getting that higher level support when you call them again, if you haven't done so already.

  • JordanFrederick Level 1 Level 1 (0 points)

    I have had this same exact problem for almost a month now and after finally finding this forum I saw the ##UPDATE# listed by one of you and I had never saw this before or even heard of it from the Virgin mobile or Radioshack people. After seeing this I dialed it in and received the Update Failed. Then I connected wifi and dialed it again and it worked! Data started working and I have to give all the credit to you guys because without your help I would still be sitting on the phone with virgin mobile hours each night! Thanks!!

  • TechExpress Level 1 Level 1 (0 points)

    Did you turn your WiFi off and try the data again? Mine didn't.

  • pupvolunteer Level 1 Level 1 (5 points)

    I want to say that I have had the exact same problem as comeaugm, since Feb. 9th. I have spoken with customer service at virgin mobile many times, reset the phone, etc. I chatted with apple support today and they said it was a service (virgin mobile) issue. I tried the ##update# on my phone, but no luck. It worked with wifi on, but when I turned wifi off there was no data. Thanks to your post I called virgin mobile one more time and they sent me up to the higher level. Jessica at that level is an iphone expert, she says. She did a few things on her end and advised me to input ##873283#, which is the same as (##update#), and though my phone went into an odd "searching" mode that she was unable to explain, after it was turned off and back on it worked just fine. What a relief!

    She also credited me $21.00 for the 21 days I have been without cellular data service.

    Hope this helps!