5 Replies Latest reply: Mar 9, 2013 5:08 PM by Sowersweet01
Sowersweet01 Level 1 Level 1 (0 points)

Ok, I realize a lot of other people have had this problem and somehow managed to resolve it. I have done a lot of reading and experimenting but so far NOTHING has worked. So, to recount everything that I have tried and all the details to this problem:

First of all, I would like to mention that I have successfully burned a number of DVDs in idvd in the past. Then suddenly it just stopped working.

 

I have run a verify/ repair disk permissions. I have deleted all the idvd files off my computer, the .plist and preferences file, restarted, and reinstalled iDVD TWICE with a custom install. I have 500 gb of free space on my boot drive. I used a cleaning disc on my SuperDrive, and my regular DVD player. I switched to a better brand of blank dvd. I am now using Sony DVD-r, 4.7 gb discs although memorex DVD+r always worked just fine before. The project I am burning fits on the disc. I am not using chapters. I tried turning on the tv safe area and made sure everything was inside it, but still the same problem. I tried booting up in safe-mode then restarting. Still, same issue. I am burning at 2x speed, using professional quality setting. The project preview works just fine. It goes through the whole idvd process just fine, until the burning and multiplexing. After burning about 10 minutes of the project, the disc ejects suddenly. Idvd says "done" but then at the bottom it says "about one minute left" and the little burning wheel symbol is still spinning. The disc plays fine in my DVD player till about ten minutes in, then freezes and eventually goes back to the main menu. I can see on the disc that it is only partially burned.

   Oh, and I have also tried saving to a disc image and burning with toast and disc utility. Once, this actually did work with toast and resulted in a playable DVD. The weird part was that I still got the error sense key message in toast and thought I had made another coaster, but when I tested the DVD it worked fine in my regular dvd player only (it was not readable in my xbox or ps2). Since that one fluke, however, it hasn't been successful. Disk utility did not work for burning the disc image. I am absolutely at a loss here...somebody PLEASE help.


iMac, Mac OS X (10.6.8)
  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    Hi

     

    Yes it looks like You gone trough the most of our suggestions - but what You do not mention - and that's directing my interest - is what kind of material You did feed iDVD

     

    • Video Codec - .mov, .m4v, .mp4 etc ARE NO Codecs - but containers that can hold material iDVD can or can not use.

     

    Open the movie file with QuickTime Player

    Press [ cmd+I ] (opens Inspector) and read

    - Video format (codec) : nnnnnnnnnnnn

    - Frame rate : yy.yy / sec

     

    • Photo file format used ? I never ever use .bmp - only .jpg and in a reasonable size ( when opened ! - the compressed size is of no interest at all )

     

    • Audio file formats - I convert all to .aiff 16-bit 48kHz or from Audio-CDs (still .aiff but now 44.1kHz) - Never ever .mp3 OR directly from iTunes (here I Burn needed audio as an Audio-CD .aiff - BUT there are more Clever ways than doing this)

     

    YES - What You feed iMovie or FinalCut also matters

     

    If FinalCut - NO QUICKTIME CONVERSION ! - Known to not work

     

    Yours Bengt W

  • Sowersweet01 Level 1 Level 1 (0 points)

    I am not using final cut or iMovie, only iDVD. No photos, no audio except what is part of the video file. The video files I have tried to burn include .mov, .avi, m4v, but mostly avi. Mp4 did not work at all, not readable by idvd or anything else except vlcc player. They play just fine in QuickTime. Also, the same files burned just fine to DVD previously, even as recently as two weeks ago. Yet now they will not. Last night I used iDVD to make a disc image. Then I tried burning with disk utility. I got an error message. Next I tried with toast. Medium sense key error message. I do not think this problem is related to the content, i have used idvd many times! i'm doing exactly the same things as before, only now, its broken! I am starting to wonder if my drive is just bad. It always burns successfully the first ten minutes then quits.

    The only thing I can think of that might have caused this change is right before these problems started, I was doing some maintenance and I ran a repair disc permissions and deleted some files off my computer to free up disc space. One file i had labeled codecs and, although I thought it was not being used, do you suppose this could be the reason? Afterwards, I began having burn problems although I did make a couple successful DVDs while troubleshooting... They would play on the regular DVD player but not the Xbox or ps2. Now I can't even do that. I wonder, did my drive begin to fail, sputter out a last few partially readable DVDs, then just give out altogether? If it burns at all, then it should be able to burn all the way, right?

  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    Now it's getting tuff. So I can only share some thoughts.

     

    A. QuickTime player - can play much more Codecs - than iDVD (and iMovie) can use

     

    B. include .mov, .avi, m4v, but mostly avi.

     

    non of them is a Codec - they are containers (type of folders) and can hold about anything - Codecs that works and not.

     

    • Open file with QuickTime player

    • press [cmd+I] = opens Inspector

    • read - Video format (Codec) : nnnnnnnnnnnnn and Frame Rate : yy.yy / sec

     

    What does they read ?

     

    C. Tidying out files - I never dare to do this - very close to killing ones Mac - only for people much more experience than I (only used computers since 1973)

     

    Yours Bengt W

  • Sowersweet01 Level 1 Level 1 (0 points)

    Ok. Some progress has been made. I purchased an external DVD drive off amazon and used disk utility to burn one of the disk images I created in idvd to DVD. Worked perfectly. Movie (which was an 89 minute .avi file, originally) played fine in regular DVD player, Xbox, and ps2. So, i am thinking that the problem was a partial hardware failure after all. Not too surprising since my iMac was purchased from a previous owner who, though he took really good care, probably put some use on the SuperDrive. Combined with what I have done with it, it probably just wore out.  have not yet tried burning a movie straight from idvd because NOW idvd keeps freezing up on me, usually after I have added the video to my idvd project. It works fine then suddenly, rainbow wheel forever. Over and over, the same thing. Sometimes it just abruptly crashes and the program closes. I did not use to experience this problem before so this tells me, something's still not right with my precious iMac. Grrrrrr. But, I WILL get to the bottom of this!

     

    Not sure with this new problem if I will even be able to create more disk images for burning.

  • Sowersweet01 Level 1 Level 1 (0 points)

    I believe I have finally fixed the problem but I am going to post what I went through just in case someone else ever runs into these same issues, maybe I can save them some time. I went through so much troubleshooting and each problem solved seemed to result in new problems, so, let me recap.

     

    First, computer was working fine. Burned a DVD, it worked. Then a few days later, tried to burn another DVD. It didn't work. I tried different brands of discs, different types of discs, (-r and +r) sometimes there was a partial burn, sometimes no luck at all and an unusable, unplayable disc. The disc would eject early during the burning phase, giving me simultaneous contradictory messages that it was both "done" and had " about one minute left".

     

    I tried running a verify/ repair disk permissions. Everything came out fine, but still no burned DVDs. I tried uninstalling and reinstalling idvd. I tried a cleaning disc. Still no go. Sometimes idvd would crash or freeze on me or give me error messages. Result varied depending on what i tried, but were never good.

     

    Then I bought an external drive and tried saving my DVD project as a disc image and burning with toast as many people have suggested. This worked! So, I concluded that my SuperDrive was faulty but I'm not going to bother getting it replaced right now because the external works just fine. I thought my problem was finally solved, but then...

     

    I noticed that upon restarting, my computer would display a white-gray screen as is normal, with the familiar apple symbol, but now a new addition: a very annoying loading bar that took 5-10 minutes to load. Unacceptable!!! Also, I noticed shortly after that iTunes did not work. It wouldn't even open, but crashed due to an error and asked if it could send a report. I tried deleting and uninstalling iTunes but that didn't work.

     

    I ran another verify disc permissions with disc utility, and I got a very bad error message. It said there were errors on the drive and it could not be repaired and it said I needed to start up from the Mac OS X install disc and use disc utility to repair the volume. Problem with that...my install disc says it can't install on this computer. I soon learned from one (finally) helpful apple support guy that the reason for this was that I am running snow leopard 10.6.8 and the disc that came with my computer was for 10.5.2 or something.

    On a side note: I had called apple support before and specifically asked if the reason the disc didn't work was because it was for a different version and the guy said he had no idea if that was the reason or not. Jerk. CLEARLY, that was the reason and my ignorant butt didn't know any better and he wanted me to pay 19.99 just to answer that question for me.

     

    So, I went to the apple store and purchased snow leopard. It was delivered today, I started my computer from the new snow leopard disc and repaired my drive. Restarted. A bit slow restarting but no more loading bar and not as bad as before...iTunes still didn't work but I completely uninstalled a reinstalled it again and this time it seems to be working fine. Idvd is working, I saved another movie to disc might. And am assuming it will still burn fine with toast in the external drive.

     

    During my arduous troubleshooting I discovered that I most probably have the seagate 1 tb hard drive that was recalled by apple due to its tendency to fail...whether this has been the root of my computer's troubles from the start, I still don't know for sure. But, everything seems to be functioning correctly now at least and since my computer has lasted this long without hard drive failures, maybe it will be ok. It's possible that I somehow caused the errors while I was fiddling around on the computer trying to fix idvd and iTunes. Hope this is helpful to somebody, someday. I did gain a lot of advice from various forums on the web and found many people having one or more of the issues I was running into, so I thought I should record my process here for others as well.