9 Replies Latest reply: Feb 24, 2013 2:14 PM by dapadizzle
dapadizzle Level 1 Level 1 (0 points)

please help, im having midi timeout errors and gonna try this


Logic Pro, Mac OS X (10.5.8)
  • 1. Re: re install.......will i lose songs and vst?
    CCTM Level 6 Level 6 (9,015 points)

    Hi

     

    If you are having MIDI timeout errors, re-installing Logic is not likely to fix it. You need to track down the source of the errors, and then remove it.

     

    Most common causes are due to DigiDesign/Avid/MBox MIDI drivers.

     

    Have a look in System:Library:Extensions for any of the above.

     

    You should not lose any Logic Projects or any 3rd party plugins should you decide to try re-installing Logic (but backups would not hurt).

     

     

    CCT

  • 2. Re: re install.......will i lose songs and vst?
    dapadizzle Level 1 Level 1 (0 points)

    thanks for the reply. none of that is there.

     

    i had some advice to create a new user, load up logic and try again. i kept getting errors on every vst, even Au apple ones. i opened logic and still have midi timeout and all my plugins are gone.....

     

    im going crazy here!

  • 3. Re: re install.......will i lose songs and vst?
    The Art Of Sound Level 5 Level 5 (6,530 points)

    What do you mean, all your plugins are gone? If you created a new user that can happen.... Who gave you that advice?

     

    Logic does not use VSTs so I assume you really mean AU plugins yes?

     

    Are you sure you looked in the right folders?

     

    Do you have an Mbox? If so, it's likely to be related to their drivers which you had to install so they will be in the folder as indicated by CCT.... so make sure you look in the right folder...

     

    Also look in your Local Library (Not the User Library) which is found in the root directory of your System Drive... for any Midi drivers...

     

    Typically the path would be Macintosh HD/Library/Audio/Midi Drivers and tell us what you find in there...

     

    If you renamed your system drive to something else other than the default..  then change Macintosh HD to the name of your System HD

     

    Again, this is not the User Library.. so make sure you look inside the correct folder...

  • 4. Re: re install.......will i lose songs and vst?
    Eriksimon Level 6 Level 6 (10,815 points)

    The Art Of Sound wrote:

     

    What do you mean, all your plugins are gone? If you created a new user that can happen.... Who gave you that advice?

    Yeah, who? I'll kick his ***... !

     

    Well, I did, and nothing's "gone", it can in fact NOT happen. In the old user account nothing will have changed. And since the new user account actually did also exhibit the midi timeout error, we now know that it is not user library related (which is the whole point of this new account-test). So he can now log back into that and delete the testaccount again. On the minus side, this means deleteing the prefs won't solve it either.

    I dare bet a handsome sum far exceeding my creditlimit that all the .components are still there were they always were, some with a neat little (k) behind their name too...

    The plugins failed to validate; it was the OP who then said that they "were gone from logic". But they're not. If he goes back to his old account, it will all still be the same. He should probably delete some sort of MIDI driver from his User Library or something, but his vibe really made me withdraw.

    Earlier he said that he "...read most forums and deleted stuff from my audio units etc."  Sound like a mess has been made.

    Too much has already been tampered with, imo.

    I think the only way out of this situation is a clean install of everything, OS X, Logic Pro, 3rd party plugins.

     

    http://www.logicprohelp.com/forum/viewtopic.php?p=482869#p482869

  • 5. Re: re install.......will i lose songs and vst?
    The Art Of Sound Level 5 Level 5 (6,530 points)

    Yeah, who? I'll kick his ***... !

     

    LOL... Guess that didn't exactly come across as i meant it to

  • 6. Re: re install.......will i lose songs and vst?
    Eriksimon Level 6 Level 6 (10,815 points)

     

  • 7. Re: re install.......will i lose songs and vst?
    dapadizzle Level 1 Level 1 (0 points)

    what do u mean my vibe made you withdraw?!

  • 8. Re: re install.......will i lose songs and vst?
    Eriksimon Level 6 Level 6 (10,815 points)

    Just like this one: you're angry, like you want 'revenge' for some 'injustice'.

     

    And no, you never 'say' that, that's why I say 'vibe'.

     

    Note that I am very much aware that this is what I feel, not necessarily what you do... I may be wrong.

    And it was not just the 'vibe', to be honest. It seems you already 'did stuff', and in my experience those things are only repairable if I'm actually looking that Mac and can see, eh, 'stuff', for myself. Many things are easy to do, but almost impossible to explain, it takes volumes. And since your words were already Xtremely vague (like 'did stuff'... what the h... am I supposed to guess that you did? It's a computer you know, it basically works via very precise commands, so to troubleshoot you have to be as precise as you can, and not go like "juz doin' stuff 'n sh*t" and stuff) so I really felt like I was not (emotionally) capable of assisting you. And for that, I'm sorry.

     

    But Annieway, did you ever solve your issue?

  • 9. Re: re install.......will i lose songs and vst?
    dapadizzle Level 1 Level 1 (0 points)

    its not that im angry at all! lol.

     

    its how you read the posts and form your own opinions that might be wrong!

     

    As far as being vauge, thats because im not clued up on the mechanics of computers............dont think i quite put it how you say i did...........again, its how you read the posts!

     

    i came back to asisist anyone else having this problem. i run osx 10.5.8 and this worked fine for me. just remember to preserve users and network settings. All the 'sh*t and stuff i was juz doin' (as eriksimon says) was back after software updates all was back to normal.

     

    http://support.apple.com/kb/HT1710

     

    my sh*t, stuff, stuff is all working.

     

    hope this helps anyone who had the drama ive had.