Previous 1 2 Next 20 Replies Latest reply: Jan 13, 2015 9:50 AM by basilgg Go to original post
  • mende1 Level 10 Level 10 (90,615 points)

    If it's a hardware error (it is), there's not too much to identify, because it's clear that the key is stuck (and you say it is not) or a part of your Mac is damaged. You are welcome

  • Badunit Level 6 Level 6 (11,205 points)

    Give this a try to see what happens:

     

    Preferences/Keyboard/Keyboard/Modifier Keys. Put "no action" for Option key. It might get you through for a while.

  • wagnerman Level 1 Level 1 (0 points)

    This started this morning for me on a macbook pro in the middle of working on the computer.  I searched and tried several things, coming close to losing my mind in the process.  I know this is an old thread, but its the first one that comes up on google and I finally got it fixed and wanted to share what worked for me in case anyone else is hunting for a solution...

     

    My symptoms -

    Keystrokes and trackpad were all of the sudden being modified as if the option key was being pressed.

    Keyboard viewer did not show that the option key was being pressed.

    Tried disabling option key in modifier key controls

    Tried rebooting - no change

    Bluetooth keyboard worked normally

    Sticky keys was turned off

     

    My fix-

    Open system preferences

    Select accessibility

    Select keyboard

    Enable sticky keys

    Press option twice quickly to enable sticky and once more to turn it off (option key must be enabled if you previously disabled it in modifier key controls)

    Problem solved!

    Turned sticky keys back off afterwards

     

    Somehow the laptop had a sticky option input (even though sticky keys was off and it was not displayed in the top right corner) and activating/deactivating the sticky option key cleared it.

  • Tom Gewecke Level 9 Level 9 (73,740 points)

    wagnerman wrote:

     

    My fix-

    Open system preferences

    Select accessibility

    Select keyboard

    Enable sticky keys

    Press option twice quickly to enable sticky and once more to turn it off (option key must be enabled if you previously disabled it in modifier key controls)

    Problem solved!

    Turned sticky keys back off afterwards

     

    Somehow the laptop had a sticky option input (even though sticky keys was off and it was not displayed in the top right corner) and activating/deactivating the sticky option key cleared it.

     

    Very interesting, thanks!

  • MoreBikesFewerCars Level 4 Level 4 (1,285 points)

    EASY FIX -> Hold down the option key for a few seconds and then let go. This will unlock the ⌥ (Alt / Option) key and put it back to normal.

     

    I experimented a bit to find the solution on my own.

     

    What's really odd is that the ⌥ key was locked on my external USB keyboard, but not the Macbook Pro built-in keyboard. Except when I was using the trackpad on the Macbook. In that case, all mouse/trackpad gestures behaved as if the ⌥ key was down.

  • basilgg Level 1 Level 1 (0 points)

    Hallo Wanja- I had the same problem: Option key stuck active but not physically pressed. I just finally fixed it. (OS 10.10.1) Essentially, what you need to do is go to System Preferences -> Keyboard -> Modifier Keys and then set Option to No Action. The problem is that you can't get it to actually ignore the option key while it's being pressed. So the first thing you have to do is disable the built-in keyboard. But before we disable the built-in keyboard, hook up an external keyboard (USB or bluetooth) and ensure that it works fine.

     

    To disable the internal keyboard now, copy paste this into the Terminal application on your mac:

    sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyb oard.kext/

     

    It will prompt you for your password and give you an error message, but it will disable the keyboard (on OS 10.8 and 10.10, at least).

     

    Your keyboard should be off. Now- do the first step in System Preferences where we set the Option key to No Action.

     

    Now we can turn the internal keyboard back on by typing this into terminal:

    sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyb oard.kext/


    Now your keyboard should be on, and the option keys should be disabled. Except that you can't use the option keys anymore, your keyboard should be fine.


    Let me know if it works!


    -basil


Previous 1 2 Next