2 Replies Latest reply: Aug 2, 2014 11:45 PM by JoelCorrea
jlaurice Level 1 (0 points)

Since changing my router to a Dlink DIR-651, my apple deivces are not detecting airprinters.

Dlink says I need to open ports on the router.  

Please advise.

iPhone 4S, iOS 6.1.1
  • Fightin' Engineer Level 1 (125 points)

    Most of the resources I could find said that AirPrint uses Bonjour to advertise its services.  To make AirPrint available, then, you might need to open ports on the router.  This document should be helpful.



  • JoelCorrea Level 1 (0 points)

    Hi..I've had a variant of this problem; my internet was accessible but my devices on wifi could not see the PC on Lan. That meant no iTunes syncing, Airplay from iTunes etc.

    Dlink has a strange default setting that isolates Wifi & Wired connections into different subnets.I'm assuming you have DHCP setup on your router and you're PC or MAC has internet access via the same router. Try the following steps to see if this solves the problem for you; first Log into your DLINK admin page-

    1. Go to Setup -> Local Network  and Uncheck the box that says 'Configure the second IP Address and Subnet Mask for LAN' - Hit Apply

    2. Go to Wireless -> Wireless Basic and Uncheck 'Enable MultiAP Isolation' - Hit Apply

    3. Restart your Router


    You do not need to port forward. Just get the Wired & Wireless devices on the same Subnet.


    Let me know if this solves your problem. I've been frustrated by my problem for months & had nearly given up.