8 Replies Latest reply: Feb 19, 2013 10:07 AM by Bob Timmons
willmtaylor Level 1 Level 1 (0 points)

All,

Hello, and my apologies if this is redundant or been repeatedly explain; I searched the fourms and came up with nada.

 

My ISP is CenturyLink and they have provided me with a Zyxel PK5001z modem/router. I also have a Time Capsule and am running Mtn. Lion on my iMac.

 

I've run into several issues, so I have several questions:

  1. Are there benefits to either using the modem as the router and the TC in bridge mode or the modem in bridge mode & my TC as a router?
  2. I've turned on bridge mode with the modem, but I'm still getting a double NAT error message with flashing amber light on the TC. What's up with that?
  3. When I reset the TC and restore all defaults, it comes back up automatically in bridge mode, is this normal?
  4. When I try to turn off bridge mode, I get an error message about IP addresses, what is this about?
  5. Now, my Time Machine won't back up, telling me that the drive can't be found. Is this connected to my bridge mode issues?

 

I know these are a lot of questions, but I know just enough to get myself in trouble and not enough to get myself out. Please help me out! You're time and patience are appreciated!

 

Thanks,

Will


iMac, OS X Mountain Lion (10.8.1)
  • Bob Timmons Level 10 Level 10 (89,380 points)
    Are there benefits to either using the modem as the router and the TC in bridge mode or the modem in bridge mode & my TC as a router?

     

    It's pretty much personal preference here. If you have a simutaneous dual band TC and you want to enable the Guest Nework feature, that would require that the TC be  configured as the "main" router handling both DHCP and NAT services.....since the Guest Network option will not work correctly when the TC is in "bridge".

     

     

     

    I've turned on bridge mode with the modem, but I'm still getting a double NAT error message with flashing amber light on the TC. What's up with that?

     

    Sounds like the Zyzel gateway is not configured as a simple bridge mode modem. There are a number of modem/router or gateway devices that really won't allow a true bridge mode setting.....even though the setting might indicate that.

     

    IF....the Zyxel really was in bridge mode, you would have to configure the TC to Connect Using = PPPoE credentials, not connect using DHCP or Ethernet.

     

     

    When I reset the TC and restore all defaults, it comes back up automatically in bridge mode, is this normal?

     

    AirPort Utility recognizes that there is a modem/router or gateway devcie "upstream" on your network and configures the TC in the correct Bridge Mode setting accordingly.  This is normal.

     

     

    When I try to turn off bridge mode, I get an error message about IP addresses, what is this about?

     

    When you change the TC out of Bridge Mode, then it is acting as a router. So, you now have two devices on the network both trying to provide DHCP services (supplying IP addresses) and NAT services.  IP conflicts are common when this occurs and it breaks a fundamental networking rule.

     

    There are ways to adjust settings to reduce the chances of IP address conflicts, but you will still have an error known as Double NAT on the network.

     

     

    Now, my Time Machine won't back up, telling me that the drive can't be found. Is this connected to my bridge mode issues?

     

     

    Probably. The TC is confused now and has lost its way since you have made changes on the network. Once you get the network working correctly, you will likely have to reset the TC by restarting it and then possibly "pointing" Time Machine at the TC again as a backup destination. No sense in trying to do this until you get your network operating correctly again.

     

    Bottom line here.......unless you are able to configure the Zyxel device as a "true" bridge mode modem, in which case the TC can only Connect Using PPPoE settings, you should reset the Zyxel back to its normal default settings of acting as a modem/router providing DHCP and NAT services....and...configure the TC in Bridge Mode to operate correctly on the network.

     

    Or.....if it is important for the TC to act as the main router on the network, you might check with your ISP to see if they can provide you with a simple bridge mode modem......not a modem/router or gateway type of device.

     

    As I mentioned earlier, your modem/router might have a setting for bridge mode.....but it may not be a true bridge  mode setting.....as different manufacturers have different interpetations of what "bridge mode" might be.

     

    Normally, bridge mode means that both DHCP and NAT are "off". The fact that you are picking up a Double NAT tells me that NAT has not been turned off on your modem/router....so it is not really in Bridge Mode.

  • willmtaylor Level 1 Level 1 (0 points)

    Epic response. A million "Thanks" for taking the time to help me out as well as explaining in a way that was comprehensible. I'll investigate it all when I get home this evening, and report back. Thanks again!

  • willmtaylor Level 1 Level 1 (0 points)

    I've gone home and enabled bridge mode on the modem. I then changed mt TC from bridge mode to DHCP & NAT. After letting those settings be applied, now the modem is blinking that it doesn't have Internet & I have 2 error messages in Airport Utility:

    - Amber Internet connection

    - Amber No DNS Servers

     

    What's going wrong here?

  • Bob Timmons Level 10 Level 10 (89,380 points)

    If the Zyxel modem/router is configured to operate as a simple bridge mode modem......which I cannot say is possible.....but this article might help......How to configure a Zyxel Router in Transparent Mode

     

    And.....You have changed the setup of the TC to Connect Using = PPPoE.....and things do not work, I would suspect that the Zyxel device cannot be configured the way you want.....and you will need to revert to the setup of using the Zyxel modem/router in its default settings and set up the TC to operate in Bridge Mode.

     

     

     

    Screen Shot 2013-02-18 at 3.19.23 PM.png

  • willmtaylor Level 1 Level 1 (0 points)

    Bob,

    After working out my issues with CenturyLink technical support, you were definitely on the right track. That particular model is one of their "gateway" modems, meaning it's a router (wired & wireless) as well, and because of this, they don't support it in bridge "transparent" mode. Also, because CenturyLink doesn't use PPPoE here, it's not possible.

     

    To solve my issues, I simply went back to my old Zyxel 660r and put it in bridge mode; it works just as well.

     

    Regarding my other issue with my Time Capsule backups:

    After working out my modem & router issues, my TC still couldn't find my backup, even after doing a full reset, deleting the plist, etc. After poking around a bit, I did stumble upon my solution. In the Time Machine preferences screen where you can select the backup disk, devices are divided into 2 sections: Backup Disks above and Other Available Disks below.

     

    2 Backup disk selection.jpg

     

     

    I simply had to select my backups from the Other Available Disks below and was FINALLY given the prompt to re-enter my new credentials. After that, it was good to go.

     

    Thanks again for your time and help, Bob.

     

    Will

  • Bob Timmons Level 10 Level 10 (89,380 points)

    Glad that you got things working.

     

    For the record, since you spoke to CenturyLink support, what exactly does Bridge Mode on a PK5001z do?

  • willmtaylor Level 1 Level 1 (0 points)

    Technical support gave me very little information as "CenturyLink doesn't support bridging on our gateway devices." Basically, though, one has to have PPPoE credentials to support this mode, but since CenturyLink uses "DHCP"? I was told it's not possible here. Does that all sound right?

     

    Thanks again.

  • Bob Timmons Level 10 Level 10 (89,380 points)

    I guess I don't understand CenturyLink's requirements, but if things are working with the old modem, and you don't have a Double NAT error, then best to leave things well enough alone.