9 Replies Latest reply: Mar 24, 2014 1:24 PM by Ralph Johns (UK)
jeffrey147 Level 1 (0 points)

I dont want imessage on my macbook but i dont know how to get it off

iOS 5
  • ShazadTech Level 1 (5 points)

    iMessage is Built in to OS X Mountain Lion so you can't really delete it.

  • jeffrey147 Level 1 (0 points)

    Can I somehow unsync it so it doesnt recieve messages?

  • ShazadTech Level 1 (5 points)

    You know. You can always go to store.apple.com then Find the button that says "chat now". Then a representative will be glad to help you out.

  • CT Level 6 (17,545 points)

    Suppose you went to the Messages menu, Accounts and unchecked iMessage - would that help?

  • ShazadTech Level 1 (5 points)

    CT does have a point there.

  • Ralph Johns (UK) Level 9 (71,111 points)



    As CT says Messages can receive Messages (IMs and iMessages)  from the accounts set up in it and those that are Enabled.


    You can go to Messages Menu > Preferences > Accounts and untick all the boxes or each account that reads "enable" this Account.


    You can go further and Sing Out on the iMessages account

    All the other except the Bonjour one you can highlight then use the minus Button at the bottom of the List to delete.


    Alternatively you can go to System Preferences > Mail, Contacts and Calendars and deselect the Messages option against the IDs that are now listed in Messages.



    You cannot delete the Bonjour Option in Messages  (everyone gets this one) It can only be turned Off


    Example pic




    8:58 PM      Tuesday; February 19, 2013

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Sirthinks Level 1 (0 points)

    I just removed it from my iMac.  In terminal Go to ../Application and type sudo rm -rf Messages.app .  You will then be prompted for your password. NOTE:  BAD THINGS CAN HAPPEN using the SUDO command.


    Note:  If you remove it for account it messes it up for other accounts.  So it is a good solution for a single account machine.

  • Sherryl81 Level 1 (0 points)

    All you have to do is go to finder and click quit message. Hope it helps.

  • Ralph Johns (UK) Level 9 (71,111 points)



    Depending how they set up Messages and the iMessages account then this may not be enough,

    Any account in the Messages app is "supported by the IMAgent app.

    This Listens for incoming Invites  and new messages.

    This setting stops that.


    As I posted Earlier the Account can be "disabled' by unticking the "enable this Account box on any account  in Messages.

    You can't delete the Bonjour or iMessages account but you can disable them.


    In the case of the iMessages account you can Sign Out as well which removes the Apple ID.


    Just Quitting the app may not stop IMAgent "listening" and restarting the app when new messages arrive.




    8:23 pm      Monday; March 24, 2014


      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad