Previous 1 2 Next 27 Replies Latest reply: Nov 17, 2013 5:03 PM by wendy woo Go to original post
  • Johntr18 Level 1 Level 1 (0 points)

    Hi Michael and Nick,


    Here's the whole story. I left Terminal on and running since our last conversation. When I checked and saw nothing happened, I tried to launch FCS disc for installation. I got the same "no longer supported" message. Therefore, you got my "nothing happened" message earlier.


    But as a habit, I thought I would give this painful and unpredictable process a second chance. So I started Terminal again. When I copied and pasted your instruction line in again, the installation suddenly occured. And bingo, this installation issue is successfully solved.


    Thanks to you all. I am checking to see if the applications programs run properly. If there's any problem, you'll see me here bugging you guys again.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    Great news!


    Please come back and CONFIRM that installation was successful, so that I can confidently support this approach to installation of FCS2 into Mountain Lion!

  • Johntr18 Level 1 Level 1 (0 points)

    So far so good. Enjoy your 10 winning points, Michael.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    More importantly, with confirmation, I am able to properly advise other Final Cut Studio users on how to install in Mountain Lion!


    How long did installation take, after you initiated the instruction in Terminal the second time?


    A THANK YOU to Jeremy Johnstone; whose blog alerted me to this tip.

  • greg32 Level 1 Level 1 (0 points)

    Works!!! (Mountain lion)


    1.You will not see the usual installation window and you will not see anything happening besides the info in the terminal.

    2.You will not have the option to select installation of any additional content like audio loops. You can install those afterwards using the other disks. (each disk has an installer pkg which works on Mountain Lion)

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    Thank you for this additional confirmation!


    Can you respond with a step by step instruction set for future installers of FCS2 in Mountain Lion!  Thanks!


    I will then link to your instruction set post in the future...

  • greg32 Level 1 Level 1 (0 points)

    Will do. Still testing and running updates.

    One new development is that LiveType content can't be installed using the disc installer shortcut.

    The terminal trick works, you just have to substitute the file names in the path. 


    DVD studio pro is acting funky, will see how it does after updates.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    greg32 wrote:


    The terminal trick works, you just have to substitute the file names in the path.


    You mean, like these:



    DVD Studio Pro Content

    $ sudo installer -package /Volumes/DVD\ Studio\ Pro\ Content/Installer/DVDStudioProContent.mpkg/ -target /

    Motion Content
    $ sudo installer -package /Volumes/Motion\ Content/Installer/MotionContent.mpkg/ -target /

    Audio Content 1
    $ sudo installer -package /Volumes/Audio\ Content\ 1/Installer/AudioContentforSoundtrackPro.mpkg/ -target /

    Audio Content 2
    $ sudo installer -package /Volumes/Audio\ Content\ 2/Installer/AudioContentforSoundtrackPro2.pkg/ -target /
    $ sudo installer -package /Volumes/Audio\ Content\ 2/Installer/AudioContentforSoundtrackPro3.pkg/ -target /

    Audio Content 3
    $ sudo installer -package /Volumes/Audio\ Content\ 3/Installer/AudioContentforSoundtrackPro5.pkg/ -target /
    $ sudo installer -package /Volumes/Audio\ Content\ 3/Installer/AudioContentforSoundtrackPro7.pkg/ -target /

    LiveType Media 1
    $ sudo installer -package /Volumes/LiveType\ Media\ 1/Installer/LiveTypeMedia1.mpkg/ -target /
    $ sudo installer -package /Volumes/LiveType\ Media\ 1/Installer/LiveTypeMedia1A.pkg/ -target /
    $ sudo installer -package /Volumes/LiveType\ Media\ 1/Installer/LiveTypeMedia1B.pkg/ -target /

    LiveType Media 2
    $ sudo installer -package /Volumes/LiveType\ Media\ 2/Installer/LiveTypeMedia2A.pkg/ -target /


  • Johntr18 Level 1 Level 1 (0 points)

    Hi Michael,

    Something I don't understand: FCstudio has 9 disks. Terminal installed 01 disk (installation disk) by itself. What about the other disks?


    Final Cut Pro is doing fine. I haven't been able to try all other programs but SoundTrack and DVD StudioPro showed a message like "some of the items of the project will not be properly imported." every time I opened an old project. I continued anyway. The file appeared to be fine regardless. I saved that project and opened it again, I didn't get that message anymore.


    One more thing: I didn't type the dollar/money symbol ($) from your instruction line  in. I did try, but Terminal kicked me out.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    Yes, I should have left out the "$" sign.  It is merely the Terminal prompt character.


    I posted the list above, for most of the other discs.  Try these and let me know if any are still missing instructions.

  • greg32 Level 1 Level 1 (0 points)


    All the other disks can be installed after you install the Main FCP disk. Each disk has an install package in it that works. The only discs that don't are the LiveType content discs.  You have to use same method MichaelLAX described just with a slight modification.

    1. put the LiveType content disc1 in and in the terminal use:


    $ sudo installer -package /Volumes/LiveType\ Media\ 1/Installer/LiveTypeMedia1.mpkg/ -target /


    2.Once install is successful swap in the second LiveType content disc and use:

    $ sudo installer -package /Volumes/LiveType\ Media\ 2/Installer/LiveTypeMedia2A.pkg/ -target /



  • tedp1 Level 1 Level 1 (0 points)

    Hey guys,

    Just got a Macbook Pro a couple weeks ago and I'm trying to install FCS 1 with Final Cut 5, will this work for this version?


    Also, for the FC users in this thread-would it be worth it just to upgrade to FCS 3 or skip that and go onto FCPX?





  • wendy woo Level 1 Level 1 (0 points)

    to all in this thread, I have been having all kinds of issues transitioning from my mac pro to my new imac and when I tried to reinstall my Final Cut Studio 2 and got the error code I was about to scream.   I looked for and found your solution, and so far so good.  Oddly, only the FCS install disk had to be installed using the terminal.  the other disks are being loaded normally.  I am just glad I didn't have to buy another FCS program. 


    thanks, this has been a great help.

Previous 1 2 Next