8 Replies Latest reply: Feb 25, 2013 1:00 AM by egocomplex
egocomplex Level 1 Level 1 (0 points)

Hi all,


Sylenth was previously working fine until I installed 9.1.8 update moments ago. My apology if my explaination is rather confusing but this is what I'm currently facing.


I'm on 64bit logic and trying to load Sylenth, this window pops up.

Screen Shot 2013-02-20 at 12.19.40 AM.png


Sylenth eventually shows up after clicking it but logic is now being overlapped by the 32-bit Audio Unit Bridge application, restricting me to audition Sylenth with the Capslock keyboard. Notice that my top status bar (next to Apple Icon) has 32-bit Audio Unit Bridge as active window now? Disallowing me to play the Capslock keyboard.

Screen Shot 2013-02-20 at 1.43.11 AM.png



So, I cannot play Capslock keyboard when I have Sylenth as active window and vice versa. Is there a way I could go around it ?


Thanks a bunch in advance.

MacBook Pro, OS X Mountain Lion (10.8.2), 2.6 GHz Core i7, 8 GB RAM
  • freevito Level 2 Level 2 (290 points)

    As far as I can tell, Sylenth is a 32-bit instrument, not a 64-bit instrument. If you're running Logic in 64-bit mode, the only way you can use Sylenth is via the 32-bit Audio Unit Bridge.


    When I run a 32-bit plugin in Logic Pro in 64-bit mode, I can preview instruments with my MIDI keyboard controller, or with the Capslock keyboard in Logic. I don't have Sylenth, or Logic 9.1.8, or Mountain Lion (on purpose!), so I can't duplicate the condition you're reporting (assuming I've understood your post correctly). But with any 32-bit plugin I own and use via the 32-Bit Audio Unit Bridge in Logic Pro running in 64-bit mode, I can use either the MIDI keyboard controller or Logic's Capslock keyboard. I am not restricted to using only the Capslock keyboard, nor does the 32-bit Audio Unit Bridge render the Capslock keyboard non-functional. It works exactly as it should.


    It might be that your problem is with Logic 9.1.8. It has known bugs with certain plugins. I was unable to get any of my EastWest Quantum Leap plugins to validate under Logic 9.1.8, and I had to revert to 9.1.7. (I'm running Snow Leopard v10.6.8. and 9.1.7 is extremely stable and reliable in that system.)


    If you need to revert to Logic 9.1.7, here's how to do it: https://discussions.apple.com/thread/4551179?tstart=0

  • egocomplex Level 1 Level 1 (0 points)

    Hi freevito,


    Thanks for the reply !


    Had a peep at your discussion, successfully downgraded to 9.1.7. Bad news is, it is still the same.


    I shall search for more solution. Thanks again freevito !

  • freevito Level 2 Level 2 (290 points)

    Sorry I couldn't be of more help, egocomplex. With an application as complex as Logic Pro and so many other variables (system version, platform, plugins,...etc.), it's tough to diagnose a problem without a hands-on session.


    You might try sending a support query to Sylenth's developer. Also, check the forums at KVRaudio.com for others who might have experienced similar problems and found a workaround or a solution. Good luck!

  • egocomplex Level 1 Level 1 (0 points)

    Many thanks again freevito ! Have a great day ahead !

  • Eriksimon Level 6 Level 6 (11,990 points)

    Judging from your screenshot, you are in Solo mode. Is that intentional? What happens if you disengage Solo mode (just hit "s")?

    Also: do you have Sylenths' track selected?

  • egocomplex Level 1 Level 1 (0 points)

    Hi Eriksimon,


    Thanks for the response.


    The Solo Mode was accidental. I've tried disengaging it too. And yes, the respective Sylenth track was selected because I only had one track on Arrange window.


    Any idea? =)

  • Eriksimon Level 6 Level 6 (11,990 points)

    Your problem is you cannot use capslock to play Sylenth whilst tweaking its' parameters? Really the best solution is to get a real MIDI controller (much snappier MIDI respons too - it is  not really possible to play music with the CLK.) It does work when in the Bridge - I just tested that.

    What you could also very simply do, is open Logic in 32-bit mode, so there's no bridge at all.

    Top item on this page: http://support.apple.com/kb/HT3989


    So: either go to 32 bit mode, or get a MIDI controller.

  • egocomplex Level 1 Level 1 (0 points)

    Thank you again for the speedy response.


    I finally understood how Logic works with the 32bit bridge now. Yes you're right, having a MIDI controller definitely solves the problem. This problem only bugs me because I'm on mobile most of the time. Well, guess I'm out of luck at the moment =)