Previous 1 2 Next 17 Replies Latest reply: Feb 27, 2013 9:54 AM by Hz_UK
Hz_UK Level 1 Level 1 (0 points)

Hello,

 

I attempted to boot my mac up the other day and was given a 'prohibited' sign, so I re-booted into safe mode.

 

Once booted, I received this message when I tried to insert a flash drive:

 

System extension cannot be used

 

The system extension /System/Library/Extension/IOstorageFamily.kext was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update.

 

I followed advice given on another thread and replaced the extension with a time machine back-up.

 

The error message went away and I could use my flash drive

 

I then turned off my Mac, rebooted and was given the prohibited sign again.

 

I then tried to enter safe mode and it went so far and ground to a halt.

 

I tried over and over, but with no luck.

 

I zapped the NVRAM, reset the SMU, tried in single user mode, etc, as advised on another thread.

 

I did, once,  get past the safe mode task bar and got to a grey screen with an apple logo, but it remained in that state for over 20 minutes, so I rebooted and was back to square one again.

 

I couldn't find my original 'snow leopard' disc, so I ordered a new disc.

 

Try as I might, I cannot re-install snow leopard.  Thinking it might have been a hardware issue I have removed the HD and placed it into another Mac, ran a hardware test, etc, everything seemed fine.

 

I then thought it might have been the optical drive so using a FireWire cable, used the other mac's op drive, still no joy.

 

I bit the bullet, reformatted my HD, via the other mac, and tried again with no luck.

 

I am pretty sure it is not a hardware issue as such as I am typing this on the problem mac, as I have installed ubuntu precise pangolin, from disc, with no problems whatsoever.

 

I am now at a complete loss on how to proceed, as I desperately need to reinstall my mac OS, for my job as a graphic designer

 

Thanks in advance,

 

Hz.


Mac Pro, Mac OS X (10.6)
Previous 1 2 Next