9 Replies Latest reply: Feb 21, 2013 11:14 PM by baltwo
Charlie_Potatoes Level 1 Level 1 (0 points)

I've got a 2008 Macbook currently running Mountain Lion OS. I can move files to trash but delete and secure delete don't function. Whenever I try either method, I get the scrunchy paper sound effect, the window displaying the contents of the trash can disappears, however if I reopen the trashcan all the items remain there.

 

When I was running Leopard and Snow Leopard I had the same problem - no idea why it started, or how to solve it - but I used an app called Trash It which seemed to work.

 

When I installed Mountain Lion, my trash emptied as normal for a while, then the problem started again. Trash It worked again for a while, but now even Trash It fails to shift unwanted trash.

 

Any ideas:

 

What might be causing this issue?

How I can fix it?

Another app which might resolve it?

 

Many thanks in advance.


OS X Mountain Lion (10.8.2)
  • baltwo Level 9 Level 9 (62,210 points)
  • Linc Davis Level 10 Level 10 (173,705 points)

    Hold down the option key and empty the Trash. Any difference?

  • Charlie_Potatoes Level 1 Level 1 (0 points)

    No - tried that, still makes a noise, the trash window disappears but upon re-opening the contents are still there.

  • Charlie_Potatoes Level 1 Level 1 (0 points)

    Thanks for the tips - look useful. I'll try 'em later and let you know if it works or not.

  • mrbear235 Level 1 Level 1 (25 points)

    Move (not copy, move) the files to a USB stick, plug it in to another computer, and delete the unwanted files.

  • Linc Davis Level 10 Level 10 (173,705 points)

    Launch the Console application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.

     

    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select

    View Show Log List

    from the menu bar.

     

    Click the Clear Display icon in the toolbar. Then try the action that you're having trouble with again. Select any messages that appear in the Console window. Copy them to the Clipboard (command-C). Paste into a reply to this message (command-V).

    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.

    Please do not indiscriminately dump thousands of lines from the log into this discussion.

    Important: Some private information, such as your name, may appear in the log. Anonymize before posting.

  • Charlie_Potatoes Level 1 Level 1 (0 points)

    Log from trying to empty the trash:

     

    Thursday21/February/2013 18:07:08.045 _securityagent[378]: audit warning: soft /var/audit

    Thursday21/February/2013 18:07:08.047 _securityagent[376]: audit warning: allsoft

    Thursday21/February/2013 18:07:08.048 _securityagent[377]: audit warning: closefile /var/audit/20130221100416.20130221100708

     

    Log from trying to secure empty the trash:

     

    Thursday21/February/2013 18:08:00.674 quicklookd[386]: ImageIO: CGImageReadSessionGetCachedImageBlockData *** CGImageReadSessionGetCachedImageBlockData: readSession [0x7f9c5143a840] has bad readRef [0x7f9c514354a0]

    Thursday21/February/2013 18:08:36.782 _securityagent[396]: audit warning: closefile /var/audit/20130221100708.20130221100836

    Thursday21/February/2013 18:08:36.787 _securityagent[395]: audit warning: soft /var/audit

    Thursday21/February/2013 18:08:36.787 _securityagent[397]: audit warning: allsoft

     

    Log from trying to empty the trash with TrashIt:

     

     

    Thursday21/February/2013 18:09:28.801 coreservicesd[63]: Application App:"Trash It!.app" [ 0x0/0x34034]  @ 0x0x7ffafac83f80 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x35035:) ), so denying.

    Thursday21/February/2013 18:09:28.801 WindowServer[73]: [cps/setfront] Failed setting the front application to Trash It!.app, psn 0x0-0x34034, securitySessionID=0x186a4, err=-13066

    Thursday21/February/2013 18:09:28.819 authexec[425]: executing /System/Library/ScriptingAdditions/StandardAdditions.osax/Contents/MacOS/uid

    Thursday21/February/2013 18:09:28.839 sudo[425]:     root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/rm -fR /.Trashes/* /Users/myname/.Trashes/* /Users/my name/.Trash

     

    myname = not my real name

  • Charlie_Potatoes Level 1 Level 1 (0 points)

    I used the empty and re-create an account's Trash from the FAQ section. It involved a lot of manual file deleting, but it worked. Trash appears to be functioning normally now. Fingers crossed it stays that way. Cheers for the tip.

  • baltwo Level 9 Level 9 (62,210 points)

    thumbsup.gif