7 Replies Latest reply: Jan 11, 2014 8:31 PM by Mialbry
Tullier1 Level 1 (0 points)

My Apple TV is not responding to my remote control.

AppleTV 2
  • julesnewtoMac Level 4 (1,245 points)

    Tullier1, did it used to work?  Have you checked battery?  Does the light blink when you press the remote?



  • Skwog Level 1 (0 points)

    For a little while now, I've been having the following issues with my Apple TV remotes on two Apple TV devices:


    1. Pressing a button on the remote, there is no response from the Apple TV, the front light does NOT blink and nothing changes on screen.
    2. Without moving the remote, pressing the same button repeatedly (any button), after several presses and a couple of seconds have elapsed, the Apple TV front light blinks, but still NO CHANGES on screen.
    3. After the light blinks at least once, wait for another second, then press the same button on the remote and suddenly the Apple TV will respond as expected.


    Wondering if this is related to the last firmware update?

  • pippin12 Level 1 (0 points)

    I am having the same problem, Have you had any success?

  • waz317 Level 1 (0 points)

    hmm... having the same problem with my remote...


    My remote doesn't work but I've found that unplugging and replugging the power cable powers up the Apple TV.  The remote still doesn't work but my ipad could still link to the Apple TV so we could watch a movie on the TV that was playing on my iPad etc.

  • owenslr Level 1 (0 points)

    waz317, were you able to determine the issue? NEVER had any issues with mine until today when I tried to unplug, both power/usb and I've changed the battery in the remote, but the Apple TV just displays my screensaver photos, iPhone and iPad remotes do NOT link either, all the above used to work fine.


  • Skwog Level 1 (0 points)

    So mixed results for me.


    After replacing the CR 2032 3V batteries in my Apple TV remote with newly purchased batteries of the same model, my Apple TV seems to be mostly responsive again.  It would be easy to mistakenly buy the much less expensive 2025 batteries which are the same size and look identical, not sure if that would have reduce performance of the remote in any way with respect to this issue.


    Certainly it's much better, but there are still times when it seems to get hung up for a while, almost like it needs to wait a minute while it clears some buffer somewhere.  There are still times when clicking the Menu button takes too long for the device to go up a level in the menu system.  It feels like the software still has some short comings around garbage collection.


    owenslr, your device may be suffering from the same issue as mine but it could also be a different issue, or both.  It sounds more fundamental.  Does the light blink on the Apple TV at all when you press buttons on the remote?

  • Mialbry Level 1 (0 points)

    Restored, changed battery and rebooted...still not responding...any suggestions?