1 Reply Latest reply: Sep 24, 2013 2:30 AM by wforkel
wforkel Level 1 (0 points)

I have problems recording audio in Quicktime using a multichannel audio interface. I tried two firewire interfaces, an Apogee Ensemble and the RME Fireface. Both are supported by core audio and work as expected with any audio sequencer such as Garage band, Logic, Studio One etc. However, both show the same strange behavior in Quicktime 10.2 and as well in iMovie and FCPx:



First, i selected interface channels 1 / 2 in the audio-midi-settings window as the stereo input source. In the quicktime audio recording window, I select the audio interface (fireface or ensemble) as the audio source. I expected that the recorded audio would be stereo. However, regardless of these settings, the recording is always mono. Actually quicktime records only channel 1 and ignores all other channels. This might be a bug in Quicktime with regard to the handling of multichannel interfaces. The same bug occurs in Final Cut Pro X and iMovie, which seem to use the same audio engine as Quicktime. However, Garage band and Logic do not show the problem.



It does also not seem to occur with simple stereo interfaces. I tried a Logitech C920 webcam with a built-in stereo microphone and a Zoom Q2HD recorder used in stereo USB microphone mode. In both cases, the recordings in FCPx are 2 channel stereo as it should be. Thus the problem is specific for multichannel interfaces.


Can anybody reproduce or explain this behaviour?



I am using OS X Mountain Lion (10.8.2), MacBook Pro 15 Retina 2.3 GHz.


Regards, Werner

Final Cut Pro X, OS X Mountain Lion (10.8.2), MacBook Pro 15 Retina 2.3 GHz
  • wforkel Level 1 (0 points)

    It seems that apple has reacted to this bug report without notice. Recently I tried it once more with quicktime and an apogee ensemble interface. Surprisingly, the problem did not occur anymore. I have not tested it with iMovie and FCPX yet.


    The sad side of Apples support strategy is that I spent time and money searching for a workaround without knowing that Apple had removed the bug in the meantime.