Previous 1 2 Next 20 Replies Latest reply: Feb 23, 2013 10:50 PM by MlchaelLAX
CarlNug Level 1 Level 1

Hello ive recently sent of my mac book pro for repair and it has come back with Lion on it i know its an upgrade but none of my games will run on lion so the upgrade was unwanted what can be done because i want snow leopard back. Sods law i have lost my os disc someone in my house has moved them and i cant find them. any help will be very greatful
Carl.


MacBook Pro
Solved by Klaus1 on Feb 21, 2013 7:32 AM Solved
Reply by BGreg on Feb 21, 2013 6:28 AM Helpful

If whoever did the repair can't reinstall OS X 10.6 Snow Leopard, and you don't have a backup, you can buy a new DVD of Snow Leopard from the Apple online store. Either call them (in the US it's 800-MY-APPLE) or you can order online too. That doesn't come with the iLife applications, however.

 

I have a dual boot system with OS X 10.6 Snow Leopard on one partition and OS X 10.7 Lion on the other. That allows me to still use some PowerPC-based programs that will not run under Lion. 

Reply by BGreg on Feb 21, 2013 7:27 AM Helpful

Call the online Apple store at0800 048 0408 . It costs $20 in the US which should be around 13£. I did read somewhere that if the online Apple store in UK doesn't have it, to call Apple Support.

All replies

  • BGreg Level 6 Level 6

    If whoever did the repair can't reinstall OS X 10.6 Snow Leopard, and you don't have a backup, you can buy a new DVD of Snow Leopard from the Apple online store. Either call them (in the US it's 800-MY-APPLE) or you can order online too. That doesn't come with the iLife applications, however.

     

    I have a dual boot system with OS X 10.6 Snow Leopard on one partition and OS X 10.7 Lion on the other. That allows me to still use some PowerPC-based programs that will not run under Lion. 

  • CarlNug Level 1 Level 1

    BGreg,

     

     

    Thanks for the help ill just rebuy the dvd do you know how much this will cost and can i buy in the UK?

  • BGreg Level 6 Level 6

    Call the online Apple store at0800 048 0408 . It costs $20 in the US which should be around 13£. I did read somewhere that if the online Apple store in UK doesn't have it, to call Apple Support.

  • Klaus1 Level 8 Level 8
  • CarlNug Level 1 Level 1

    Thank you both ill buy a new disk

  • ds store Level 7 Level 7

    CarlNug wrote:

     

    Thank you both ill buy a new disk

     

    Hold on a bit.

     

    Download the free MacTracker and do a About This Mac > More Information and punch into MacTracker the Mac's model like "Macbook Pro 2,1" for instance.

     

    If the operating system that came originally with the machines says 10.6.3 or later, then the 10.6.3 White Snow Leopard retail disk you were instructed to purchase will NOT work on that machine.

     

    Any Mac that had 10.6.3 - 10.6.8 originally installed on the machine needs 10.6 MACHINE SPECIFIC INSTALL DISKS, you have to call Apple to order them.

     

    It's because the hardware drivers for that machine are not on the 10.6.3 white retail disk.

     

    Call Apple to confirm before you buy the wrong disk (you can resell it on eBay fast)

     

     

     

    Here is how to revert that machine back to Snow Leopard, it's not easy but it's possible because most of your files haven't been altered by 10.7 versions of the programs.

     

    How to revert your Mac to Snow Leopard

     

     

    You should seriously file a complaint with Apple for them altering your software, all your PPC games/software wont' run in 10.7+

  • MlchaelLAX Level 4 Level 4

    If you are unable to restore Snow Leopard, consider Installing Snow Leopard (with Rosetta) into Parallels in Lion.

    :Scrabble in Lion.jpg

                                  [click on image to enlarge]

     

    NOTE:  Computer games with complex, 3D or fast motion graphics make not work well or at all in virtualization.

  • CarlNug Level 1 Level 1

    Ok ive got that mac tracker program and it says i have two this are :

     

       Macbook Pro (15-inch, Early 2011)
       Macbook Pro (15-inch, Late  2011)

     

    any ideas what disc ill need or if that one will work?
      Also i will be complaining!

     

     

     

    Much thanks for this help.

  • ds store Level 7 Level 7

    CarlNug wrote:

     

    Ok ive got that mac tracker program and it says i have two this are :

     

       Macbook Pro (15-inch, Early 2011)

     

    any ideas what disc ill need or if that one will work?

     

     

    You have the 15" Early 2011 and it came with Snow Leopard 10.6.7

     

    You need the 10.6.7 machine specific dark disks, these come with free iLife suite also.

     

     

    Screen shot 2013-02-22 at 12.48.00 PM.jpg

     

    You will have to call Apple and order these disks, your copy is defective and you need replacements, do not mention your machine has 10.7, insist they send you the 10.6.7 disks, not the 10.6.3 retail disks.

     

    The 10.6.3 white retail version will not work (at least not without considerable work) and don't include the free iLife.

     

     

     

     

    Trying to virtualize 10.6 in 10.7+ it's slow for games and it's also LOT of effort to get it to work, Apple is going after virtual machine companies to prevent it. So it works, then a update later then it may not. Since your machine came with 10.6.7, the disk and reverting the machine is the best method.

     

    How to revert your Mac to Snow Leopard

  • MlchaelLAX Level 4 Level 4

    ds store wrote:

     

     

    Trying to virtualize 10.6 in 10.7+ it's slow for games and it's also LOT of effort to get it to work, Apple is going after virtual machine companies to prevent it. So it works, then a update later then it may not. Since your machine came with 10.6.7, the disk and reverting the machine is the best method.

     

     

    With regard to your cautionary note: the VMWare Fusion Snow Leopard patch gets broken each time Fusion is updated. 

     

    My method for installing Snow Leopard into Parallels has worked flawlessly since the introduction of Parallels 7 and each update through and including version 8 since!  "Install once; works continuously thereafter!"

     

    My instruction set may look like a "lot of work" but it is written for the lowest, common denominator installer, and hence the instructions are well spelled out.

     

    With Snow Leopard Server going for as low as $51 on eBay recently, it takes virtually NO work to install into Parallels or Fusion.

     

    I think even you would be surprised by the speed achieved by Parallels with today's modern, fast CPUs; especially compared to running the games on original PowerPC CPU architecture.

  • ds store Level 7 Level 7

    Thanks for your great assistance on getting 10.6 client running in Parallels, it's really well appreciated.

     

     

    I think the OP has 3D PPC games, which will require 10.6 running natively, unless they are fine with a 1/5 drop in fps.

     

     

    Perhaps like many of us, they just don't like Lion.

     

     

    https://www.adobe.com/downloads/cs2_downloads/index.html

     

     

    And there is no Scrabble for the Lions, they said "bye" since the PPC switch.

  • MlchaelLAX Level 4 Level 4

    ds store wrote:

     

    And there is no Scrabble for the Lions, they said "bye" since the PPC switch.

     

    Most of my post was for your general information; not necessarily for the OP.

     

    Surely you noticed Scrabble running on my Lion MacBook Pro: ?  So, I am confused by your post...

     

    Scrabble in Lion.jpg

     

    PS: I downloaded CS2 for free, before the new and confusing notice was attached to that page.

     

    PPS: Do you have the non-specific, retail 10.6.8 Install DVD that seems to be available?  I have not tried it yet...

  • seventy one Level 6 Level 6
    expertise.peripherals
    Peripherals

    Hello MichaelLAX,

     

    Looks a good Scrabble app ... where did you get it?

     

    Regards,  71.

Previous 1 2 Next