6 Replies Latest reply: Feb 21, 2013 5:44 PM by Randall White
Randall White Level 1 (5 points)

I used to be able to add Bookmark Folders within BookmarksMenu via Show All Bookmarks



Now when I add a new folder, it shows in the Bookmark Menu's window but not in regular browser window

MacBook Pro, OS X Mountain Lion (10.8.2), 13" MacBookPro8,1 - 2.7 GHz
  • Linc Davis Level 10 (192,431 points)

    Where do you expect to see the folder -- in the Bookmarks menu or in the Bookmarks bar at the top of a browser window? If you expect to see it in the bar, you have to add it to Bookmarks Bar in the Bookmarks window.

  • Randall White Level 1 (5 points)



    I think I specified "Menu" twice.

  • Linc Davis Level 10 (192,431 points)

    I think I specified "Menu" twice.


    And I think I've answered questions on this site a few thousand times from people who specified something different from what they meant. Before I use some of my spare time to try to help you, I want to make sure I know exactly what the problem is. Otherwise I'd rather do something else. If that's what you'd prefer, just say so.


    So you add a folder, let's say at the top level of the Bookmarks menu. You then pull down the menu and the folder is not there. Is that correct? If so, when you close and reopen the All Bookmarks window, is the folder still there?

  • Randall White Level 1 (5 points)



    What I didn't make really clear is that I found it easiest to manage bookmark folders in the "Show All Bookmarks" (SAB) function.


    When I get all hot on a subject that I'm researching say like "BMW" I select SAB from the Safari Menue and will add a folder somewhere close to where I want it and rename it. I drag that new folder to where I actually want it and start adding new folders for subheadings within those folders (i.e. "E39" "E28" yada yada ya).


    I've been doing this for years and it worked fairly well. Now, for about six months this is what happens.


    I add a folder or a sub in the SAB window and the folder appears there like before, but when I return to a regular browser window the new folder doesn't appear. And I can't find it when I try to add a page ( cmd-D ).


    However, when I go back to the SAB window again. The new folders that I made are still there, even afer quit, restart, rebuild permissions, reinstall OS. All the folders I added for the last six months are still there, but I can't add to them.


    So the answer is "Yes" and "No"


    Thanks for your precious time,



  • Linc Davis Level 10 (192,431 points)

    From the Safari menu bar, select


    Safari Preferences Extensions


    If any extensions are installed, disable them and test. If there's no change, proceed as below.


    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Randall White Level 1 (5 points)



    You're not going to like this…


    I was actually interested in the rest of the steps — really I was — and I didn't follow your initial instructions exactly. I read "…log in as Guest…" and kinda ignored everything else. Once I got the thing logged in I logged into my debugging account — thinking that was OK — and returned to this page to read the rest and saw that I wasn't good at following instructions…


    Anywayz, I decided to run that first test anyhow. And the SAB function worked and added a new folder "Rockerfeller's Faith" which showed up in the browser.


    I logged back into my regular account and "Rockerfeller's Faith" wasn't there — like you said it shouldn't be. So I added that sub folder and — VIOLA! — it appeared in a regular browser window. Everything working as it should!


    Looks like we "whacked it up side the head" and gave it a really hot cup of tea. The other oddity was that all those mystery folders that I have been adding for the last six months (which weren't functional anywayz) dissappeared in both the SAB window and the browser. I added a few other new folders for fun and filled them with bookmars. Looks like woteveritwuz just split…


    Thanks for the test that turned out to be a tool,