Previous 1 2 Next 17 Replies Latest reply: Feb 22, 2013 9:39 PM by XENiCraft
XENiCraft Level 2 Level 2 (265 points)

Hello All

 

I have been having problems accessing iCloud.com as most of the text seems to be scrambled/glitched.

 

Screen Shot 2013-02-21 at 6.33.07 PM.png

An example of one email in my inbox:

Screen Shot 2013-02-21 at 6.33.01 PM.png

 

I get the messages fine in Mail.app, it seems only iCloud.com (not just mail in iCloud) is messed up.

I have never seen this anywhere else on my Mac. I am running 10.8.2 with Safari Version6.0.2 (8536.26.17)

Can anyone help?

 

Thanks in advance,

xeni

 

EDIT: I am also seeing this is some youtube embeds (the korean is meant to be there but the weird numbers and letters aren't.):

Screen Shot 2013-02-22 at 8.26.43 AM.png


iMac, OS X Mountain Lion (10.8.2)
  • Linc Davis Level 10 Level 10 (154,655 points)

    A few things might be causing this.

     

    From the Safari menu bar, select

      
    Safari Preferences Advanced
       
    and uncheck the box marked Never use font sizes smaller than...

  • XENiCraft Level 2 Level 2 (265 points)

    Hi Linc

     

    I have this box already unchecked but I checked to see if it made any difference and it didnt seem to have any effect.

     

    xeni

  • Linc Davis Level 10 Level 10 (154,655 points)

    Select

            

    Safari Preferences Extensions

         

    If any extensions are installed, disable them and test. If that doesn't help, continue.

     

    Back up all data.

    Launch the Font Book application and validate all fonts. You must select the fonts in order to validate them. See the built-in help and the support article linked below for instructions. If Font Book finds any issues, resolve them, then boot in safe mode* (by holding down the shift key at the startup chime) to rebuild the font caches. Boot again as usual and test.

    Mac 101: Font Book

    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode. In that case only, after running Font Book, launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Drag or copy — do not type — the following line into the Terminal window, then press return:

    sudo atsutil databases -remove

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. After running the command, reboot as usual.

  • XENiCraft Level 2 Level 2 (265 points)

    Linc,

     

    I have disabled and re-enabled extensions to no effect.

     

    I don't think it is a fonts issue because I have tried Firefox, Opera and Chrome and none of them produce the same results.

    It is just Safari. I have never seen this anywhere else on my system outside of Safari.

     

    I have thousands of fonts, and I use FontExplorer X Pro to validate them all when I install them, so I don't think using FontBook to validate all of them would do any good.

     

    If you still think that I should do this then I will.

     

    xeni

  • Linc Davis Level 10 Level 10 (154,655 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • XENiCraft Level 2 Level 2 (265 points)

    OK. It is localised to my user account. Will try above steps.

  • XENiCraft Level 2 Level 2 (265 points)

    Awesome! It works now thank you!

     

    Here's how:

    I shutdown and rebooted in safe mode with all peripherals disconnected and logged in and opened Safari to and navigated to iCloud. (Side note it took FOREVER to load the iCloud page as it kept doing a weird refresh thing for about 2 minutes then with every key stroke it did this a few times probably due to something not being available in Safemode...)

    The text appeared fine! So I logged out thinking that if it was indeed a problem with a startup item then I would have to go through a long tedious process of enabling and disbaling each one to see which triggered it but thank god I don't have to do that!

    It seems just the Safe boot fixed it.

     

    So thank you Linc!

    I should know to Safe Boot always when there's a problem but I wasn't thinking...

     

    Thanks again Linc!

    xeni.

  • XENiCraft Level 2 Level 2 (265 points)

    Hi Linc.

    'It seems as though the problem is back. iCloud displayed fine after the Safe boot and reboot but it is back to the scrambled form. And what's worse, I'm now seeing it in Reminders on the MacI have Notes, Mail, Calendars & Reminders, Find My Mac, Docs & Data, Back to My Mac and Contacts checked.

     

    Screen Shot 2013-02-22 at 9.47.58 PM.png

     

    Notes seems to be fine, Mail is fine, I only have Calendars & Reminders checked for the Remindrs, Contacts is fine.

    Would you recommend that I do the trial and error with startup items?

    Or maybe I should create a test account and add the iCloud account to that and see if that symptoms are replicated?

    This is so annoying!

     

    I am just going to start by backing up and repairing disk permissions etc etc and then doing the font book thing.

     

    xeni

  • Tom Gewecke Level 9 Level 9 (74,710 points)

    When you see numbers in the wrong place, it may be caused by the font Helvetica Fractions or something similar which replace Latin with fractions.  Try getting rid of that to see if it makes a difference, if you have it.

  • XENiCraft Level 2 Level 2 (265 points)

    I do not have Helvetica Fractions, I have already read up on that and it sin't affecting my entire system, just iCloud stuff.

  • Tom Gewecke Level 9 Level 9 (74,710 points)

    Do you have any fonts that replace Latin by fractions?  Such problems rarely affect everything.

  • XENiCraft Level 2 Level 2 (265 points)

    How would I check for that?

  • Tom Gewecke Level 9 Level 9 (74,710 points)

    In Character Viewer, look in the Font Variation pane for a selected latin character and see if you see fractions intead of the correct letter.

  • XENiCraft Level 2 Level 2 (265 points)

    I don't see any of those strange characters in the Font variation for Latin...

Previous 1 2 Next