6 Replies Latest reply: Jun 17, 2013 10:05 PM by dcmaccer
moh2o Level 1 (10 points)


Well besides the 3 finger backswipe not working very well, and tempermental at best. Safari has also not been able to load certain pages (my firefox does just fine) , it has also been suuuuperr slowwwww. And just in general not working well at all. In other words it's been crappy.


So, uh, whats up with Safari.


I already did a permissions repair, and a 'Safari Reset' (multiple times), finishing always with a clean restart of the machine.


I do have snow leopard still, as my os (10.6.8). I have a macbook pro, 7.1


So hey everybody whats up with Safari, anyone know how to fix this?

Do I need to uninstall Safari and reload it? Is that possible?


Please only answer if you really know what is going on with safari, thanks



MacBook Pro, Mac OS X (10.6.8), Aluminum Macbook pro 7.1
  • moh2o Level 1 (10 points)


  • moh2o Level 1 (10 points)

    Well I found the answer, at least it seems to work well and has repaired my Safari for now.

    I was looking at my 'User Tips' folder. (funny, I don't even know what it is, I've never looked at it before)


    And there I found this article by Carolyn Samit, a level 9 mac tutor here:



    'Help for trouble shooting the Safari .plist (prefrences)'

    -is the name of the tip here at apple discussions .


    Thanks Carolyn, you never really answered my question, but I found your answer by accident, and it worked!



    Take care


  • moh2o Level 1 (10 points)

    Well, it worked for about 2 days. It still is better than before, but now 3 finger swipe is acting tempermental. For instance, it works fine on all other websites, except craigslist. I can trick it into working by giving 2 quick 3 finger back swipes.

    Well hopefully it won't degrade to the state it was before, of having to do 3, 3 finger swipes to get it to respond.

    But , Firefox still plugging away, with no problems.

    , I'll keep you posted.

  • ryanfromoklahoma city Level 1 (0 points)

    Same problem for me in Mountain Lion. I just upgraded a few weeks ago. Good luck getting Apple to acknowledge this as "their fault."


    Sometimes they just randomly fix things like this without ever acknowledging that it affected their entire user base previously. For me, sometimes 3-finger swipes work, and sometimes they don't. I haven't identified what circumstances make the difference, but I am getting upset pretty consistently.


    Message was edited by: ryanfromoklahoma city

  • moh2o Level 1 (10 points)

    Yeah, I get no replies from any of the techs here. Everyone has usually always been friendly and cordial and helpful here. But , only silence regarding this issue.


    I may have thrown some people off when I stated in my original question, "Please only answer if you really know what is going on with safari, thanks ""


    Well the reason I said that is , sometimes I get people who say things like, "Do a permission repair" or, "Check your Prefrences for Trackpad."

    ,,,,,,Already did all that. Did that before I ever got on this forum, that stuff is like real basic protocols for me.

    I want to know what the heck is really going on,,,,,,just like you.


    Anyone else have a real clue?


    thanks, all 

  • dcmaccer Level 1 (0 points)

    My first post.  I too was searching and I did try a lot of posters' (good) solutions, but none of them worked for me.  For me, the solution was accidental and perhaps too simplistic, but it solved the problem in my case.


    Three-finger swipe was not going to other Safari pages as well as not going to other applications (such as EXCEL).  My solution: you have to make sure that the pages are fully expanded...at the top right corner (for example in Safari), there are 2 diagonally-positioned arrows and pointing away from each other...click on that to expand fully onto the screen.  Once I did that, I was able to do the 3-finger swipe and go to other Safari pages as well as other applications.


    Good luck!