13 Replies Latest reply: Feb 25, 2013 11:27 AM by BDAqua
snowman999 Level 1 (0 points)

I have Leopard 10.6 and a long time ago I partitioned my HD for Panther and Leopard. I erased my Panther version tonight which had 350gigs of space. The Leopard only has 150 gigs. After erasing Panther I went to partition the panther gigs to the Leopard. It won't let me.


ERASE and REPAIR DISK are not available to me for the Leopard disk space. Though when I tried to partition I was told the disk needs repair. It also gave instructions when "Erase & Repair Disk" are not available to try using the Install DVD.


I put in the INSTALL DVD and double clicked. It did nothing. It just restarted the computer and that's it.


What am I doing wrong? I would love to just give the gigs to Leopard without having to reinstall all my software. But, if I have to, I will. But, I can't it's not an option.



Final Cut Pro 6, Mac OS X (10.5.8)
  • BDAqua Level 10 (121,625 points)

    With the install Disc inserted, restart & hold Option key at bootup, see if it';s a boot choice.


    Tough without the Install disc, but some things to try...



    Does it boot to Single User Mode, CMD+s keys at bootup, if so try...



    /sbin/fsck -fy



    Repeat until it shows no errors fixed.



    (Space between fsck AND -fy important).



    Resolve startup issues and perform disk maintenance with Disk Utility and fsck...






    Just recently I ran into a problem when I tried to Verify my hard disk and when it tried to verify the catalog, it responded "Invalid sibling link." Repair Disk didn't work. I searched the web and Apple's site, and couldn't find anything useful except to buy DiskWarrior or reformat the drive. Knowing that OS X is built on Unix gave me a few clues on how to proceed. The solution is pretty simple:

              1.          Boot off the OS X CD (reboot, hold C while booting).

              2.          The installer will load up, go to Utilities in the menu and run Terminal.

              3.          Type df and look for the drive that has your Mac system mounted---you'll have to unmount this. On my MacBook Pro, it was /dev/disk0s2.

              4.          Type umount /dev/disk0s2, replacing disk0s2 with whatever disk your OS lives on.

              5.          Type fsck_hfs -r /dev/disk0s2. If you umounted the wrong thing, it will complain that you can't repair a mounted drive. Go back and umount the right thing and repeat this step.

    Just for fun, you might want to run another fsck_hfs on your disk (use the -f option because your drive is probably journaled). Hope this helps someone so they don't buy a program that's going to do pretty much what we did with fsck_hfs, and so they don't waste time searching for an answer to no avail. By the way, TechTool Deluxe (3.1.1) didn't find the Catalog problem for some reason (you'll have this on a CD if you have AppleCare), which is why I resorted to fsck.




  • snowman999 Level 1 (0 points)

    Thanks for this info.


    The only option that did anything was holding the Option key while rebooting with the Install DVD.


    A screen of  a circle arrow then a HD picture with Leopard under it and a next arrow appears.


    I can't do anything,but a clock is running.


    What do I do next?


    Thank You

  • BDAqua Level 10 (121,625 points)

    Whew, so it isn't seeing the Disc, what is the 2z691-****-A number on it?


    Did Single user boot not work at all?

  • snowman999 Level 1 (0 points)

    When holding down the Option with Disc in there is no number Just the items I mentioned above.


    When I tried your other ways a bunch of computer program text came up. But, the keyboard doesn't work to type anything.


    Is there a way I can just wipe the entire HD when it's like this? I have all the programs I need on disk so I can just redo everything.


    Thanks again for the help. I have a date with the Genuis Bar this Sunday. But, I'd like to try to do this myself.

  • BDAqua Level 10 (121,625 points)

    We're stuck without a bootable Install Disc... unless you know somebody with a bootable clone of say 10.6 on an external drive.

  • snowman999 Level 1 (0 points)

    I'm not the most computer literate person alive. But, I'm not an idiot either. I'm guessing what you're saying is because I have nothing with a usable 10.6 system available the computer won't turn on. Is that correct?


    The reason I'm asking is because I bought this HD years ago and there was nothing on it. What did I do then, that I can't do now?


    Thanks Again for your help.

  • BDAqua Level 10 (121,625 points)

    Great toask, but you had to have some kind of Install Disc, either your Optical drive isn't working, or it was some other Install Disk... or we have some other hardware problem that's hard to diagnose. Did you ever find the 2z691-****-A number on that Disc?

  • snowman999 Level 1 (0 points)

    I thought the 2z number was on the HD on the computer that's not working. I have the install disc and I've been  using it for the things you've been telling me to try. I have to use it on an external DVD player because the one on my G5 hasn't worked in years.


    The number on the Install Disc is 2z691-6178-A

  • BDAqua Level 10 (121,625 points)

    OK, that appears to be the Retail Leopard 10.5.1 Install Disc, should work.


    We need to see why it isn't finding that Disk to boot from, or se if the geniuos can help better hands on.

  • snowman999 Level 1 (0 points)

    Thanks for all your help. One last thing I'm going to try before tomorrow,maybe you can help.


    I bought a seagate internal HD. I removed the HD that doesn't work, put in the new HD, attached the cables. I put the INSTALL DVD in and turned on the computer. All I get is a flashing little mac symbol and question mark.


    I tried turning it on while holding down the option key and that didn't work.Neither did holding down the C and turning it on.


    Is there something else I can try?

  • BDAqua Level 10 (121,625 points)

    If you have another Mac with Firewire & a FW cable, put the Install Disc in the other Mac,  boot the Other Mac into Target mode...




    And boot this one with the option key.

  • snowman999 Level 1 (0 points)

    I went to the Genius Bar yesterday. Somehow I fried the original HD, the people there had no idea what was going on with it. It took 2 hours for them to get the new HD up and running. When the uploading was down to "about a minute" some little girl was a milimeter from pushing the off button. It's all good now.


    Thanks again for the help. It'sgreatly appreciated.

  • BDAqua Level 10 (121,625 points)

    Great to hear it's fixed, thanks for the report!