12 Replies Latest reply: Jul 3, 2013 7:25 AM by Docteur Maboule
evanbrown Level 1 (0 points)

Hi all

 

I am working on a Mac Mini running OS X 10.5.8.

 

I am not able to drag and drop files in Finder and copy and paste operations do not work.

 

I have read previous posts which state that the SECURITYSESSIONID environment variable being set can cause this problem.  The output of env in Terminal on this system indicates that it is indeed set.

 

My question is how do I unset SECURITYSESSIONID?  The posts that I have read indicate that it is set in ~/.MacOSX/environment.plist but I don't have this file on the user account on my system.

 

How can I remove SECURITYSESSIONID from the environment variables?

 

Any other thoughts and suggestions on this problem would be much appreciated.

 

Thanks.


Mac mini, Mac OS X (10.5.8)
  • BDAqua Level 10 (122,276 points)

    Apparently that file doesn't exist in 10.5.8 or earlier.

     

    Where are you trying to drag TO, or Paste?

     

    In Finder do a Get info on that folder/location, see if it's Locked or what rights you have.

  • evanbrown Level 1 (0 points)

    Thanks for the reply.

     

    I am not able to drag and drop files from and to anywhere in the Finder.  The icon is not picked up when I click and hold on the file although it is selected (highlighted).  Also Copy and Paste universally does not work in the Finder or in any running applications.

     

    I have seen a number of different solutions to this problem on the Internet but I'm wondering if anyone here can help with some suggestions as to the probable cause.

     

    Can you tell me where the SECURITYSESSIONID environment variable is set in 10.5.8?  Is it set automatically by loginwindow.app or is there an entry perhaps in .profile or somewhere else?

     

    Many thanks for your help.

  • BDAqua Level 10 (122,276 points)

    What is that variable set to?

     

    In 10.4.11 mine is SECURITYSESSIONID=a9f070 & no problems.

     

    To find out if it's system wide or user specific, try this...

     

    Open System Preferences>Accounts, unlock the lock, click on the little plus icon, make a new admin account, log out & into the new account.

     

    Does it work in the new account?

  • evanbrown Level 1 (0 points)

    I have solved the problem.

     

    It turns out that somehow my client had deleted the /tmp folder from the root of their hard disk. This caused drag-and-drop and copy and paste to stop working.

     

    I rectified the situation by recreating the symlink tmp pointing to /private/tmp.

     

    Everything now works as expected.

     

    Thanks to the responder in this thread for their help.

  • BDAqua Level 10 (122,276 points)

    Great work, thanks... I should've thought of that actually.

  • Docteur Maboule Level 1 (0 points)

    I have exactly the same problem and would like to try your solution.

     

    Can someone explain exactly how to "recreate the symlink tmp pointing to /private/tmp" ???

  • BDAqua Level 10 (122,276 points)

    Old directions here, but should work...

     

    http://support.apple.com/kb/TA21161?viewlocale=en_US

  • Docteur Maboule Level 1 (0 points)

    I ran the Disk Utility --> Repair permissions and then reboot

    but the problem is still there, and the Disk Utility log doesn't seem to have made any changes to the /tmp

     

    Any other way?

  • EvB Level 1 (0 points)

    Try this.

     

    Open a Terminal and type the following commands:

     

    cd /

    sudo rmdir tmp

    sudo ln -s tmp /private/tmp

     

    If your tmp directory is not already there then the second command will give an error - just proceed to the third command in this case.

     

    Once you have done this sequence, reboot the machine and see if your drag and drop is restored.

  • Docteur Maboule Level 1 (0 points)

    Goodness, that did not work either

    Am I going to have to re-install the whole OS?

    Any other idea?

  • EvB Level 1 (0 points)

    Have you tried booting the machine into safe mode to see if the drag and drop function works here?

     

    See here:

     

    http://support.apple.com/kb/ht1455

  • Docteur Maboule Level 1 (0 points)

    Yep, I've tried that too