Previous 1 2 Next 25 Replies Latest reply: Mar 17, 2013 7:06 AM by ChipDale
ChipDale Level 1 Level 1

After upgrade from OS 10.6.8 to 10.8.2, MacBookPro intermittently requires 'exit' and 'boot'

commands to exit startup script and finnish booting. So far 'exit' and 'boot' does the job but

I'm hoping for a permanent fix. Thanks! Jay


MacBook Pro, OS X Mountain Lion (10.8.2)
Solved by Eric Root on Mar 14, 2013 2:02 PM Solved
Only attempting to clarify - Are you looking at Login Items or Login Options or maybe both?
Reply by ChipDale on Mar 15, 2013 11:04 AM Helpful
Eric: You're right; I was looking at Login Options. Now, I've unchecked all three Login Items. In addition, on similar boards from early MountainLion upgrades back in July 2012, I discoveredadvice to NOT connect BLUETOOTH devices before power up. I'm trialing that now with my MagicMouse and Apple Wireless Keyboard; I should have mentioned those BLUETOOTH devices earlyin my discussion here; Sorry! Thanks, your guidance has led me to search Google for titles not found on my original post here.There's plenty of fundamental troubleshooting and maintenance information available out there.I'll progress slowly with any repair mechanism. I've been spoiled by more than three years ofsimple problems to solve since switching from Windows to Mac. Therein may lie the problem forMac newbies; we don't have much trouble to resolve so we relax and don't bother to use AppleTutorials. I'll get back to my habit of Scientic Method for user knowledge. It's been easy to belazy with my Apple products up to now.Jay
Reply by ChipDale on Mar 15, 2013 11:11 AM Helpful
Barney: Thanks for your patience. I'm sticking with simple resolution methods so far. Hard toimagine but just powering up without MagicMouse and Bluetooth Keyboard turned on seems tohave resolved my startup script issue. I can't be certain though because Eric's recommendationto uncheck Startup Items may also have helped. A Google search revealed beaucoup reportsof startup script issues after upgrade to Mountail Lion at last Summers release of the OS. Good discussion and leads from you both, Thanks!!

All replies

  • Barney-15E Level 8 Level 8

    First, try repairing the disk by booting into the Recovery HD (cmd-r on startup).

    If that doesn't help, try reinstalling the OS.

  • ChipDale Level 1 Level 1

    Thanks Barney! Recovery HD "Repair" was not available so I Verified Disk "This voume Mac OS X Base System appears to be OK" Next, I reinstalled OS 10.8.2 from a fresh download but the Startup Script still stopped and required 'exit' and 'boot' to finish startup.

    However, I noticed RESTART did not exhibit this problem, only STARTUP from Power Up. It's still intermittant so I'll keep investigating.

    Jay

  • ChipDale Level 1 Level 1

    Oh yeah! I forgot to mention that shut down, after a troubled Power Startup, limps to finish too. But, at least, it does finish shut down without user input.

    Jay

  • Barney-15E Level 8 Level 8

    ChipDale wrote:

     

    Thanks Barney! Recovery HD "Repair" was not available

    What does that mean?

    Could you boot into Recovery?

    If yes, could you run Disk Utility?

    If yes, did you select your hard drive boot volume (Macintosh HD if not changed)?

    If yes, was the Repair button grayed out on the First Aid tab?

  • ChipDale Level 1 Level 1

    Barney:

    - I did boot into Recovery, and, within Disk Utility, ran Verify Disk on my Mac HD.

    - Yes, the Repair button was greyed out.

    - I noticed Recovery showed my Mac HD and, apparently, the physical hardware with the Manufacturer's      Name. So, I ran Verify Disk on the Mfr's disk too. I expect they're one and the same because they were

       identical size. I have only one hard drive on this MacBookPro and am wirelessly connected to my Time

        Capsule for backup.

    Jay

  • Barney-15E Level 8 Level 8

    Did it find anything wrong with the disk when you verified?

     

    Try resetting PRAM by holding down cmd-opt-P-R during restart. Keep holding until you here the startup tone twice, then let go.

     

    Another thing to try is Safe Mode. Restart holding down the Shift key. It will run disk checks and clear some caches. You should see a progress bar while it runs the checks. It will boot to the login screen, so make sure you know your login password.

     

    I don't know why it was grayed out. Macintosh HD is the boot Volume. The manufacturer name/size is the physical device. Repairing each does different things. I don't know why it is grayed out, but maybe resetting PRAM will help.

  • ChipDale Level 1 Level 1

    Barney:

    - resetting PRAM executed OK

      - I booted to SafeMode OK; but didn't see a progress bar. Logged in OK

      - I opened Disk Util from Apps and ran:

           - Verify Disk Permissions; this revealed numerous errors

           - Disk Permissions Repair, completed OK

     

    I appreciate the guidance. I was on DOS, then Windows, from 1990 to 2009; then

    bought my first Mac, this MacBook Pro, in late '09. I'm beginning to recall

    directory/registry details from those DOS/Windows years. Choosing to repair

    a registry fault on this Mac was new to me; that's why I sought guidance.

     

    Interestingly, my 2011 iMac upgraded from Snow Leopard to Mountain Lion

    without faults. Until my MacBook Pro startup glitch, I'd experienced no faults

    of any kind with either Mac.

     

    I'll monitor startup/restart activity to see if 'Disk Permissions Repair' resolved

    failure to execute full startup without 'exit' & 'boot'.

     

    Jay

  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X
  • ChipDale Level 1 Level 1

    Thanks Eric!

    Good information that I've just finished reading. I'll continue to monitor for

    any startup issues; but I hope the Disk Permissions Repair did the trick.

     

    I'll inform you within several days.

     

    Jay

  • Barney-15E Level 8 Level 8

    With the permissions repaired, is the Repair Disk button available now from Disk utility in the Recovery HD?

     

    Also, you may see a lot of stuff when repairing permissions. Much of it is completely irrelevant and is not actually a problem. When you run it again, you will likely see many similarities as those things are not actual problems that need repair.

    It is quite possible that it did repair some stuff that fixed your problem, but I just want to warn you against freaking out if you repair permissions again, sometime, and see the same stuff over and over. Basically, the source Repair Permissions uses to check the permissions may not be correct for some files after updates. It flags them as being incorrect, but they are really ok and they don't actually get changed, despite what it says.

  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X

    Reference Barney-15E's post above:

     

    Disk Utility Repair Permissions You Can Safely Ignore

     

    Barney, after much hesitation about straying from the thread, did you fly in the F-15E?

  • Barney-15E Level 8 Level 8

    I flew in it. I was a Weapon Systems Officer (WSO).

  • ChipDale Level 1 Level 1

    Barney: After Permissions Repair, the Repair Disk is still greyed out in Disk Utility when I boot into Recovery HD.

     

    Since running Permissions Repair and Repair Disk from Disk Utility.app, I've had two instances of the hung boot and noticed, if I wait several seconds after entering 'exit', the boot completes. So, I was in error about the 'boot' entry; it's not needed. As always, after a boot requiring user input of 'exit' the Shut Down runs a short script too but requires no user input to finish.

     

    I'll continue to monitor for boot issues; and, beyond AutoUpdate, I select Software Update every day.

     

    Jay

  • Barney-15E Level 8 Level 8

    Do you have FileVault enabled?

Previous 1 2 Next