Previous 1 2 3 Next 88 Replies Latest reply: Sep 29, 2015 4:58 PM by LtotheK Branched to a new discussion.
medinaray Level 1 Level 1 (55 points)

Hello everyone! I haven't been here in a while because I just haven't had any Mac issues. Now I do.


I have a 1 TB WD external HD that won't mount. I connect it via firewire to an Old G4 Sawtooth running OS 10.5.8. My mac sees the drive, it just won't mount. I've also tried to mount it via USB, but again, my system sees the drive, but won't mount it. I inadvertantly disconnected the firewire cable, which I didn't realize for several hours. I reattached the cable, tried to mount it, and nothing. I ran disc repairs, and Disc Utility actually told me the drive was successfully repaired. Again I tried to remount it, but nothing. I repaired permissions, and this didn't work. I've tried different cables, and this doesn't work.


I don't have another Mac to connect it to, so I don't know if this would work. Here's where things get a little wierd, but interesting. I connected it to my PC laptop, and it mounted. Now, this is a drive that was formatted Mac OS Extended (Journaled) on my G4, so I have to use Mac Drive so my PC will recognize and mount The Drive. So My PC sees The Drive as Mac OS Extended, and mounts it. All files are in tact, and the drive runs normally. This is a music drive and it plays normally on my PC. Meanwhile, if I try connecting it back on My Mac, the name of The Drive randomly changes from 931.5 GB WD to 931.5 GB WD My Media Book. I believe My Media Book is the factory name of The Drive before OS formatting. The Volume name remains the same on my G4 each time I've tried to mount it.


I do have another identical drive that mounts from all the bus ports on my G4. Any ideas here? Can I get my Drive to begin mounting on my G4 again? Any and all answers are appreciated.

Sawtooth G4; 1.8 GHz Dual 7447A; Radeon 9800/128MB; 2GB Ram, Mac OS X (10.4.11), Seagate 200 & 500GB HD; WD 120GB HD; Lacie DVD±RW; 550 Watt PSU
  • BDAqua Level 10 Level 10 (121,165 points)

    Hi, I assume you were trying to mount it in Disk Utility by highlighting it & clicking on the Mount icon above?


    In Finder's Menu, select Go menu>Go to Folder, and go to "/volumes". (no quotes)


    Volumes is where an alias to your hard drive ("/" at boot) is placed at startup, and where all the "mount points" for auxiliary drives are created for you to access them. This folder is normally hidden from view.


    Does it show there?

  • medinaray Level 1 Level 1 (55 points)

    Hi BDAqua


    It does not show in the Volumes Folder. Disc Utility shows it, but I can't mount it.


    Can I mount it thru volumes folder?

  • BDAqua Level 10 Level 10 (121,165 points)

    I don't think you can do that, & my guess is the PC changed it somehow.


    Might try to mount it in Terminal, like the last post here...


  • medinaray Level 1 Level 1 (55 points)

    Hmm, interesting that you think the PC changed the drive. How could it change the directory, or mapping w/o initializing the drive, and wiping out all the data?


    I'm heading out for the day, so I can't try the terminal mount 'til later tonight. Perhaps that will work. Of course, I'm terminal ignorant, so unless someone tells me exactly how to write the command, I'm usually at a loss. But, I'm willing to try.


    The other option is to try mounting the drive on another Mac.


    Thanks for now BDAqua.

  • BDAqua Level 10 Level 10 (121,165 points)

    I'll try to help with terminal if you need it when you get back.

  • medinaray Level 1 Level 1 (55 points)

    I need a little help with the terminal command.


    I think I need to use this command: diskutil mountDisk MountPoint|DiskIdentifier|DeviceNode.


    I know the MountPoint is the Drive's Volume Name. In this case 1TB Music Drive. I think I found the DiskIdentifier thru Disk Utility, by highlighting the Volume name and clicking on Info. Disk Identifier is clearly at the top. But where do I find the DeviceNode? In Info under Device Tree there is a node@ with a number: is this it? I tried it in terminal w/o success.


    Also, should I just use the command mountDisk and omit diskutil? Not sure here. Or is there another command I should be using?



  • BDAqua Level 10 Level 10 (121,165 points)

    As I understand it there are two forms...


    diskutil mount disk0s1


    diskutil mountDisk "DriveName"

  • medinaray Level 1 Level 1 (55 points)



    I've tried the two ways you mention. All that happens when you type that into terminal is you are given a list of ways to mount or eject a disc with possible command forms....I think?


    It seems that the command I listed above is what will work. I just need to know where to find the device node, and how exactly to type the command.



  • medinaray Level 1 Level 1 (55 points)

    I've discovered in disc info thru terminal that the external hard drive that won't mount has Owners:  Disabled. All my other drives have Owners: Enabled. So when I enter the command to mount my hard drive thru terminal I'm told,  "permission denied." I've tried to enable ownership thru terminal, but I just don't know the right commands.


    So I'm wondering, if I can enable ownership for said drive, will I be able to mount it thru terminal? Can I enable ownership of of a hard drive that won't mount thru terminal?



  • BDAqua Level 10 Level 10 (121,165 points)

    Good work!


    Open Terminal and type these commands carefully with the spaces & change 320GB HD to the name of your drive.


    sudo chflags 0 "/volumes/320GB HD"

    sudo chown root "/volumes/320GB HD"

    sudo chmod 1775 "/volumes/320GB HD"

    sudo -k

  • medinaray Level 1 Level 1 (55 points)

    Hello again,


    And thank you for all your patience and help BDAqua.


    I typed in the first command: sudo chflags "/volumes/1TB Music Drive", and terminal tells me there is no such fule or directory.


    Just to remind you, Disk Utility sees the drive, and the volume name, and I can access info on the drive thru terminal. So I guess the question remains: can I enable ownership on a drive that won't mount, and isn't mounted?


    Thank you

  • medinaray Level 1 Level 1 (55 points)

    Two more things I've noticed thru Disk Utility information. First, the unmountable drive is not showing up in the IODeviceTree. All my other drives show up there. Second, and finally, the unmountable drive has Journaled:  No. Though it does show itself as Mac OS Extended (Journaled). All my other drives have Journaled:  Yes.

  • BDAqua Level 10 Level 10 (121,165 points)



    In Terminal, what does this command show?


    diskutil list


       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *596.2 GB disk0

       1:    Apple_partition_map                    31.5 KB   disk0s1

       2:             Apple_Boot                    128.0 MB  disk0s2

       3:             Apple_RAID                    596.0 GB  disk0s3


       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *596.2 GB disk1

       1:    Apple_partition_map                    31.5 KB   disk1s1

       2:             Apple_Boot                    128.0 MB  disk1s2

       3:             Apple_RAID                    596.0 GB  disk1s3


       #:                   type name               size      identifier

       0:              Apple_HFS CVBRaid0           *1.2 TB   disk2


       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *465.8 GB disk3

       1:    Apple_partition_map                    31.5 KB   disk3s1

       2:         Apple_Driver43                    28.0 KB   disk3s2

       3:         Apple_Driver43                    28.0 KB   disk3s3

       4:       Apple_Driver_ATA                    28.0 KB   disk3s4

       5:       Apple_Driver_ATA                    28.0 KB   disk3s5

       6:         Apple_FWDriver                    256.0 KB  disk3s6

       7:     Apple_Driver_IOKit                    256.0 KB  disk3s7

       8:          Apple_Patches                    256.0 KB  disk3s8

       9:              Apple_HFS Leo                167.3 GB  disk3s10

      10:              Apple_HFS Mac OS X Install DVD 9.0 GB    disk3s12

      11:              Apple_HFS LeoUPdate          167.3 GB  disk3s14

      12:              Apple_HFS TigerOS9           121.7 GB  disk3s16


       #:                   type name               size      identifier

       0:    CD_partition_scheme                    *754.2 MB disk4

       1:    Apple_partition_map                    31.5 KB   disk4s1s1

       2: Apple_partition_scheme                    656.7 MB  disk4s1

       3:              Apple_HFS Civilization III   632.6 MB  disk4s1s2


       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *40.0 MB  disk5

       1:    Apple_partition_map                    31.5 KB   disk5s1

       2:              Apple_HFS Chicken of the VNC 40.0 MB   disk5s2


  • medinaray Level 1 Level 1 (55 points)

    Terminal List. disk4 is the malfunctioning drive.


    Last login: Mon Feb 25 19:25:12 on ttys000

    raymond-medinas-power-mac-g4-agp-graphics:~ raymondmedina$ diskutil list


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     Apple_partition_scheme                        *111.8 Gi   disk0

       1:        Apple_partition_map                         31.5 Ki    disk0s1

       2:             Apple_Driver43                         28.0 Ki    disk0s2

       3:             Apple_Driver43                         28.0 Ki    disk0s3

       4:           Apple_Driver_ATA                         28.0 Ki    disk0s4

       5:           Apple_Driver_ATA                         28.0 Ki    disk0s5

       6:             Apple_FWDriver                         256.0 Ki   disk0s6

       7:         Apple_Driver_IOKit                         256.0 Ki   disk0s7

       8:              Apple_Patches                         256.0 Ki   disk0s8

       9:                  Apple_HFS Mac Leopard II          91.8 Gi    disk0s10

      10:                  Apple_HFS Mac Tiger               19.7 Gi    disk0s12


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     Apple_partition_scheme                        *186.3 Gi   disk1

       1:        Apple_partition_map                         31.5 Ki    disk1s1

       2:             Apple_Driver43                         28.0 Ki    disk1s2

       3:             Apple_Driver43                         28.0 Ki    disk1s3

       4:           Apple_Driver_ATA                         28.0 Ki    disk1s4

       5:           Apple_Driver_ATA                         28.0 Ki    disk1s5

       6:             Apple_FWDriver                         256.0 Ki   disk1s6

       7:         Apple_Driver_IOKit                         256.0 Ki   disk1s7

       8:              Apple_Patches                         256.0 Ki   disk1s8

       9:                  Apple_HFS Mac Leopard I           186.2 Gi   disk1s10


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     Apple_partition_scheme                        *465.8 Gi   disk2

       1:        Apple_partition_map                         31.5 Ki    disk2s1

       2:             Apple_Driver43                         28.0 Ki    disk2s2

       3:             Apple_Driver43                         28.0 Ki    disk2s3

       4:           Apple_Driver_ATA                         28.0 Ki    disk2s4

       5:           Apple_Driver_ATA                         28.0 Ki    disk2s5

       6:             Apple_FWDriver                         256.0 Ki   disk2s6

       7:         Apple_Driver_IOKit                         256.0 Ki   disk2s7

       8:              Apple_Patches                         256.0 Ki   disk2s8

       9:                  Apple_HFS 500 GB HD               465.6 Gi   disk2s10


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     Apple_partition_scheme                        *931.5 Gi   disk3

       1:        Apple_partition_map                         31.5 Ki    disk3s1

       2:             Apple_Driver43                         28.0 Ki    disk3s2

       3:             Apple_Driver43                         28.0 Ki    disk3s3

       4:           Apple_Driver_ATA                         28.0 Ki    disk3s4

       5:           Apple_Driver_ATA                         28.0 Ki    disk3s5

       6:             Apple_FWDriver                         256.0 Ki   disk3s6

       7:         Apple_Driver_IOKit                         256.0 Ki   disk3s7

       8:              Apple_Patches                         256.0 Ki   disk3s8

       9:                  Apple_HFS 1 TB Music Drive II     931.4 Gi   disk3s10


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     Apple_partition_scheme                        *931.5 Gi   disk4

       1:        Apple_partition_map                         31.5 Ki    disk4s1

       2:             Apple_Driver43                         28.0 Ki    disk4s2

       3:             Apple_Driver43                         28.0 Ki    disk4s3

       4:           Apple_Driver_ATA                         28.0 Ki    disk4s4

       5:           Apple_Driver_ATA                         28.0 Ki    disk4s5

       6:             Apple_FWDriver                         256.0 Ki   disk4s6

       7:         Apple_Driver_IOKit                         256.0 Ki   disk4s7

       8:              Apple_Patches                         256.0 Ki   disk4s8

       9:                  Apple_HFS 1TB Music Drive         931.4 Gi   disk4s10

    raymond-medinas-power-mac-g4-agp-graphics:~ raymondmedina$


    Terminal info on disk4s10.


    Last login: Mon Feb 25 22:22:41 on ttys000

    raymond-medinas-power-mac-g4-agp-graphics:~ raymondmedina$ diskutil info disk4s10

       Device Identifier:        disk4s10

       Device Node:              /dev/disk4s10

       Part Of Whole:            disk4

       Device / Media Name:      Apple_HFS_Untitled_1


       Volume Name:              1TB Music Drive

       Mount Point:             

       File System:              Journaled HFS+

       Owners:                   Disabled


       Partition Type:           Apple_HFS

       Bootable:                 Is bootable

       Media Type:               Generic

       Protocol:                 FireWire

       SMART Status:             Not Supported

       Volume UUID:              61A8EAFF-E1C9-3605-AF92-5A210E3C781A


       Total Size:               931.4 Gi (1000069726208 B) (1953261184 512-byte blocks)

       Free Space:               0.0 B (0 B) (0 512-byte blocks)


       Read Only:                No

       Ejectable:                Yes

       Whole:                    No

       Internal:                 No


    Disk Utility Info on 1TB Music Drive.


    Name : 1TB Music Drive
    Type : Volume


    Disk Identifier : disk4s10
    Mount Point : Not mounted
    File System : Mac OS Extended (Journaled)
    Connection Bus : FireWire
    Device Tree : IODeviceTree:fwx/node@90a9c5c29aa50b/sbp-2@c000
    Writable : Yes
    Universal Unique Identifier : 61A8EAFF-E1C9-3605-AF92-5A210E3C781A
    Capacity : 931.4 GB (1,000,069,726,208 Bytes)
    Owners Enabled : No
    Can Turn Owners Off : Yes
    Can Be Formatted : Yes
    Bootable : Yes
    Supports Journaling : Yes
    Journaled : No
    Disk Number : 4
    Partition Number : 10


    I've read that WD uses crappy chipsets in their external drives. I'm wondering if the chipset is suspect here? Just not sure. I did discover that I can clone the drive from my PC as an exact Mac OS Extended (Journaled) drive, and my Mac doesn't even know the difference. I've also read that I can initialize the drive, and reinsert the drivers, and the drive should function normally. Interesting, huh? Well, let me know what you come up with BDAqua. And again, many, many thanks.

Previous 1 2 3 Next