11 Replies Latest reply: Feb 27, 2013 7:47 PM by aaperry
toshikobe Level 1 (0 points)

I moved my house and subscribed to different Internet provider. Through Ethernet cable, I can connect to Internet. I'm setting up AirPort Express 802.11n (1st Generation). I had been using this one at previous home or at hotel with this PC without any problem. However, on this network at new home, I have problem. I reset to factory default. From Windows 7, AirPort Utility finds this AirPort Express (connected to cable modem by Ethernet). When I press "Manual Setup" or "Continue" on AirPort Utility, I get "Error -4" saying "An error occurred while trying to access the Apple wireless device. Make sure your network connection is valid and try again." So, I have no idea how to solve this issue, and wanted to get advise.

  • JoeMY Level 1 (120 points)

    After reset to factory default, can your Windows machine see the Express via wireless?  Configure from there as the WAN port is for the internet connection.  Cannot remember for sure if you can setup via the WAN port to a PC as I always set it up via wireless.

  • fredtheson Level 1 (0 points)

    I have the same problem. I bought two airport express (A1088). Whenever I try to configure them using Airport Admin Tool I receive the same "Error -4". It does not make a differnce whether I use LAN or Wifi connection.

  • edex67 Level 4 (3,250 points)

    Try rebooting, or waiting for Windows to ask you to make a firewall exception. This problem seems to be caused by the firewall blocking access to the Express. Alternatively, try using a Mac or iOS device if you have access to one. Configure wirelessly if possible as JoeMY has said, with the older Expresses (and Extremes) there can be problems configuring over Ethernet.

  • toshikobe Level 1 (0 points)

    > After reset to factory default, can your Windows machine see the Express via wireless? 


    Yes Windows sees AirPort Express, but cannot access to it to confiture.


    I tried connecting to AirPort Express via Ethernet cable and wireless. Both did not work.

  • toshikobe Level 1 (0 points)

    I rebooted this morning, and the problem remains the same. The odd thing is that this PC was accessing the AIrPort Express before, so nothing would be wrong on PC. When I moved to a different service provider, AirPort did not work.


    From iPhone, the utility try to find AirPort, but it cannot find one and shows message "No AirPort base stations have been found. AirPort Uitlity will continue searching", and never found one.

  • edex67 Level 4 (3,250 points)

    OK, then the AirPort must be at fault. If you have factory reset multiple times and the Express still doesn't work then it unfortunately looks like a hardware fault in the Express.

  • Lou1133 Level 1 (0 points)

    Hi, I received the same error and here is how I fixed it.


    Go to a XP computer and run the Airport program.  I configured my Airport orginally using an XP computer so when I tried to connect to the Airport using Win7 I recieved the Error 4. I installed from the CD on my XP desktop computer then connected my Airport to my network using the WAN port.  Was able to connect right away and had no problems running firmware updates and resets on the Airport.  Guess I'll have to maintain an XP box for future fixes.  Good Luck.

  • fredtheson Level 1 (0 points)

    - works -


    I have no idea why and how but right now I was able to connect to the airport express using the airport utility. I deleted and reinstalled the software and reset the device one last time. When I tried to connect windows firewall asked me for an exception (so good hint edex67). I confirmed and had access.


    All good. Thank you very much for your support and good luck with your device toshikobe.

  • Kakie33 Level 1 (0 points)



    I have a similar problem, except that the network is detected by my Toshiba (xp) but it still doesn't want to connect me to internet.  I tried to enter either the password key or the WPA - PSK but it gives me an error message:  "The network password needs to be 40 bits or 104 bits depending on your network configuration...".  On second try, it just didn't change a thing as far as password is concerned and still didn't connect me to internet.

    Is it an Airport problem or a PC one?


    My Airport was configured from my MacBook in the first place...  should I run the CD in the PC also?


    Thanks for your advises...  looking forward to read them

    Have a great day

  • toshikobe Level 1 (0 points)

    Solved as follows !!!


    I turned off both AirMac Express and Cable modem (StarHub in Singapore), turned on AirMac Express first, waited until my PC and iPhone are connected to, then turned on the cable modem. It simply worked.


    This may help you all.

  • aaperry Level 1 (0 points)

    In the Airport Utility Menu, try:


    File -> Configure Other


    password: public