6 Replies Latest reply: Jan 11, 2015 9:41 AM by fastway
Gonzalo Diaz00 Level 1 Level 1 (0 points)

I've been trying to connect to homesharing checking the following options:


Updated all my devices with 11.0.2

Turned On Homesharing from Itunes

Checked computers on Apple TV and Airplay

Check for firewalls but my firewall in my Mac is off.


What could be the issue? SOS...




AppleTV 2
  • Winston Churchill Level 10 Level 10 (91,920 points)

    Welcome to the Apple Community.


    The following article(s) may help you.


    Troubleshooting Homesharing

    Troubleshooting WiFi Networks

  • Gonzalo Diaz00 Level 1 Level 1 (0 points)

    Didnt work Winston. SOS!!!!!

  • KasperDanielHansen Level 1 Level 1 (0 points)

    I had the same issue, iTunes 11.02 on a fully updated Mountain Lion and Apple TV 3.  Airplay was working without problems, but I could not connect to my home share, despite the fact that it worked flawlessly before updating iTunes.


    However, restarting the apple tv manually (I believe with Settings -> General -> Restart)  solved the problem for me.

  • tuckermanfromwanstey Level 1 Level 1 (0 points)

    Hi Winston,


    I have read everything Apple has to say about Home Sharing problems until I have memorized most of it.  None of that (or the various other suggestions like turn on/off IPV6, restart everything, stand on your head and swear) have ever worked for me on Mavericks.


    However I recently stumbled across some comments about there being two ways to share in iTunes - and that one should use one or the other but not both. Using both sometimes apparently leads to conflicts. The two methods are 1) 'Share my library on my local network' in iTunes>Preferences>Sharing and 2) Home Sharing in iTunes File>Home Sharing. So I unchecked 'Share my library on my local network', quit iTunes, restarted my iMac and opened iTunes. I still wasn't able to wake my iMac from sleep with the Bonjour Sleep Proxy from the ATV until I then Reset the Apple TV - not Restart, but Reset and then update. That was a ten days ago and I am now able to reliably and consistently wake by iMac from sleep for Printer Sharing, Printopia from an iPad and with an Apple TV for music streaming. I'm convinced that it was the unchecking the 'Share my library on my local network' that did the trick as I haved simply Reset the ATV several times with no effect.  Do hope this helps someone else...

  • Anonymous user of Apple Level 1 Level 1 (0 points)

    Had the same problem and got this answer from Apple tech support;

    1. Go to system preferences>sharing.

    2. Chainge your computers name in the box at the top of the window to something OTHER THAN the default name.

    3. Restart Computer.

    4. After boot open iTunes.

    5. Go to Apple TV and see if it works.

  • fastway Level 1 Level 1 (0 points)

    Only thing that worked for me.

    Thanks a bunch.