3 Replies Latest reply: Apr 17, 2013 8:54 AM by Nealf
DHD47 Level 1 Level 1


I just installed a new Drobo5N NAS and find that projects and events in iMovie are not visible.  iMovie sees the NAS but the dreaded yellow triangle shows up and I cannot transfer projects to the NAS.  Aperture works fine.

I see lots of churn in this forum with this issue but everything appears to be a bit older and/or on Leopard . 

I see the "defaults write -app iMovie allowNV -bool true" trick which I may eventually try but thought I'd ask first in the event that folks have already figured this out.


I'm running Lion (10.8.2) and iMovie 11.


Thanks for any help



Late 2009 iMac, 10.8.2, Aper 3.4.1
  • DHD47 Level 1 Level 1

    Well, this is a first.  I may be answering my own question.  The "defaults write -app iMovie allowNV -bool true" trick mentioned above appears to work.  I can now see all my events and projects stored on the NAS and iMovie seems to work normally.  Trouble is:  I don't understand the fix nor whether I'll have to do this everytime I boot up or whether it will stop working in the future.  I found this with a simple Google search of the problem which always makes me nervous....


    Hope this helps someone else but I'm still interested in the "experts" take on this.

  • DHD47 Level 1 Level 1

    Some further information on the -bool true workaround I've reported as seeming to work.  It does NOT work.


    Using it does indeed allow iMovie to see the NAS and read and copy etc... projects and events to the NAS.  It seems to work normally...however....  I have lots of cases where I've made multiple projects from a single event.  In these cases iMovie will copy over the entire event for every single project which, of coarse, is eating my storage...  I tried copying the projects and events over to the NAS seperately from within iMovie and I also tried just copying the projects and then using Consolidate Media to bring over the events with the same results.


    More disturbing is the presense of a growing number of iMovie temp folders in both the events and project directories.  These are as large as the events themselves and appear to grow exponentially with use of iMovie.  I cannot get rid of them from within iMovie using delete.  I've been forced to disconnect the NAS from iMovie (disable the -bool true trick) and use finder to dump all the temp directories.  I still have a couple though that seem to have some magic "rights" attached to them that I cannot get rid off - still working on figuring that out.


    I have currently disabled the -bool true trick and have settled on using the NAS only as a backup storage system for all my events/projects.  I'll have to copy any projects/events that I want to work on to my local drive manually.


    Apple states that they do NOT support NAS drives with iMovie.  With the above experience I believe them.  I'll avoid ranting about how stupid this all seems .....

  • Nealf Level 1 Level 1
    Photos for Mac

    You are not alone. I am having similar problems with a Drobo 5N.