1 2 Previous Next 18 Replies Latest reply: Feb 25, 2013 8:40 PM by Asialimarco Go to original post
  • 15. Re: iMac doesn't start up
    WZZZ Level 6 Level 6 (12,215 points)

    If the drive is failing it may be determined to fail sooner or later, so this may not be a long term solution, and I'm not sure I would trust a drive that has been "reclaimed" this way. You don't want to do a simple erase and install. What you can try is first to reformat the drive from Disk Utility. Then, select Secure Erase>Options>One Pass. Then restore from TM.

     

    On formatting:

     

    http://pondini.org/OSX/DU1.html

     

    Secure Erase one pass

     

    http://pondini.org/OSX/DU2.html

     

    Then see if you can restore from your TM backup.

     

    http://pondini.org/TM/14.html

     

    Message was edited by: WZZZ

     

    Note: I haven't done this in a while, so don't remember if it's zero first then reformat or vice versa, but it wlll be clear when you do it.

  • 16. Re: iMac doesn't start up
    Linc Davis Level 10 Level 10 (117,790 points)

    Performed twice fsck -fy, always I/O error.

     

    The more you try to repair your failing, unrepairable drive, the less likely you are to be able to rescue the data.

  • 17. Re: iMac doesn't start up
    Jack Tomac Level 1 Level 1 (5 points)

    I experienced the same symptons as Asialimarco, on start up I got the Apple screen and then it went to a blank screen with the little circle turning and would never get out of it.  I did all that was suggested; Safe Mode got the same results as the original startup, running fsck from single user several times until I got the disk is ok message didn't change a thing, starting from recovery mode and running Disk Utilities as well as TechTools eDisk, which found issues, didn't do a thing.   Finally chose to re-install Mountain Lion and now things appear to be working correctly.  At least it booted up and I have everything.

  • 18. Re: iMac doesn't start up
    Asialimarco Level 1 Level 1 (5 points)

    Latest Update:

     

    after trying the fsck 5 or 6 time, i decided to stop that and tried to access to the drive as Davis suggested by the wirefire cable, by starting the imac in target mode, and linked to my macbook.

    The imac did started in Target mode, but there was no way for the macbook to see that partition.

     

    so i decided to forget about some files i didn't backup recently and tried a restore from the Recovery HD.

     

    started in recovery mode, restore from the external drive where my latest back time machine were stored.

     

    It tooked 7 hours but at the end the imac restarted normally. I tried to power it off and on again, seams fine.

     

    I'm almost sure the internal HDD is not anylonger trustable, so i'm thinking to replace it with a new one.

     

    After i restarted the imac the second time, i run disk utility, and during the verification i still get an error message about a node, the difference is that this time the report tells me that the node broken is not in use, but to try anyway to repair it by make the repair disk from the recovery HD.

     

    Well i didn't try it yet as it was already early morning and i had to go working, so i will try it once again this evening.

    If the node is not in use now, probably the repair disk utility will clean up (if not physical damaged) the problem.

     

    Anyway i will change that drive with a new one.

     

    when i bought the imac (early 2009) i had the snow leopard disk, but than i bought from app store on-line the osx Lion, which is not coming with the installation disk.

    If i restore the system on the new HDD, will i get also the partition for Recovery HD???

    if not, how to do it?

     

    thanks again to everybody for your help.

     

    Marco

1 2 Previous Next