4 Replies Latest reply: Feb 25, 2013 9:44 PM by Paul_31
Jimbo Ceasar Level 1 Level 1 (0 points)

My intel imac running 10.5.8 stopped communicating with my CX7400 Epson printer today. All of the usb ports work fine with keyboard and iphone and camera but not the printer. I've tried reinstalling the printer software and spoke with an Epson tech who said I had an issue with my usb ports. The printer works fine when I plug it into other printers. Is there a reset process to restore full functionality of the ports or am I possibly facing a hardware issue?


iMac (20-inch Mid 2007), Mac OS X (10.5.8)
  • Paul_31 Level 6 Level 6 (13,050 points)

    Maybe resetting the printing system will help:

    http://support.apple.com/kb/HT1341

  • Baby Boomer (USofA) Level 9 Level 9 (56,100 points)

    Try these suggestions.  Hopefully, one of them will work:

     

    http://support.apple.com/kb/HT1151 USB & FireWire Tips and Troubleshooting

     

    Resetting your Mac's PRAM and NVRAM

     

    Snow Leopard & Lion Printer solutions and suggestions.

     

    Install the Gutenprint and Gimp-Print for Mac OS X (10.2 and later) drivers.

     

    Boot up from your Leopard Install DVD while holding down the "c" key.

    Select the language you wish to use, and then choose "Disk Utility" from the menu bar.

    Your HD should appear in a panel on the left hand side of the window which opens. Select it and then click on the "repair disk" button in the right hand section of the window.

    If Disk First aid is unable to complete the repair you will need to use a stronger 3rd party utility like DiskWarrior or TechTool Pro.

     

    Once this process has been completed restart your computer.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    2ue5vgy.gif

  • Jimbo Ceasar Level 1 Level 1 (0 points)

    I deleted my 2 printers (there were 2 of the same listed) within the print and fax preference window and added it back and now I can print again. I guess after multiple reinstalls of the Epson software, I ended up with 2 of the same printers and it got confused as to which one to select. But I still can't get Epson Fax to open up, which was my problem to begin with. It tries to open with a gray preview window and a gray main window, then after 4-5 seconds, it quits and I get an error massage: "The application EPSON Scan quit unexpectedly". When I click the relaunch button, the same thing happens again. There is nothing wrong with the printer as I can print and copy and I can scan if I plug the printer into another computer. I just can't get the EPSON scan application to open on my main compute which has worked fine for 5 years until today. I just now tried to select the printer and scan form the Apple Image Capture application. When I do, Epson Scan almosts opens, but Image Capture crashes, so the problem could be a bug in the Image Capture app. The error message says: The problem may have been caused by the UI plug-in.Any sugesstions out there to fix Image Capture?

  • Paul_31 Level 6 Level 6 (13,050 points)

    How about uninstalling the Epson software using its uninstaller and then trying Image Capture. I have a Brother printer/scanner and only have the software available from the Apple site to run it - not the software that came with the printer of is available on Brother's website. Image Capture opens and works fine without it opening any other software. I think IC is a standalone app.