1 Reply Latest reply: Feb 26, 2013 10:20 AM by BDAqua
astaheltborg Level 1 Level 1 (0 points)

My connection has always been fine, right since I bought my macbook pro, more than a year ago. But last week I began having some issues with my wireless internet. A couple of times a day, it would say "connection timeout" which I've tried a couple of times before, but it fixed itself after just a few minutes all of the times I've tried it. But this time, waiting didn't solve the problem as I had hoped - it took me several restarts and tries to get wireless after every time it told the "connection timeout". And now it is completly impossible for me to go online, it keeps telling me that the connection is in timeout. It is the same routine everytime I try, I press the enter-button in hopes of it working, and the first 10-15 times it says "connection timeout", and then after the 10-15 times it says "password incorrect" - even though it is the correct password that I'm using. Then I type in my password once again, and then my computer tells me that I'm online - which I am really not. Then I start over, and it is the same routine over and over again.

 

My wireless internet doesn't seem to work anywhere anylonger, and I have a clue that it might be the network interface controller, but I am really not sure. Does anyone know what I can do with this?

My other macbooks work perfectly fine, and they are connected to the same wireless in the same place.


MacBook Pro, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (120,305 points)

    Hi, this has worked for a few...

     

    Though all of these steps may or may not be needed, I'm including them all.

     

    Make a New Location, Using network locations in Mac OS X ...

     

    http://support.apple.com/kb/HT2712

     

    10.7 & 10.8…

     

    System Preferences>Network, top of window>Locations>Edit Locations, little plus icon, give it a name.

     

     

    10.5.x/10.6.x/10.7.x instructions...

     

    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.

     

    The interface that connects to the Internet should be dragged to the top of the list.

     

    If using Wifi/Airport...

     

    Instead of joining your Network from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.

     

    For 10.5/10.6/10.7/10.8, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...

     

    208.67.222.222

    208.67.220.220

     

    (There may be better or faster DNS numbers in your area, but these should be a good test).

    Click OK.