9 Replies Latest reply: Feb 26, 2013 5:50 AM by Kurt Lang
kayjobes Level 1 Level 1 (0 points)

Hi there,

 

I've noticed that my font book won't start at all when trying to install fonts. Is there a way to re-install Font Book or to delete it completely and re-install? I've tried pressing 'Get info' and checking the box to start in 32-bit mode and that doesn't help either.

 

I'm on a Mac Pro 2.1 running Mac OS X 10.7.5, Font Book version 198.4 and am fully up-to-date.

 

Thanks in advance.


Mac Pro, Mac OS X (10.7.5)
  • 1. Re: Font book won't start
    Kurt Lang Level 7 Level 7 (31,995 points)

    Most likely, the database is hosed.

     

    Restart your Mac and immediately hold down the Shift key when you hear the startup chime to boot into Safe Mode. Keep holding the Shift key until you see a progress bar towards the bottom of the screen. You can let go of the Shift key at that point.

     

    OS X asks you to log in (you will get this screen on a Safe Mode boot even if your Mac is set to automatically log in). Let the Mac finish booting to the desktop and then restart normally. This will clear Font Book's database and the cache files of the user account you logged into in Safe Mode.

     

    If that doesn't do it, then the other problem that normally causes Font Book to fail to launch is corrupt font collections.

     

    From the desktop, hold the Option key and choose Go > Library. This opens the Library folder in your user account. Open the /Library/FontCollections/ folder. Move all of the collection files to your desktop. This will of course cause you to lose any collections sets you've created.

     

    Launch Font Book. If it works now, one or more of the collections were damaged. You can try putting back some of your personal collections to see which one (or more) is bad. Close Font Book. Put a collection back from the desktop. Launch Font Book. If it doesn't open, you know that one's no good.

  • 2. Re: Font book won't start
    kayjobes Level 1 Level 1 (0 points)

    Hi and thanks for the quick reply Kurt.

     

    I logged into Safe mode, where the Font Book didn't launch either. I shut down and re-logged in as normal and the Font Book still doesn't launch in normal mode either.

     

    I don't seem to have a library within my /Users/kay/ folder. I've tried removing all of my fonts from Macintosh HD/Library/Fonts & /Fonts Disabled. However, this didn't work.

     

    Any other ideas...?

     

    Thanks again.

  • 3. Re: Font book won't start
    Kurt Lang Level 7 Level 7 (31,995 points)

    Noted above. You get at the Library folder in your user account this way...

     

    From the desktop, hold the Option key and choose Go > Library. This opens the Library folder in your user account.

     

    Maybe a bit more specifically, make sure to click on the desktop to it says Finder by the Apple at the upper left, and not the name of an open app.

  • 4. Re: Font book won't start
    kayjobes Level 1 Level 1 (0 points)

    Holding option and clicking on the desktop does nothing. If I right click my options are as follows:

     

    New folder
    Get info

    Change Desktop Backgound...

    Clean Up

    Clean Up By >

    Sort By >

    Show View Options.

     

    If I go to 'Go' at the top of the screen, I don't have Library there either. And When I click on 'Home', there's no Library inside.

     

    Screen Shot 2013-02-25 at 23.34.10.png

     

    Screen Shot 2013-02-25 at 23.40.09.png

  • 5. Re: Font book won't start
    Kurt Lang Level 7 Level 7 (31,995 points)

    Not quite the right idea. Hold the Option key (don't let go), then up at the top on the menu bar, choose Go > Library.

     

    The choice for the Library folder in your user account only appears while you're holding down the Option key.

  • 6. Re: Font book won't start
    kayjobes Level 1 Level 1 (0 points)

    Thanks for that. Sorry, I wasn't sure what you meant before, oops. I've removed all the Fonts & Font Collections, plus the Disabled Fonts and Font Book still doesn't launch It just pops up in the bar at the bottom and disappears again (as it did before).

  • 7. Re: Font book won't start
    Kurt Lang Level 7 Level 7 (31,995 points)

    Hmm, unless the app (or OS itself) is damaged, that only leaves the preference file. Go back into the Library folder of your account and delete the following file from the Preferences folder.

     

    com.apple.FontBook.plist

     

    If that doesn't do it, boot into Safe Mode one more time and try it there. If that doesn't work, a quick determination to see if it's the OS, or the Font Book app itself is damaged is to boot back into your account normally. In the System Preferences, click on Accounts and create a new account. Log into that and see if Font Book works. If it doesn't work from a new account, then a reinstall of the OS is in order.

  • 8. Re: Font book won't start
    kayjobes Level 1 Level 1 (0 points)

    Thank you!! Deleted the plist and the "com.apple.FontBook.plist.lockfile" as well, and it's opened up straight away, super quick. Thanks

  • 9. Re: Font book won't start
    Kurt Lang Level 7 Level 7 (31,995 points)

    Excellent!

     

    Figures, it's the last, and usually least likely of the common causes.