11 Replies Latest reply: Feb 27, 2013 10:30 AM by IPreferFuji
IPreferFuji Level 1 Level 1 (0 points)

Hi - Does anyone know of a way for me to prevent Safari from trying to reload a page after being unable to reach it?

 

To reproduce what I'm talking about, disable your network connections, try to browse to Google and get an error, then turn your network connections back on.  What you will see is that Safari retries and loads the page when your network is back.  I'd like to disable this.

 

Thanks.


MacBook Pro with Retina display, OS X Mountain Lion (10.8.2)
  • dominic23 Level 7 Level 7 (31,935 points)

    Hold the "shift" key down and launch Safari.

     

     

    Empty Caches

     

    Safari > Preference > Advanced

    Checkmark the box for "Show Develop menu in menu bar".

    Develop menu will appear in the Safari menu bar.

    Click Develop and select "Empty Caches" from the dropdown.

     

    Best.

  • IPreferFuji Level 1 Level 1 (0 points)

    Hi - I have the develop menu enabled.  I couldn't see how clearing cache would change the retry behavior, but I tried it anyways.  I also tried "disable caches" and these do not stop this behavior.

     

    Again, to reproduce, take your mac off of the network, browse to any website you like and receive the "you are not connected to the Internet" error.  Next turn your wifi back on or plug your cable in, whatever, and wait.  Within a few seconds, Safari will automatically retry and browse to the site.  This is what I would like to disable.

     

    Thanks.

  • dominic23 Level 7 Level 7 (31,935 points)

    If Safari is not able to go to the website, Safari may be trying to site from the saved information.

     

    This is because of the "Resume" feature.

     

    Another way to discard the saved information

     

    is to quit Safari with the "option" key down before shutting down the computer.

     

    This is what I can think of right now.

  • IPreferFuji Level 1 Level 1 (0 points)

    Hi, thanks for the followup.

     

    I think there's a bit of disconnect here. In this case, Safari is not using resume, it's simply retrying the previously unreachable URL.  This isn't being done via cached or saved information, you can reproduce the behaivor with a URL that you have never visited before.

  • dominic23 Level 7 Level 7 (31,935 points)

    Right now I do not know where Safari stores that "Auto try" information.

     

    I will search Apple Knowledge Base again.

     

    Best.

  • CT Level 6 Level 6 (16,800 points)

    I guess you could close the window/tab of the website in question, or switch it to Top Sites. Just saying.

  • IPreferFuji Level 1 Level 1 (0 points)

    Just saying what?  "You're doing it wrong" is not adding any value here, I have a need to turn off this "function", simple as that. 

     

    So, does anyone know of a way to turn this off?

  • CT Level 6 Level 6 (16,800 points)

    Wow. Grouchy.

  • IPreferFuji Level 1 Level 1 (0 points)

    Grouchy?  No, I'm in a perfectly good mood.  Annoyed?  Absolutely. 

     

    I asked a simple and reasonable question.  If the answer is "no", I'll accept that.  If the answer is "yes", please tell me how.  If the answer is "I don't know" then please move on.

  • dominic23 Level 7 Level 7 (31,935 points)

    Safari > Preferences > AutoFill > Other > Edit

     

    Does this site shows up there?

     

    Tried resetting Safari?

  • IPreferFuji Level 1 Level 1 (0 points)

    Hi Dominic, thanks for the reply.  I checked that list and tried it with a site that was not on the list, but am still able to reproduce the behavior.

     

    I think that this is just built-in behavior in Safari 6 for any site that is at first unreachable.