13 Replies Latest reply: Nov 22, 2013 2:14 AM by emyr
emyr Level 1 Level 1 (0 points)

I have had to stop using the keyboard shortcuts (mainly for the ratings) because they simply don't work any more.

 

They used to work just fine but now it's just crap. Not sure when the change happened but it effects both my desktop and laptop but the "new" shortcuts are different for both machines (see screenshot of the commands form the laptop attached). Aperture seems to have created a new lot of highly illogical parallel shortcuts that do not work either but seem to screw things up and cannot be deleted from the default command set.

Screen Shot 2013-02-26 at 16.54.18.jpg

Tried everything that I can think of – using the iPhoto shortcuts (then switching back to Aperture defaults which works on one Macbut not the other), deleted all my custom shortcuts, deleted any preferences associated with Aperture and searched everywhere (including in the Aperture.app Package contents) for any command preferences that I can ditch to make the app reset to its default commands.

 

When I use the Aperture.app Metadata menu and select a rating it displays the correct shortcut (e.g. "5" for five stars) and selecting it from the menu works fine but hitting the 5 key just gives me a 'Funk' noise and the app flashes to say it didn't work.

 

It's driving me nuts and is VERY inefficient.

 

System info: Aperture 3.4.3 running on both a MacBook Pro, OS X Mountain Lion (10.8.2), Late 2008 model and a Mac mini, OS X Mountain Lion (10.8.2). Both machines run the OS in English but with Swiss keyboard layouts.

 

Help, anyone any ideas? :-(


MacBook Pro, OS X Mountain Lion (10.8.2), Late 2008 model 4Gb RAM
  • Frank Caggiano Level 7 Level 7 (25,720 points)

    but with Swiss keyboard layouts.

     

    When I look in Language & Text I don;t see a Swiss keyboard. Is that what it is called? What is your setting? As this problem is affecting both system you have  Is this a new setting for you?

     

    As a test have have you tried setting the keyboard to someting other then what you have ti set to now?

     

    Another thing you can try is to look in ~//Library/Applicatio Support/Aperture/Comman Sets/ and see if there is anythign in there.

  • emyr Level 1 Level 1 (0 points)

    Hi Frank,

     

    Thanks for the response.

     

    See attached photo for the current keyboard setting. I sometimes switch to the Swiss German setting and other layouts too but this is the one I use the most. It never used to be a problem.

    Screen Shot 2013-03-01 at 03.38.20.jpg

     

    I had already deleted my personal command sets and I had checked where you suggest plus in the administrator accounts for the two Mac I use.

     

    I'll try changing the keyboard language to english to see if that changes anything.

     

    Emyr

  • emyr Level 1 Level 1 (0 points)

    Hmmm....

     

    No it's not a new setting for me that's why I'm puzzled as to why it's happening especially as it occurs on both machines. Also, I don't understand why it would create two sets of commands for each action, there never used to be two of each. How many do you have in your comand set (I'm assuming you use your Mac in English only)? If I turn on four or five keyboard layouts there are still only two sets of commands.

     

    Definitely a bug, or a layout corruption somewhere, maybe with the Swiss French keyboard config. Something to do with the keyboard layout as you suggested. If I turn off the other layouts, the commands work again but I have to activate the US English layout (see result). The English layout doesn't make it work.

    Screen Shot 2013-03-01 at 04.02.34.jpg

    Switched to the Swiss French layout and restarted Aperture – bingo! the problem is back. :-(

    Screen Shot 2013-03-01 at 06.16.58.jpg

    Oddly enough I disabled the Swiss French and enabled the Swiss Geman (along with the US one) layout and it works again.

     

    Any ideas of anything I can do to reset the keyboard layouts to the "out-of-the-box" settings?

  • Frank Caggiano Level 7 Level 7 (25,720 points)

    The default command set should never be altered, is that what you have selected?

     

    If you select the Default pulldown at the top of the command set window what does it show you

     

     

    Screen Shot 2013-03-01 at 13.56.50 .png

    Check both the Default and iPhoto settings.

  • emyr Level 1 Level 1 (0 points)

    Brilliant, thanks for pointing that out to me. I have never noticed that before on any other application.

     

    U have never altered the default command set, in fact it seems to be impossible to do so.

     

    Previously I was not offered language options (it just said default with no arrow) from the default command menu but after I switched on the German it gave me this...

    Screen Shot 2013-03-01 at 8.51.32 PM.jpg

    After turning on the US English in the International & Text prefs it gave me this (turning on British English doesn't).

    Screen Shot 2013-03-01 at 8.57.29 PM.jpg

    But I still have two lots of commands!

    Screen Shot 2013-03-01 at 8.57.48 PM.jpg

    My problem now is that it always defaults to the French commands when I start Aperture. there is no way to keep it as English and I have to re-set it every time I open Aperture.

    Screen Shot 2013-03-01 at 9.10.44 PM.jpgScreen Shot 2013-03-01 at 9.10.59 PM.jpg

     

    Aaaarrrrggghhhhhh!

  • Frank Caggiano Level 7 Level 7 (25,720 points)

    Looks like it is picking that up from your preference settings. I tired setting the Input Source option to allow a different one in each document but Aperture still uses the one set in Preferences.

     

    regards

  • emyr Level 1 Level 1 (0 points)

    Bah! I have no idea which preferences to ditch to get this back to its "out-of-the-box" state short of doing a clean install which I've not done for about five years now despite keeping up-to-date with OS versions. My self esteem couldn't handle the shame of physically taking it to a genius bar (it feels like I was using a Mac before most of the ones in Geneva were eating solids)!

     

    Any hints? I've tried the looking for the Language and text prefs and keyboard layouts but to no avail. The most frustrating thing is that it keeps jumping back to the French default commands.

     

    Perhaps I'll have a trawl through the forums again...

  • emyr Level 1 Level 1 (0 points)

    Months down the line and the problem does not go away. I have instealled a new HD in my MbP and a clean install of Mavericks but the behaviour never changes.

     

    Despite setting the default command to English every time I restart Aperture, the setting is never remebered and I must do it again each time.

     

    It's as if there is a basic fault in the commands/keyboard preferences.

  • léonie Level 9 Level 9 (75,155 points)

    Have you checked the keyboard shortcuts in the "Language&Text" preferences? I once had a similar problem with the keyboard continually switching, until I discovered that a shortcut, that I was frequently using had been reassigned to "Select next Input Source". Screen Shot 2013-11-18 at 17.11.36GMT+1.png

  • emyr Level 1 Level 1 (0 points)

    Hi Léonie,

     

    Thanks but no that they were not activated & I use ⌘Space & ⌥⌘Space for a system-wide command in another app.

     

    Actually the keyboard layout does not change my problem is that the Aperture Command Default Language does remain set to English. I have to set it to English every time I launch Aperture and it reverts backk to French each time. It seems to be inependent of what the Default language for the system is (which is English despite having a Swiss French/German keyboard layout).

     

    All the other apps on my machines run in English which is the System Language.

     

    Really really frustrating!

  • emyr Level 1 Level 1 (0 points)

    I'd actually like to report this as a bug to Apple but there is no obvious way of doing this...

  • léonie Level 9 Level 9 (75,155 points)

    Use the built-in Feedback Form in Aperture:

    In the "Aperture" application menu > Provide Aperture Feedback

     

    or the direct link:

     

    Apple - Aperture - Feedback

     

    Actually,  I am also using a german keyboard, too, and my main system language is set to English; my keyboard shortcuts are also always very funny and the "Commands > Default"  setting will always revert to German with horrible shortcut settings. I do not even try to memorize combinations like ^⇧ß 

    Screen Shot 2013-11-19 at 13.39.32GMT+1.png

  • emyr Level 1 Level 1 (0 points)

    Thanks for that, it's been a couple of years since I submitted any feedback and I just couldn't find it (showing my age I think...).

     

    Currently I have duplicated the default English commands and have set that to be the Custom Command Set that is used. For the moment it seems to work but then again it worked previously too and stopped for some reason. I'll have to see if I can duplicate the functionality on the other Mac.

     

    Not sure the Swiss French/German keyboard is much better!

     

    Screenshot 2013-11-22 11.07.05.jpg