1 Reply Latest reply: Mar 7, 2013 5:59 PM by smp-mac
smp-mac Level 1 Level 1 (0 points)

Machine:

 

MacBook Pro

OS X 10.8.2

 

Scenario:

 

I work at two locations mainly, office and at home during any given week. At both places I VPN in using Network Connect. Let's say I am at home using the VPN on Monday and use it all day. I will then close the computer lid, putting the machine to sleep. Before putting it to sleep I can either sign out of the VPN (Network Connect) or not, either way my issue of no Internet will happen when I get to work the next day. On Tuesday I take my laptop into work, oepn it up an grabs an IP via DHCP, but I have no Internet at all. My machine will have an IP via Wi-FI, but no Internet. My assumption is that my Wi-Fi connection is holding onto something in my routing table from when I was using Network Connect. As of right now my only way of fixing this is to reboot the machine, which if I have items I was working on from the day before, I'd prefer not to.

 

Couple Things worth Noting:

 

- If I re-open my laptop on Monday while at home later that night, Internet will work just fine with/without the VPN.

- The scenario will happen when I go from work to home as well, it's just not home to work.

- I am not the only one with this issue

- I should point out that if I connect an Ethernet cable to my machine, I will have Internet without having to reboot. (we do not have Ethernet to our desks, so this is not a viable solution)

 

What I've tried so far:


- Renew/release does nothing (I already have an IP, but figured it was worth a shot)

- Turning Wi-Fi On/Off (Left machine off for 60 sec)

- Disconnecting from the Network and then reconnecting

- Changed my DNS

- Statically assigning an IP

 

What fix I'm looking for:

 

- Fix this issue 100%

- Set of steps to resolve the issue without having to reboot


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: Network connect and switching Wi-FI Locations results in no Internet
    smp-mac Level 1 Level 1 (0 points)

    OK, so I am going to assume my issue was unique and hence the lack of replies. Needless to say it is now working. Hard to say what fixed it, but there are two possibilities.

     

    1. Latest Java update that Apple pushed out

    2. Java update form Oracle.

     

    These were both updated at the same time or there of. Regardless this was some bizarre Java issue. Why can;t we live in a word without Java...I sometimes wonder.