8 Replies Latest reply: Feb 24, 2014 4:55 AM by a brody
enricofrompd Level 1 Level 1

I am having enormous problems trying to copy data. A lot of the time I get "error -36".

I have spent a lot of time "cleaning" my directories by using the "dot_clean" solution.

All my external HDs are formatted MAC OS journaled (even my SD cards!).

And yet I still get the error.

I am unable to make copis of my data which is now getting dan gerous if anything happens to my MAC.

I am using a MAC PRO 2011 model, iOS 10.7.5

Can anyone help?


MacBook Pro, Mac OS X (10.7.5)
  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    Mac Pro is a desktop.  MacBook Pro is a notebook.  But that matters not for the error in question.  That is an input/output error.  Typically means there is a problem with the data device or cables.      Backup your data.  Never heard of dot_clean.  The only directory solutions I recommend are Alsoft Disk Warrior and Apple's own Repair Disk from command-R boot's Disk Utility.

  • enricofrompd Level 1 Level 1

    Sorry, I meant Macbook Pro.

    I have been checking various forums to see if others have had this problem and it appears to be reasonably common. One of the solutions proposed was to use the terminal and input "dot_clean" followed by a space and the directory containing the file(s) involved. It worked a few times, but not always.

    I was told also that this is due to a file created in FAT32 with data pertaining to the file in question, and the two did not always link up when being copied to another HD.

    My MAC has 2 SSDs, the main one for iOS and programmes, and the other is for data.

    I back up both, that is not the issue - it is when I have to make a copy of file(s) onto a flash drive or external hard drive. I've been told too that these external drives should be always formatted MAC OS not WIN - which I have done, but it has not helped.

    I've noticed that it doesn't seem to be limited to any particular type of file either - it happens with jpeg, with .doc files, with pdf files, and so on.

    I'l check to see if Alsoft Disk Warrior can be of help.

    I may add too that this has not been going on for a long time, only a few weeks - it was never a problem before.

    Thanks for your suggestions.

  • enricofrompd Level 1 Level 1

    Have purchased and tried Disk Warrior, but it has not made any difference.

    Apple's Disk Repair was one of the first things I tried and that too has not helped.

    I have checked all connections and all appear OK.

    Short of reformatting and hoping that works, is there any other suggestion?

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    If Disk Warrior can't detect anything, it typically is a hardware problem.  -36 means input/output error.

  • silversword411 Level 1 Level 1

    FYI I had the same problem. Was multiple bad sectors that were part of a 2GB vmdk file (virtual HDD). I used the below technique, but you're basically copying the data, ignoring any errors and hoping for the best:

     

    - Used mucommander to sync directories to another device, make note of the file(s) that are giving io errors.

    - Use dd to copy whatever you can, repairing the file after the fact (and hope for the best) using: http://aeroquartet.com/wordpress/2012/06/06/how-to-copy-a-file-with-io-errors/

     

    Then preferrably replace the drive or at least test with surface scan after and make a determination if you want to keep trusting the drive.

     

    Good luck!

     

    Another item of note: Apple wanting to be "easy to use" time Machine has been reporting "last successful backup" as ok, and silently ignoring the problem file so I can't revert to backup of the file :/

  • anilkapur Level 1 Level 1

    I ran into this problem while copying many files to a NAS.  During the copy a failure occured whic probably caused a file corruption somewhere on my filesystem.  After some research, here's what I found.

     

    Finder creates a .DS_Store hidden file in almost every directory where files are located.  Using "terminal" and logged in as "sudo", type "ls" in the directory where the offending files exist.  You should see the .DS_Store file.  I deleted the .DS_Store and all was well again. 

     

    If these instructions are unclear, simply google "remove .DS_Store" and detailed answers will appear.

     

    Hope this helps and good luck!

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    I always thought DS_Store stored meta data.  Have you had trouble restoring information from your backup that doesn't have an associated DS_Store file?