Previous 1 2 Next 26 Replies Latest reply: Jun 6, 2015 10:56 AM by lyw519 Go to original post
  • dc26 Level 1 Level 1 (0 points)

    I HAVE THE LATEST VERSION FLASH AND SAFARI AND IT STILL WON'T WORK...

  • supportmac Level 1 Level 1 (0 points)

    Brilliant and soooo simple. Worked for me.

     

    Thanks.

     

    MENU:

    > Choose Safari

    > Preferences

    > Security

    > Check "Enable Plug-Ins"

  • dc26 Level 1 Level 1 (0 points)

    Thank-you however, I already have Internet Plug-ins enabled so that is NOT the problem. Preferences>Security>Interent plug-ins>All all other plug-ins, IS Checked.

     

    And Safari and Flash were latest version and installed each several times uninstalled and re-installed many times, etc.

     

    FLASH DOESN'T WORK WITH SAFARI anymore. So I no longer use much-broken Safari.

  • icollectglass Level 1 Level 1 (0 points)

    I have a 27 inch iMac (just purchased in December) and cannot get Flash Player to work properly either.

     

    I have unistalled and resinstalled with no luck. Preferences are set to enable plug-ins.  Works fine in Firefox!

     

    Works fine on my Macbook Air running Lion. So Safari is indeed broken, again?

  • icollectglass Level 1 Level 1 (0 points)

    Hi, thanks - I actually tried the instructions twice ... No luck.

  • dc26 Level 1 Level 1 (0 points)

    Update:

     

    After many uninstalls and re-installs that just kept failing I stopped using Safari for awhile.  THEN...

     

    I manually removed the Flash Plug-in and any older backups from my Internet Plug-ins folder, re-booted my computer (yes to compeltely clear it), installed Flash, then rebooted computer (again) and I got Flash to work better in Safari.

     

    Other browsers work better though and have less issues working on more webstites.

  • Waspsting Level 1 Level 1 (0 points)

    I tried several of the suggestions in this discussion, but this was the only one to fix the problem in my case.

     

    Many thanks!

  • julielovessnsd Level 1 Level 1 (0 points)

    GUYS I HAVE DONE IT!!!!!

     

    I tried repeatedly installing it, restarting my iMac and installing Google Chrome (instead that said that browser was open too when it wasn't).

    And finally...DUN DUN DUN...I have found the solution!

    The iMac equivalent to Task Manager is Activity Monitor.

    So, go to your launchpad, search it up and then when you are in Activity Monitor, simply click on Safari and click the X icon in the top left hand corner, below the actual X button to close the window.

     

    You're welcome in advance ;-)

  • cloudsongs Level 1 Level 1 (0 points)

    That did it! OMG thank you. Ive been trying to chase that down for.... years?  Yosemite didn't fix it etc...


    Turned out it was my preferences in Safari   (Just like smsgatorsaid)

     

    MENU:

    > Choose Safari

    > Preferences

    > Security

    > Check "Enable Plug-Ins"

     

    I didn't have to re install

     

    Thanks

  • omairr.azam Level 1 Level 1 (0 points)

    i have read all the suggested solutions but i found a different solution that fixed the problem. my safari version is Version 8.0.5 (10600.5.17).

    goto Preferences of safari and then to security tab. Then click the settings button in front of internet plugins as shown in picture below

    Screen Shot 2015-06-02 at 10.50.29 PM.png

    After clicking it you will see a window as shown in next snapshot

    Screen Shot 2015-06-02 at 10.54.02 PM.png

    see in above snap that in left menu adobe flash player is selected and then you can allow/block flash for any site you want from here.

    In my case my site gana.com couldnot use this flash even though it was latest, after is switched it from Block to Allow Always (from dropdown), my plugin started working.

    I hope this would help!.

    Regards.

  • lyw519 Level 1 Level 1 (0 points)

    Hey, guys. I had the same problem, but I think I've found a way to solve it. Go to your Safari preference settiing and check out your extensions. If you see any unusual extensions, uninstall them. I noticed there're two unusual extensions in my safari setting. One is called "macfest" and the other is "Searchme". If you find such things in yours, delete them right away. Then your safari will be back to normal. 

Previous 1 2 Next