11 Replies Latest reply: Jun 24, 2013 9:55 AM by etresoft
Cartoonguy Level 1 Level 1 (0 points)

I have been finding this intermittent problem typing a reply to an email in Mail.  When I mistype a word, auto correct fixes it, but then deletes the space before hte word and joins it up to the previous word, so I keep having to go back and add a space.  Here is a link to a screen grab video that shows exactly what happens:  http://youtu.be/RvknuXh-OAc

 

Here are some particulars about when it happens.

 

  • Only when typing a reply to an email and while typing in the body of the senders email message.  Typing above, in the normal reply area, no problem.  That is, when you give notes and say, "see below" and then type answers to their questions in their message area.
  • Not every email exhibits this problem, but many do.
  • I forwarded this email to other people and the problem sticks to the email.  Opened it on other computers and also on Outlook on a Mac and the problem persists, but only in that email.  It's as if the problem is part of the email message itself.
  • As above, not specific to any one computer, so not to do with the user or plug ins or whatever.
  • Never have this problem in Outlook (which I used to use).  Only Mail.
  • If I were to type slowly so that the auto correct balloon had time to appear, it does not delete the space.  Of course, I don't type slowly so that is not a fix.
  • It appears that it is related to the way the auto-correct works, but only in the body of the reply, not in a reply above or an original email.  If I turn auto-correct off, it does not do this.

 

So this is a big mystery to me and really annoying when I am replying to an email and trying to type quickly.  Very strange.  Hope someone has an idea what it could be.

 

Thanks!

 

P.S.  Had to post the video on Youtube because the Insert Video button here is greyed out.  Not sure why.


iMac, OS X Mountain Lion
  • 1. Re: Bizarre typing problem in Mail
    Linc Davis Level 10 Level 10 (118,030 points)

    From the menu bar, select

    Edit Substitutions

    and uncheck Text Replacement.

  • 2. Re: Bizarre typing problem in Mail
    Topher Kessler Level 6 Level 6 (9,340 points)

    Try going to the Language & Text system preferences and uncheck the option to correct spelling automatically in the "Text" tab. This should have the word underlined in red if misspelled. Then see if the same problem happens when you right-click the word and choose a replacement for it. Also try adjusting or toggling the "Word Break" setting, which should be either "Standard" or "English" as the default.

  • 3. Re: Bizarre typing problem in Mail
    Cartoonguy Level 1 Level 1 (0 points)

    Thanks, but both suggestions fix it, but then I no longer get spell checking, which I want.  So I am looking for a fix that doesn't involve disabling a useful feature and clearly, should not be behaving like this.

  • 4. Re: Bizarre typing problem in Mail
    Topher Kessler Level 6 Level 6 (9,340 points)

    Unchecking this option should not prevent it from checking the spelling, and the system should still underline misspelled words in red. To be sure this is enabled, go to the Edit > Spelling and Grammar > Check Spelling menu and select the option to do so "While Typing."

     

    I'm not offering this suggestion as a permanent solution, but rather something to try to see how this problem is manifesting itself and whether or not it is linked to the auto-correct or simply to any correction features.

  • 5. Re: Bizarre typing problem in Mail
    Cartoonguy Level 1 Level 1 (0 points)

    Sort of true.  It does underline it and so I have to then go back, right click and choose the correct word.  When I do that, it then corrects the word and deletes the space before it, so joining the word up, just like before.  So I'm back where I started.

     

    It also disables any other typing shortcuts which I may have added like an abbreviation to make a longer word. 

     

    Appreciate your ideas though.

  • 6. Re: Bizarre typing problem in Mail
    Christiaan_BT Level 1 Level 1 (0 points)

    I'm having exactly the same problem, and its **** annoying!

    I have also tried both the suggestions, and whilst they work, they are more 'workarounds' than fixes.

     

    What I have also seen sometimes in these emails is that if one tries to type a reply directly after any point after the end of a comment in order to comment or answer in return, the line just jumps to a new line directly below it and doesnt let you edit text in line with the (now above) comment.

     

    Maybe this sheds some light on it? Surely it cannot just be the two of us having these issues?

  • 7. Re: Bizarre typing problem in Mail
    Cartoonguy Level 1 Level 1 (0 points)

    Glad to hear (well, not glad, but you know) that I'm not the only one having this issue.  It totally vexed Apple support.  Had an agent trying to help and made an earnest effort, but no joy.  If you figure anything out, please post!  it is really annoying and I have never had this issue in Outlook.

  • 8. Re: Bizarre typing problem in Mail
    Stefan9876543 Level 1 Level 1 (0 points)

    I'm also having the exact problem.  I love the iPhone-esque auto correct in emails, and I don't want to have to disable it.  It's just really a problem having to go back and delete those spaces!  Is this just a glitch in the OS we're going to have to deal with?

  • 9. Re: Bizarre typing problem in Mail
    mohavetbird52 Level 1 Level 1 (0 points)

    I have the same problem as well. Any fix yet?

  • 10. Re: Bizarre typing problem in Mail
    Cartoonguy Level 1 Level 1 (0 points)

    Not that I'm aware of.  In my lengthy discussions with Apple support, they basically said that they have never heard of this issue and don't know what could be causing it.  Not so helpful!

  • 11. Re: Bizarre typing problem in Mail
    etresoft Level 7 Level 7 (24,270 points)

    What 3rd party software do you have installed? I wrote a little diagnostic program to help show what might be running in the background. Download EtreCheck from http://www.etresoft.com/etrecheck, run it, and paste the results here.

     

     

    Disclaimer: Although EtreCheck is free, there are other links on my site that could give me some form of compensation, financial or otherwise.