1 Reply Latest reply: Mar 6, 2013 6:51 PM by maker
Tomdbl Level 1 Level 1 (0 points)

For no apparent reason I suddenly can't receive email from my iCloud mail account using Mac Mail. I get a dialog box repeatedly asking for my password. The password is set correctly in preferences.

 

I tried to troubleshoot this by following this very recent article from Apple support: http://support.apple.com/kb/TS4002

 

The article says that my incoming mail server should be set at imap.mail.me.com. In preferences it is currently set at p01-imap.mail.me.com, but I can't change it because it is grayed out!

 

Any help appreciated.


MacBook Pro with Retina display, OS X Mountain Lion, 2.7ghz, 16 gb ram
  • 1. Re: Can't receive icloud mail through Mac Mail app
    maker Level 1 Level 1 (0 points)

    You could try this:

     

    1. Delete the iCloud Mail account, use the '-' button and add it back manually.

    2. Click the '+' button to create a new account.

    3. Hold the option (alt) key down to change the 'Create' button to 'Continue' (this is to prevent your Mac from setting up the account for iCloud automatically).

    4. Click 'Continue'.

    5. Set 'Account Type to IMAP, enter a description (e.g. 'iCloud')

    6. User Name: example@me.com (use your @me.com address from your iCloud account)

    7.  Set the Incoming Mail Server to imap.mail.me.com  Click 'Create' (don't hold the option key down this time).

    8. Enter the SMTP server address - smtp.mail.me.com - and click 'Use Authentication'.

    9. Click 'Create'.

    10. Check the Advanced settings in Mail Preferences>Accounts, select the account and click the 'Advanced' tab: set the port number to 993 if it isn't than already and make sure that 'Use SSL' is checked.

     

    All iCloud Mail server settings can be found here: http://support.apple.com/kb/HT4864