Previous 1 2 3 4 Next 48 Replies Latest reply: Sep 29, 2015 3:39 AM by Stryker412 Go to original post
  • cafarom Level 1 (10 points)

    I may have found a work-around that does not involve disabling spotlight. At least it appears to be holding out relatively well on my machine.


    You need to create a LoginHook to redirect ~/Library/Caches to /Library/Caches/username, as detailed by this post:



    Make sure you set appropriate permissions on the LoginHook script and verify that it runs when you login by checking your console log.


    I found a couple of errors in the posted script. Here is the script that I used:

  • Gino@MacHero Level 1 (0 points)

    thanks cararom,  I am testing this now and it appears to have done the trick for us as well. The problem does not produce itself in our testing and we've rolled out to effected users 3 days ago. So far no instances of the bug reported since.


    FWIW, I have also tried testing an upgrade to 10.8.4 server. This solved the mds issue, but presented a host of other AFP-related problems and performance issues.

  • christoph.l Level 1 (0 points)

    I upgraded to OS X 10.9. The upgrade did not solve the problem for me, so I still use the LoginHook script.


    At first I deleted every item within ~/Libraray/Caches at login (with the LoginHook script as cafarom recommended).

    This helped me in almost every case, but I had problems with the FontExplorer X which took a very long time to start.


    Now I only remove the folder ~/Library/Caches/Metadata/Safari/History which seems to be responsible for the problem.



    By the way: When I login as admin at the mac (local account) and when I mount the home folder of the network user account (user name is 'cl') then I lost the connection to the volume and get the following error in the log when I want to open the folder /Volumes/cl/Library/Caches/Metadata/Safari/History/:

    • KernelEventAgent[87]: tid 54485244 type 'afpfs', mounted on '/Volumes/cl', from '//cl@', not responding
    • KernelEventAgent[87]: tid 54485244 received event(s) VQ_NOTRESP (1)
    • 07.11.13 12:58:33,650 KernelEventAgent[87]: tid 54485244 type 'afpfs', mounted on '/Volumes/cl', from '//cl@', not responding
  • ServerBurninator Level 1 (0 points)

    That's too bad to hear that upgrading didn't fix the problem. I was hoping that upgrading both the sever and clients to 10.9 would fix this, since they would be using SMB2 and not AFP anymore, but it sounds like AFP isn't the root cause here.


    Would you be willing to share your loginhook script? I've been having trouble getting the script from cafarom to work correctly and was hoping to see how you did it.


    Thanks a bunch.

  • Nicholas Woolridge Level 1 (0 points)

    Hi Christoph, just to be clear, did you upgrade the clients to 10.9, or both the clients and the server?

  • cafarom Level 1 (10 points)

    We haven't had total success with the LoginHook. While it does appear to delay the issue for long periods, it doesn't appear to be fullproof.


    We've switched to mobile accounts for some desktop users. It's not terrible but home sync has it's own issues.

  • christoph.l Level 1 (0 points)

    Hi Nicholas,

    I upgraded both to 10.9: server and clients.

  • Nicholas Woolridge Level 1 (0 points)

    Wow, that is disappointing. Apple has had a long time to fix this, and the fact that the problem has survived two major OS updates, and a transition to a different filesharing stack, indicates that this is a pretty fundamental problem...

  • ziondotcom Level 1 (10 points)


    I'm currently running OS X Server 10.6.8 Server on an older Xserve2,1 (2008) with RAID 5, SAS across 3x300GB SAS 15k rpm drives - about as fast as you can get except SSD and Thunderbolt - however the network is the bottleneck - I'm using gigabit cat5e. I only have 2 client iMac 2012/2013 systems running OS X Mavericks. Trying to setup network home accounts for 4 people. I migrated their home folders off one iMac onto the server.


    I've seen the same problem as others - shortly after login when you get around to launching an app - be it System Preferences, Mail, etc, folks are experience app hangs. Clicking the spotlight icon, I see it is indexing - seems. Who has patience for this? Looking at the server, it's raid array is busy flashing lights and I check network IO and it's pretty heavily hit.


    Some thoughts towards a solution:

    1. make sure your client computers are on gigabit connections and cables are cat5e at least and all switches (not hubs) in between.

    2. Relocation client caches to the local client drive following the tip here:

    (NOTE: Adobe Apps seem to be unhappy about caches being moved - see the other change for Acrobat in the link above).


    A corrupt spotlight file will surely cause your users problems, so consider these final tips:

    + As admin, remove in your client home folders any hidden spot-light index ~/.Spotlight-V100  (spotlight will rebuild the user's index unless you disable spotlight)

    + disable Spotlight altogether if you don't need/want it

    + drop spotlight priority significantly: html

    Using an admin account, carefully change: /System/Library/LaunchDaemons/

    Near the bottom on OS X Mavericks (client), change the false to true, then save your change, and reboot.





    + if you allow spotlight ot run, be patient when the user logs in for the first time on a specic machine and let spotlight do it's long heavy-handed index work - after you clean the index the first time).


    Added further details: ziondotcom

  • ziondotcom Level 1 (10 points)

    just for the record, even after my steps above, I'm still seeing problems after I left Spotlight on. I thought things were resolved but then a user logs in, and Mail hangs, and the culprit always is Spotlight churning away...or at least that is the one consistent thing about Mail hanging. I may have to resort to turning it off altogether.

  • cafarom Level 1 (10 points)

    Yep, it stinks. I'd love to see Apple fix this problem but I've just about given up hope. My advice is to switch to mobile accounts.


    Spotlight is very prevalent throughout OS X; more so than you realize before working with it off for a while.

  • ServerBurninator Level 1 (0 points)

    Yeah, I would almost consider Network accounts depricated, Apple doesn't care, and doesn't take the bug reports seriously.


    Like cafrarom said, living without Spotlight is aweful, we did it for a whole year, and there are still more issues with network accounts besides just this one. They just don't work anymore. Mobile accounts are unfortunately the only thing left.


    The login/sync times aren't too bad with mobile accounts if you enable server-side-file-tracking (used to be an option in 10.6 but now it's hidden.) on-server/


    My account is 55gb, but with server-side-file-tracking enabled it only takes about 6-8 minutes to login/logout. We tried them a few years ago and were getting all sorts of sync conflicts continually, especially with iTunes, but lately it's all been working well...too well perhaps.


    Anyway, please give mobile accounts a try, it's the only thing left.

  • ServerBurninator Level 1 (0 points)

    Hi bug-friends,


    Apple just reopened my long since closed bug report with this question:


        Engineering has requested the following:


        Are you still seeing this issue with OS X 10.9.2 and Server 3.0.3 or later?


    We've long since abandoned Network Accounts for Mobile Accounts, but I wanted to pass this info along and ask if 10.9.2 seems to fix the issue for anyone? With any luck, maybe they're actually trying to fix it?


    Let me know, I'll include what you guys say in the report.

  • k8n Level 1 (0 points)

    Nope. Same problem with 10.9.2. After rolling out 10.9.2 our shared group folder, which has been otherwise stable, now also occasionally drops out for some users.


    To share my experience, I'll say that one reliable way to resolve the issue as it is happening is to go to the server and explicitly kick the hung connection. At that point, the client computer (which has user home mounted off the server) unfreezes and at least lets me to restart the client Mac. (If the connection is not kicked, only the hard reset would bring the client machine back to life).


    Should have never moved from 10.6. *sigh*


    As a side note, I came across a couple of very special Word files sitting in an AFP share. Trying to open these files (quicklook or otherwise) hangs the AFP connection instantetiously. Perhaps the underlying cause for this is the same. If Apple support would be interested to look into this, I would love to collaborate.

  • ServerBurninator Level 1 (0 points)

    Thanks for the reply. That's a shame to hear it's still broken.


    That's interesting - those Word files do sound really suspsicious. Maybe that's why disabling Spotlight from indexing them fixes the problem?


    What are your client and server versions? If they're both using 10.9.2, then they should be using SMB2 and not AFP, so I'm wondering if those Word files would still crash their connections or not?


    Yeah, I'm sure they would love to see those files. I can attach them in my reply if you want, but it would probably be best to open a new issue here:


    Let me know, thanks.