6 Replies Latest reply: Mar 5, 2013 10:34 PM by léonie
AlinaLakitsch Level 1 Level 1 (0 points)

Hi! First, Aperture began to fail while editing, all the time. I repaired the library a lot of times, also repair permissions and move the library to a external HD for working with a new library. Nothing worked. I also did a test on my computer and the memory seems fine.

I'm using Aperture 3.4.3 and I have a 13-inch, mid 2012 MacBook Pro Version 10.7.5, 2.5 Ghz Intel Core i5, 4 GB 1600 MHz DDR3.

 

 

I copy the error message below, thanks!

 

Process:         Aperture [558]

Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

Identifier:      com.apple.Aperture

Version:         3.4.3 (3.4.3)

Build Info:      Aperture-310022000000000~1

Code Type:       X86-64 (Native)

Parent Process:  launchd [129]

 

 

Date/Time:       2013-03-04 23:13:04.401 +0100

OS Version:      Mac OS X 10.7.5 (11G63)

Report Version:  9

 

 

Interval Since Last Report:          240513 sec

Crashes Since Last Report:           25

Per-App Interval Since Last Report:  80640 sec

Per-App Crashes Since Last Report:   21

Anonymous UUID:                      21FCBB11-229D-443A-9527-F6BFD46EE7D9

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x00000001303df200

 

 

VM Regions Near 0x1303df200:

    MALLOC_LARGE           0000000130135000-00000001303df000 [ 2728K] rw-/rwx SM=PRV

-->

    IOKit                  000000013046b000-0000000130470000 [   20K] rw-/rw- SM=ALI

 

 

Application Specific Information:

objc[558]: garbage collection is OFF

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.apple.geode                    0x000000010b512041 -[DGGetPixelsProcessor processConstArea:bufferPtr:rowBytes:format:] + 1119

1   com.apple.geode                    0x000000010b4c90a9 __52-[DGImageBuffer processConstPixelsInArea:processor:]_block_invoke_0 + 72

2   com.apple.geode                    0x000000010b4c9592 -[DGImageBuffer forEachImmutableTileInROI:processor:] + 1183

3   com.apple.geode                    0x000000010b4c905b -[DGImageBuffer processConstPixelsInArea:processor:] + 111

4   com.apple.geode                    0x000000010b4fd755 DGGetPixelsForArea + 492

5   com.apple.geode                    0x000000010b4c9635 -[DGImageBuffer getPixelsForArea:destPtr:destPtrRowBytes:] + 54

6   com.apple.RedRock                  0x000000010a27ee34 -[LazyLabImage getPixelsForArea:destPtr:destPtrRowBytes:] + 2667

7   com.apple.RedRock                  0x000000010a27d3c6 -[RKSelectiveMaskProcessor processStamp:radius:softness:brushBounds:brushPtr:brushPtrRowBytes:destData:des tDataRowBytes:] + 520

8   com.apple.geode                    0x000000010b4f8611 -[DGBrushStroke rasterizeToMaskWithProcessor:scaledMaskBounds:maskPtr:maskPtrRowBytes:scale:clo se:startIndex:lastStampedIndex:] + 1403

9   com.apple.Aperture                 0x00000001098eb5a7 0x109591000 + 3515815

10  com.apple.geode                    0x000000010b4c9860 __54-[DGMutableImageBuffer processPixelsInArea:processor:]_block_invoke_0 + 72

11  com.apple.geode                    0x000000010b4c9d1b -[DGMutableImageBuffer forEachMutableTileInROI:processor:] + 1144

12  com.apple.geode                    0x000000010b4c980d -[DGMutableImageBuffer processPixelsInArea:processor:] + 139

13  com.apple.Aperture                 0x00000001098eebe3 0x109591000 + 3529699

14  com.apple.Aperture                 0x00000001098ef4ff 0x109591000 + 3532031

15  com.apple.Aperture                 0x00000001098ed012 0x109591000 + 3522578

16  com.apple.Aperture                 0x0000000109a062c7 0x109591000 + 4674247

17  com.apple.Aperture                 0x0000000109a06e85 0x109591000 + 4677253

18  com.apple.Aperture                 0x0000000109a07e83 0x109591000 + 4681347

19  com.apple.AppKit                   0x00007fff96967a0e -[NSApplication run] + 555

20  com.apple.prokit                   0x000000010aaa8be1 NSProApplicationMain + 387

21  com.apple.Aperture                 0x00000001095a14a2 0x109591000 + 66722

22  com.apple.Aperture                 0x00000001095a0df4 0x109591000 + 65012

 

 

Thread 1:: Dispatch queue: com.apple.libdispatch-manager

0   libsystem_kernel.dylib             0x00007fff964dd7e6 kevent + 10

1   libdispatch.dylib                  0x00007fff92934786 _dispatch_mgr_invoke + 923

2   libdispatch.dylib                  0x00007fff92933316 _dispatch_mgr_thread + 54

 

 

Thread 2:

0   libsystem_kernel.dylib             0x00007fff964dcbca __psynch_cvwait + 10

1   libsystem_c.dylib                  0x00007fff952a72a6 _pthread_cond_wait + 890

2   com.apple.Foundation               0x00007fff94fb3a5c -[NSCondition waitUntilDate:] + 371

3   com.apple.Foundation               0x00007fff94f7d22e -[NSConditionLock lockWhenCondition:beforeDate:] + 251

4   com.apple.proxtcore                0x000000010b77403a -[XTMsgQueue waitForMessage] + 47

5   com.apple.proxtcore                0x000000010b773282 -[XTThread run:] + 329

6   com.apple.Foundation               0x00007fff94f8472a -[NSThread main] + 68

7   com.apple.Foundation               0x00007fff94f846a2 __NSThread__main__ + 1575

8   libsystem_c.dylib                  0x00007fff952a38bf _pthread_start + 335

9   libsystem_c.dylib                  0x00007fff952a6b75 thread_start + 13

 

 

Thread 3:

0   libsystem_kernel.dylib             0x00007fff964dcbca __psynch_cvwait + 10

1   libsystem_c.dylib                  0x00007fff952a72a6 _pthread_cond_wait + 890

2   com.apple.Foundation               0x00007fff94fb3a5c -[NSCondition waitUntilDate:] + 371

3   com.apple.Foundation               0x00007fff94f7d22e -[NSConditionLock lockWhenCondition:beforeDate:] + 251

4   com.apple.proxtcore                0x000000010b77403a -[XTMsgQueue waitForMessage] + 47

5   com.apple.proxtcore                0x000000010b773282 -[XTThread run:] + 329

6   com.apple.Foundation               0x00007fff94f8472a -[NSThread main] + 68

7   com.apple.Foundation               0x00007fff94f846a2 __NSThread__main__ + 1575

8   libsystem_c.dylib                  0x00007fff952a38bf _pthread_start + 335

9   libsystem_c.dylib                  0x00007fff952a6b75 thread_start + 13

 

 

Thread 4:

0   libsystem_kernel.dylib             0x00007fff964dcbca __psynch_cvwait + 10

1   libsystem_c.dylib                  0x00007fff952a72a6 _pthread_cond_wait + 890

2   com.apple.Foundation               0x00007fff94fb3a5c -[NSCondition waitUntilDate:] + 371

3   com.apple.Foundation               0x00007fff94f7d22e -[NSConditionLock lockWhenCondition:beforeDate:] + 251

4   com.apple.proxtcore                0x000000010b77403a -[XTMsgQueue waitForMessage] + 47

5   com.apple.proxtcore                0x000000010b773282 -[XTThread run:] + 329

6   com.apple.Foundation               0x00007fff94f8472a -[NSThread main] + 68

7   com.apple.Foundation               0x00007fff94f846a2 __NSThread__main__ + 1575

8   libsystem_c.dylib                  0x00007fff952a38bf _pthread_start + 335

9   libsystem_c.dylib                  0x00007fff952a6b75 thread_start + 13

 

 

Thread 5:

0   libsystem_kernel.dylib             0x00007fff964dcbca __psynch_cvwait + 10

1   libsystem_c.dylib                  0x00007fff952a72a6 _pthread_cond_wait + 890

2   com.apple.Foundation               0x00007fff94fb3a5c -[NSCondition waitUntilDate:] + 371

3   com.apple.Foundation               0x00007fff94f7d22e -[NSConditionLock lockWhenCondition:beforeDate:] + 251

4   com.apple.proxtcore                0x000000010b77403a -[XTMsgQueue waitForMessage] + 47

5   com.apple.proxtcore                0x000000010b773282 -[XTThread run:] + 329

6   com.apple.Foundation               0x00007fff94f8472a -[NSThread main] + 68

7   com.apple.Foundation               0x00007fff94f846a2 __NSThread__main__ + 1575

8   libsystem_c.dylib                  0x00007fff952a38bf _pthread_start + 335

9   libsystem_c.dylib                  0x00007fff952a6b75 thread_start + 13

 

 

Thread 6:

0   libsystem_kernel.dylib             0x00007fff964dcbca __psynch_cvwait + 10

1   libsystem_c.dylib                  0x00007fff952a72a6 _pthread_cond_wait + 890

2   com.apple.Foundation               0x00007fff94fb3a5c -[NSCondition waitUntilDate:] + 371

3   com.apple.Foundation               0x00007fff94f7d22e -[NSConditionLock lockWhenCondition:beforeDate:] + 251

4   com.apple.proxtcore                0x000000010b77403a -[XTMsgQueue waitForMessage] + 47

5   com.apple.proxtcore                0x000000010b773282 -[XTThread run:] + 329

6   com.apple.Foundation               0x00007fff94f8472a -[NSThread main] + 68

7   com.apple.Foundation               0x00007fff94f846a2 __NSThread__main__ + 1575

8   libsystem_c.dylib                  0x00007fff952a38bf _pthread_start + 335

9   libsystem_c.dylib                  0x00007fff952a6b75 thread_start + 13

 

 

Thread 7:

0   libsystem_kernel.dylib             0x00007fff964dcbca __psynch_cvwait + 10

1   libsystem_c.dylib                  0x00007fff952a72a6 _pthread_cond_wait + 890

2   com.apple.Foundation               0x00007fff94fb3a5c -[NSCondition waitUntilDate:] + 371

3   com.apple.Foundation               0x00007fff94f7d22e -[NSConditionLock lockWhenCondition:beforeDate:] + 251

4   com.apple.proxtcore                0x000000010b77403a -[XTMsgQueue waitForMessage] + 47

5   com.apple.proxtcore                0x000000010b773282 -[XTThread run:] + 329

6   com.apple.Foundation               0x00007fff94f8472a -[NSThread main] + 68

7   com.apple.Foundation               0x00007fff94f846a2 __NSThread__main__ + 1575

8   libsystem_c.dylib                  0x00007fff952a38bf _pthread_start + 335

9   libsystem_c.dylib                  0x00007fff952a6b75 thread_start + 13


Aperture 3, Mac OS X (10.7.5)
  • léonie Level 9 Level 9 (63,990 points)

    Does it crash on any library, with any image you try? Does it crash whenever you are editing in any way, or only for certain kinds of editing, like brushing?

     

    What kind of images are you using? Are you shooting raw or jpeg? How large are your images?

     

    Do you have any plug-ins installed?

     

     

     

    Regards

    Léonie

  • Frank Caggiano Level 7 Level 7 (25,695 points)

    You tried this with a new empty library and it crashed also? If so you should make a new user on your machine for testing purposes, log in as that user and run Aperture.

     

    Report back what happens running as the new user.

  • AlinaLakitsch Level 1 Level 1 (0 points)

    Dear Léonie, I'm editing some pictures for work, so I tried them in my original library and then in another one, and It crashed anyway. So, I think that may be is a corrupt file issue in my work photos. Today I worked relatively well, with those photos in a new library, and only failed 3 times (before the faults were thousands!). Every time, before and now, It's crashes when I'm editing, mainly while using brushes. I work with RAW files, so they're very large images, and I have no plug-in installed.

     

    Dear Frank, as I said to Leonie, I imported my files back into a new library and keeps crashing. I'll try to create a new user and run Aperture. What is the use of that?

     

    Thank you both!

     

    PS: I think there might be a corrupt file, because one of the times it crashed the photo I was workig on appeared like this (attached here) when I restarted the program.Captura de pantalla 2013-03-05 a la(s) 17.45.58.png

  • Frank Caggiano Level 7 Level 7 (25,695 points)

    Dear Frank, as I said to Leonie, I imported my files back into a new library and keeps crashing. I'll try to create a new user and run Aperture. What is the use of that?

    BY doing this it will tell you if the problem is system wide or something in your environment that is causing this.

     

    If ti runs OK for the new user you know it is something specific you your environment causing it. If it crashes for the nee user also it is a system wide problem.

     

    Either way it helps to focus were to look for the problem.

     

    One thing when you do this you need to keep the new users setup pristine. Test with a new library (of course) and new images.

     

    Are you saying that when it crashes you were always working on this image? And if you don;t work on this image Aperture doesn;t crash? If so it's a very strong indication that this image is corrupt.

  • AlinaLakitsch Level 1 Level 1 (0 points)

    Hi Frank! Thanks for your quick response! I wasn't always working with the same image. It has happened with several images of the same project. It's very rare, now I'm working without problems for a few hours. Anyway, I'll try your solution. Thank you again!

  • léonie Level 9 Level 9 (63,990 points)

    PS: I think there might be a corrupt file, because one of the times it crashed the photo I was workig on appeared like this (attached here) when I restarted the

    The screenshot you are showing looks like there may be system wide problems. If it happens again and testing from a different account shows that the problem does not only occur in your user account, you may want to  check if iPhoto is working correctly (do you still have iPhoto installed? It should have come preinstalled on your mac). If there were a problem with your graphics card or memory, you should see the same kind of corruption in iPhoto as in Aperture when adjusting images.