8 Replies Latest reply: Oct 1, 2013 6:53 PM by Joe Shapiro
Jerzilla Level 1 Level 1 (0 points)

My macbook pro for some reason will not automatically connect to my wifi network when I am at home.  When I am at work or at other places where I have already entered the network info my computer joins automatically but for some reason at home every time I turn on my computer or wake it up from sleep mode it asks which network I would like to join.  It remember all of my network information because I never have to type in my password I just have to select the network but still if someone knows why this in and can please help I would greatly appreciate it. 


MacBook Pro, OS X Mountain Lion (10.8.2)
  • ds store Level 7 Level 7 (30,315 points)

    1: If your router has a "hidden network" then unhide it as the Mac won't keep asking and reveal you have one in other locations, thus forcing you to connect manually.

     

    2: Check the time and date are correct and current, updated to your location in System Preferences.

     

    3: If your router has WEP Encrypted, change it to WPA2 (AES) or open WEP, Mac's won't connect properly or to encrypted WEP as it's insecure and being made obsolete. WPA will also work but it's been cracked, so set a very long password it might help.

     

    4: Lastly, go to your System Preferences > Network > Airport and Advanced > Airport and delete all your locations using the "-" minus sign. Then reboot the computer and connect manually and save the connection to your KeyChain when it asks.

  • Jerzilla Level 1 Level 1 (0 points)

    How do I tell if it is WEP Encrypted or open WEP?  It just says WEP. 

     

    Also all it says for my locations is Automatic.

  • ds store Level 7 Level 7 (30,315 points)

    If you erase all your connections in System Preferences > Network like I mentioned in #4 above, do you have to enter a password to connect? Then it's WEP encrypted.

     

    WEP anything shouldn't be used, open WEP it allows anyone to do anything on your network and encrypted WEP is inseucre and Mac's are not connecting to it properly anymore.

     

     

    Perhaps it's time for a new router, a wireless N with WPA2(AES) if yours doesn't have it.

     

    WiFi security issues, at home and WiFi hotspots

     

     

    Remember you can always get online with a Ethernet cable to the router, or to the modem if you reboot it after connecting to your computer (bypassing the router)

  • Jerzilla Level 1 Level 1 (0 points)

    Did Mac's stop connecting just recently because my computer connect properly up until about a week ago.  Before then it was never a problem.

  • ds store Level 7 Level 7 (30,315 points)

    It's possible if you recently did a update.

     

    Did you try #4?

  • brer_rabbit Level 1 Level 1 (0 points)

    Ds store.  I also have this annoying loss of Internet problem since last update, although it recognises my wi-fi dongle. I'm desperate to get it fixed, I need Internet for work. I work away from home so can't use an Ethernet cable.  I've read number 4:

     

    4: Lastly, go to your System Preferences > Network > Airport and Advanced > Airport and delete all your locations using the "-" minus sign. Then reboot the computer and connect manually and save the connection to your KeyChain when it asks.

     

    However, I'm not sure where you find Airport and Advanced?  Is that the side panel when you click on Network?  (Sorry, my first Mac, so not too familiar with it yet).  If I remove wi-fi, Ethernet, FireWire, Bluetooth and Ethernet or EN3 then reboot, will everything reappear except for wi-fi?

     

    I've tried to work out how to connect manually too, but it doesn't appear to give me that option...

     

    Im using a MacBook Pro with 10.7.5

     

    Thanks

  • Brianfit Level 1 Level 1 (0 points)

    I had the same problem, but I was loathe to lose my list of preferred networks as I travel a lot and it's.... erm... extensive.

     

    The alternate fix for me was to add a location, change to that location. Bam. Done.

     

    >SystemPreferences >Network > Location > Edit Locations +to add.

     

    I kept all my preferred networks intact AND solved the issue of Wifi not connectiong automatically.

     

    Not sure what the root issue is -- I had no probelems until the upgrade to 10.8.4,  and that bothers the geek in me, but having lost my Saturday Morning trying different solutions, I'm going to let that sleeping dog lie and be glad it's working. ;-)

  • Joe Shapiro Level 1 Level 1 (10 points)

    Deleting all your preferred networks works - but there's an easier solution that preserves them.

     

    1. Go to System Preferences > Network > Airport and Advanced > Airport

    2. Turn Airport off

    3. Scroll through the list to find your home network. For me it had mysteriously moved to the bottom of the list.

    4. Drag it to the top of the list.

     

    Hit OK and Apply to save your changes.

    Turn WiFi back on and I bet your home network will reconnect lickety split.