9 Replies Latest reply: Mar 7, 2013 10:15 AM by Lysergic
Lysergic Level 1 Level 1 (0 points)

I am having the strangest problem in iMovie 11: I drag an edited audio file into an iMovie project, but it won't play. I can see it in the timeline but there's absolutely no sound. I have checked in the Inspector panel and the level is at 100%; there is no ducking or fading checked; I've "normalized the volume - nothing. Probably even more astounding is that if I click on "Clip Trimmer" it shows up in the editing window. I can hear it; I can shorten it, but when I click "Done" and go back to the timeline there's no sound.

Any ideas?

Alan


iMac, Mac OS X (10.7)
  • AppleMan1958 Level 7 Level 7 (27,400 points)

    What kind of audio clip is it? MP3? AAC? AIFF?

  • Lysergic Level 1 Level 1 (0 points)

    It is an MPEG 4.

  • AppleMan1958 Level 7 Level 7 (27,400 points)

    MPEG 4 is usually for video. I'm stumped. Maybe someone else can help.

  • Lysergic Level 1 Level 1 (0 points)

    Yes, it is very strange. Thanks for trying.

    Alan

  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    Hi

     

    Explain - Can't do that

     

    Tell how I do - Yes

     

    • I only use .aiff 16-bit 48kHz or Audio-CDs (.aiff 44.1khZ) audio in my projects in iMovie or FinalCut

     

    • in iMovie'08 to 11 - I export out as "Share to Media Browser" and as Medium - to be imported to iDVD. Audio still there

     

    All other as .mp3 etc - I convert to .aiff via AudaCity (free from Internet)

     

    or if from iTunes - Collected into a new PlayList ===> to a standard Audio-CD (no .mp3)

     

    and the I use these .aiff files in my projects

     

    I have about ZERO percent problems with my Audio - even on the DVDs (as I make my movies to this)

     

    Yours Bengt W

  • Lysergic Level 1 Level 1 (0 points)

    Thanks Bengt, but no. I converted the file to AIFF through GarageBand and still nothing. There are lots of other MPEG-4 clips in the show and most of them work fine. I can see the waveform in the iMovie window, it just won't play. It's almost like iMovie can't find the file - which is crazy because I'm creating new files and dragging them in - or that it is muted, which the Inspector tells me it is not.

  • Lysergic Level 1 Level 1 (0 points)

    Incredibly frustrating: I can see the waveform in the timeline; I can lower the volume; I can move the file, and I can hear it in the clip editor, but it absolutely will not play in the timeline. If I drag the audio file into another project, it plays fine. So, I'm giving up. There must be some kind of corruption in the project. I will start a new project. Does anyone know how to take the photos and videos from one project and bring them into a new one? I've tried copy/paste using just a couple of photos but it doesn't work.

  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    I wrote this a time ago - anything of use ?

     

    No Audio

     

    Most common origin is use of audio from iTunes.

     

    Work around -

    • Select needed audio to one new playlist

    • Copy out this as an Audio-CD .aiff (not .mp3)

    • Use this in the movie-project

     

    Other origins are

    1. strange / alient file formats as -

    • .mp3, .avi, .wmv etc

    • Convert them into .aiff 48kHz 16-bit and use this

     

    2. the Mac is set wrongly in regard of midi -

    • Close iMovie and other programs

    • Start GarageBand

    • Make a new GB-project and play some notes

    • Close GB and Save

    • Now try iMovie again

     

    3. No audio when playback in iMovie 1 to HD 6.

    a. in iMovie pref. - deselect ” Playback via Camera”

    b. in System preferences - see that Audio out is not set to zero. Mine often does this

    without me knowing why.

     

    4. iMovie’08 & 09 & 11

    • Toggle audio-scimming by cmd-K

     

    Stuttering audio and video

     

    1. FileVault is ON - Turn it off

     

    2. More than 50 audio files in a movie-project

    Mix down to one audio clip

     

    3. Project is stored on one (USB) external hard disk - should be a FireWire one

     

    4. the External hard disk is not Mac OS Extended formatted - but

    UNIX/DOS/FAT32/Mac OS Exchange and this will not work for Video.

     

    5. To little free space on internal boot hard disk.

    I go for a minimum of 25Gb free space when project is imported and edited and this goes for

    4x3 SD Video. For 16x9 HD my guess would be about 5 times more at least.

    Neither Mac OS, iMovie or iDVD can address any other hard disk than the boot drive for it’s

    scratch files. (Unlike Final Cut Express/Pro where You select scratch disk/s)

     

    6. Network storage - DOESN’T WORK

     

    Yours Bengt W

     

  • Lysergic Level 1 Level 1 (0 points)

    Sorry Bengt. I tried all of your suggestions (some before and some after reading your post) but no success. Then I noticed that there was an audio file later on in the project with a yellow exclamation point - meaning that iMovie could not locate the file (even though it was in a folder with all the other audio files). I deleted that file from the timeline and then dragged in the same audio file, after renaming it, and so far everything is working.

     

    Thanks to everybody for their suggestions.

     

    Alan