4 Replies Latest reply: Mar 6, 2013 2:21 PM by mende1
WalkMan Level 1 Level 1 (0 points)

Just need to know if Time MAchine will work with OSX 10.4??

 

I have a client that has backup issues and I would like to use TM. 

 

 

JCW


iPad 2, Mac OS X (10.7.5), MacPro, iBook, iMac 27