11 Replies Latest reply: Apr 12, 2014 10:35 PM by TechieJustin
TechieJustin Level 1 Level 1 (0 points)

I am in real trouble here.  Using my Airport extreme with both firmware 7.6.1 and 7.6.3 I cannot connect to my office's Windows Remote Desktop Server or Microsoft Exchange server.  Using Outlook or the Web Interface it just does not connect.  I also tries resetting thr router to factory defaults under both 7.6.1 and 7.6.3 with the same result.

When I remove the router and connect directly to the internet, it works fine.  The RDP server and email server are the same machine. 


MacBook Pro, Mac OS X (10.7.3)
  • 1. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    I have an update and it isn't good.
    Thisproblem happens completely randomly.  I can't connect to my company's email, RDP, or web server.  When I remove the Airport Extreme and connect directly to the internet, or use my old router it works fine.  Keep in mind I am not switching internet connections or external IP addresses - I checked.  The IP address Comcast assigns me doesn't change no matter whar router I use.  Everything else works fine.  So my plan is to call Apple support when I have this problem.  I have no idea when that will be - the last time was a week ago and it was too late to call.

  • 2. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    Another update - even worse.

     

    I just tried using Google's public DNS servers - nothing.

    I called Apple and was forwarded to their senior techs who contacted their engineers.  They want me to try it from another location.  Easier said than done, but I still did it and the same thing happened.
    I don't understand their reasoning.  When I disconnect the Airport Extreme, and use my old router - a Buffalo everything is fine.

    So I don't know where I go from here.  If this is a flaw with the Airport Extreme, sending me a new one won't help because the new one would have the same problem.

     

    It seems there are other people with the same issue, random sites aren't working on random days for no real reason.  ore people need to call in before they acknowledge there's a problem.

  • 3. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    Month later - no resolution.  At this point I'm insisting on a refund.

    This is obviously a problem with the Airport, not my ISP.

  • 4. Re: AirPort Extreme can't connect to RDP or Exchange
    kyoung4175 Level 1 Level 1 (0 points)

    Did you ever resolve this?  I have the identical issue.

  • 5. Re: AirPort Extreme can't connect to RDP or Exchange
    LaPastenague Level 8 Level 8 (35,380 points)

    If you are using a PC you need to manually forward all the ports required.. Apple routers do not respond to upnp requests.

  • 6. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    No, I was forced to return the router.  After speaking to Apple's engineers nobody could figure out what was going on.  We confirmed there was no problem on the server side and nothing was being triggered such as a security or firewall block. 

  • 7. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    That's not true.

    I used a PC and it worked fine until all of the sudden it would simply quit for a period of 24 to 48 hours.

    Made absolutly no sense.

  • 8. Re: AirPort Extreme can't connect to RDP or Exchange
    kyoung4175 Level 1 Level 1 (0 points)

    Thanks for the response.   Yes, identical issue due to it being a PC - sometimes it works great - then it drops and will not reconnect.   I dont see any upnp option in the Extreme - but I hear NAT works for some - obviously not for this.   Right now, I am using mine as a wireless extension to my existing router - which of course works great - but I am not sure if it is worth the cost.

  • 9. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    I had no choice but to insist APple take the router back.  I hated doing it, but that was the only solution.  I started a new job and sometimes I had to connect at night.  If I couldn't connect my job was in jeopardy. 

    This was the first major issue I have ever had with an Apple product.  In my opinion this is a Microsoft issue and Misocoft intentionally makes things difficult for Apple products to work with their proprietary junk, such as RDP and Exchange.  They makes things hard on Mac userstoforce them to switch back to PCs.

     

    One thing you might want to do is ask your systems admin if the firewall is being triggered.  Sometimes there can be a percieved attack and they start blocking your IP address.  That was happening to a friend of mine who was using an Airport and trying to connect to his company's (Lockheed) VLAN.  I'm not sure how they fixed it, but once he told his admin what was happeniend he did something to get it working again.

    It was similar to what we experienced.  Everything was fine, and then suddenly we're blocked for no apparent reason.

  • 10. Re: AirPort Extreme can't connect to RDP or Exchange
    dhartwig Level 1 Level 1 (0 points)

    Just went through this myself (replaced a Netgear WPN823v3 with an AirPort Extreme).  Extreme works great, except for RDP.

     

    From either a MacBook Pro or a Win7 machine, I couldn't get through to a Win Server I needed to access.

     

    I opened BOTH UDP and TCP ports (3389) - but nothing. 

     

    So, since I have access to the firewall in front of the Win server, I opened 3389 for my external IP on the firewall and Voila!  Not sure why I had to do that.  It hadn't been defined before, and I had a co-worker (not on an AirPort Extreme) verify that she could get in before I changed the rule.  But hey, it works now.

     

    (The Netgear supports uPnP, and the Extreme doesn't, so I'm guessing that was why it previously worked...)

     

    I may go close the UDP port now, as I don't think it's probably necessary.

     

    Hope this helps somebody.

  • 11. Re: AirPort Extreme can't connect to RDP or Exchange
    TechieJustin Level 1 Level 1 (0 points)

    There was no way I would ask the company ID guy to open a port.  I did discover something with my current Buffalo router, "pings" must be turned on.  If I uncheck "block anonymous WAN requests (ping)" I can't get in.  Once I turn it back on, it works fine.  My prevous router was old and did not support uPNP.

    I don't remember a similar setting on the AirPort.