2 Replies Latest reply: Mar 7, 2013 10:11 AM by RajaRani
gurkin Level 1 Level 1

I am a pensioner and cannot afford a new phone I have the 3g 16gb and it works well but I would like to use it for facebook and skype but it tells me I need Os5 at least, this is unfair the phone should be kept up to date as I expected to get many years of use out of it, is there anyway I can update it.


iPad 2, iOS 5
Solved by varjak paw on Mar 7, 2013 10:02 AM Solved

Sorry, but iOS 4.2.1 is the last version an iPhone 3G can run. It was, unfortunately, the choice of the developers to only support iOS 5 or higher, so there will be no way you can run those apps on your iPhone. Your iPhone will of course continue to work just fine doing what it's always done.

 

Regards.

  • varjak paw Level 10 Level 10

    Sorry, but iOS 4.2.1 is the last version an iPhone 3G can run. It was, unfortunately, the choice of the developers to only support iOS 5 or higher, so there will be no way you can run those apps on your iPhone. Your iPhone will of course continue to work just fine doing what it's always done.

     

    Regards.

  • RajaRani Level 4 Level 4

    iPhone 3G is Old technology. When it was launched it had iOS 2.0. Currently, the highest it can go is iOS 4.2.1 and therefore can not handle many newer applications. As you have recorded, it is giving good service for which it has been designed.

    Needless to say, if you want to use applications as stated, you must have at least 3GS, whose current is iOS 6.1.2. On the lighter side; Rather than updating iOS they are asking you to update iPhone (Technology). Cheers