7 Replies Latest reply: Mar 8, 2013 12:37 PM by Windsor985
Windsor985 Level 1 Level 1 (0 points)

I just had my iMac hard drive replaced, due to a recall. When trying to reinstall my Aperture library from an external hard drive, I get the message they need to upgrade. I am running Aperture 3.2.4, on OS 10.6.8 and every time I have tried to upgrade my photos, the scanning bar continues to move but nothing else happens. This has been allowed to go on for hours but nothing changes. I have reinstalled Aperture a couple of times and nothing seems to help.

I would appreciate any suggestions, hopefully in lay terms.

Thank you.


iMac (21.5-inch Late 2009), Mac OS X (10.6.8)
  • léonie Level 9 Level 9 (63,990 points)

    What Aperture version are you upgrading from and how large is your Aperture library? For a really large Aperture Library the upgrade can seem to hang for hours. If your library is close to a Terabyte let the upgrade run.

     

    Sometimes the upgrade of the Aperture library hangs, if the Aperture library has a corruption and needs repairing. In that case try the Aperture library First Aid Tools and repair or rebuild the Aperture Library before trying to upgrade.

     

    Launch Aperture with the ⌥⌘-key combination firmly held down and select "Repair Database" from the panel.

     

    Regards

    Léonie

  • Windsor985 Level 1 Level 1 (0 points)

    Thank you for your reply.

    The Aperture Library folder is 15 GB and was created in Aperture 3.1.3.  I didn't realize there would be such a problem reinstalling my photos. I tried the First Aid Tools. It would open Aperture with a new library but not the older version, original library.

     

    Thank you,

    -Peter

  • léonie Level 9 Level 9 (63,990 points)

    Peter,

    then try to hold down the ⌥⌘-keys and double click the old Aperture library to launch Aperture directly on that library. Does that work?


  • Windsor985 Level 1 Level 1 (0 points)

    I get a window that says the photos need an upgrade. When clicked, I get the following message: There was an error opening the database for the library “~/Pictures/Aperture Library.aplibrary”.

  • léonie Level 9 Level 9 (63,990 points)

    Is there a crashlog, when you get this error message?

  • Windsor985 Level 1 Level 1 (0 points)

    No, Just "Warning".

  • Windsor985 Level 1 Level 1 (0 points)

    Well, I'm still not sure how I did it but I tried a few more dig arounds and finally restored my photos.

     

    Thank you for your kind suggestions and patience.

     

    -Peter