8 Replies Latest reply: Mar 6, 2014 6:50 AM by Christian Sømme
radu92 Level 1 Level 1 (0 points)

Every time I try to copy large files (more than 100GB) the small window which shows the copy progress continues showing "Preparing to copy..". It is not really stuck, and I can cancel it if I choose to, but it doesn't copy the file either. I tried copying my iPhoto Library when I discovered this issue. It also happens if I enter Time Machine and try to restore and older (local) copy of the library.

Does anyone know how to solve this problem?

I would really appreciate any kind of help.

 

(I'm using OS X 10.8.2.)


Mac Pro, OS X Mountain Lion (10.8.2)
  • BDAqua Level 10 Level 10 (118,655 points)

    What format is the drive you're copying to?

     

    Bootup holding CMD+r, or the Option/alt key to boot from the Restore partition & use Disk Utility from there to Repair the Disk, then Repair Permissions.

     

    Then Repair Disk for all external drives.

     

    How much free space is on each drive?

  • radu92 Level 1 Level 1 (0 points)

    I am just copying files within my HDD, so it's the default Mac format.

     

    I did repair permissions from the Disk Utility, however without booting from the Restore partition.

    I'll try that as soon as possible. Thank you for your advice.

     

    There is 400+ GB of free space on my hard drive, my iPhoto library is around 180 GB.

    I have to mention that right now it just worked to copy the same library from an external drive to my mac, which is weird, but it doesn't seem to work within the same hard drive. I was trying to copy the library from Volumes/MobileBackups (local backups time machine does) to my Pictures folders, but it doesn't seem to work.

  • BDAqua Level 10 Level 10 (118,655 points)

    Pretty strange, keep us posted with any more info please.

  • radu92 Level 1 Level 1 (0 points)

    So I let my MacBook turned on over night, and it surprisingly started copying the files, but it hasn't finished even after 10 hours. I guess the problem is that the copying process is very, very slow due to my large number of photos (20000+). Thanks for your support though

  • BDAqua Level 10 Level 10 (118,655 points)

    OK, keep us posted as to the outcome please!

  • radu92 Level 1 Level 1 (0 points)

    It all worked out

  • BDAqua Level 10 Level 10 (118,655 points)

    Great to hear, thanks!

  • Christian Sømme Level 1 Level 1 (15 points)

    Hi!

     

    Recently, I have encountered the same problem.

     

    It turns out that many users have the "preparing backup" issue, but I gave it some thought and remembered that the problem started to occure after moving my iPhoto folder to an external drive.

     

    I have formatted my external Time Machine drive etc. etc. Tonight, it worked for 3 backups. Now, it is locked "preparing backup" again.

     

    radu92, could you please explained how it worked out for you.

     

    Cheers,

    Norchris