4 Replies Latest reply: Mar 9, 2013 2:15 PM by stedman1
littlescarletttheoriginal Level 1 Level 1 (0 points)

My white apple mac I purchased in 2011 witch worked my iphone and Ipad has stopped working and i have been forced to reuse my old black apple mac witch was purchased in 2008 it seems my Apple Ipad and Iphone 5 will not connect to Itumes on my apple mac I researched it and found that I needed Itunes 10.5 now itunes won't install the itunes softwear as its stating it needs MAC OS X 10.5 to run the soft wear I went to download this soft wear to find that's its been closed where can I down load this soft wear as Im in urgent need to connect my Iphone and Ipad to my mac for work

 

Kind regards

 

Scarlett


MacBook