Previous 1 2 Next 23 Replies Latest reply: Dec 28, 2013 8:01 AM by rmaruzzi
Afcla Level 1 (0 points)

I operate 2 user accounts on my Macbook Pro. The aperature lbrary is shared between both accounts. Up until a couple of months ago evverything was working fine. I now have a situation where Itunes/Imovie etc isn't linked to the aperture library. The strange thing is that this only occurs on the primary user account. If I log into the other account everything works fine.


I have tried the various suggestions in the discussion forums - create new library, delete the file without success.


Because the linkage still works on one of the accounts I am guessing it is an account or permissions issue. I am at the latest versions of operating system and Aperture.


Does anyone have any suggestions?

Aperture 3, OS X Mountain Lion (10.8.2)
  • Frank Caggiano Level 7 (25,715 points)

    How are you sharing the library between the two users?  What changed on the system when it stopped working?

  • Afcla Level 1 (0 points)

    The library sits on the hard drive and the user permissions means both accounts can see the library. When each user logs on Aperature is configured to open the same library.


    No real change occurred expect that I was exporting projects and creating additional libraries to reduce space on the hard drive.

  • léonie Level 10 (90,569 points)

    that I was exporting projects and creating additional libraries to reduce space on the hard drive.

    Your Aperture user preferences may still be pointing to the last library you opened from your main account. iTunes reads the "" in the "preferences" folder in your user library to find the library to open. It may help to trash this file and to force Aperture to recreate it. But since you are using Mt. Lion I'd log off and on again after quitting Aperture and removing the preferences.


    The library sits on the hard drive


    Where exactly? A shared folder may not be enough, if the permissions inside the library do not allow iTunes to access the iTunes photo cache inside the library.




  • Afcla Level 1 (0 points)



    thank you for the suggestions. I tried this, no luck.


    In terms of permissions. The folder is shared and I apply the permissions against the shared folder to ensure both accounts have access.


    Clearly there is some user account issue but cant pinpoint it yet

  • léonie Level 10 (90,569 points)
    The folder is shared and I apply the permissions against the shared folder to ensure both accounts have access.


    Each time you write to your Aperture Library, the items inside the library you edit may change the ownership to the user that is editing the library and the permissions inside the library will change. The only safe way to share an Aperture library, so that two users can read and write is to have the library on a disk (external drive, separate disk partition, or writable disk image) that has the "Ignore Ownership" flag set. This is explained in this support article for iPhoto Libraries, but for Aperture libraries goes the same, see: iPhoto: Sharing libraries among multiple users


    Hopefully Frank has some more ideas - I still do not see from your answer to his question what exactly changed, before it stopped working.


    One more thing to check: Sometimes the iPod Photo Cache gets corrupted and then iTunes cannot open the library. Try to remove it from the library as described here: iTunes: Understanding the iPod Photo Cache folder

    Deleting the cache should have no other consequences then that the next sync with iTunes may take longer.

  • Afcla Level 1 (0 points)



    Thanks for the informaion about permissions. I have been contemplating moving the library onto an external disk and will use this information to assist. My current workaround for this is to apply the permissions to the shared folder after I do imports into Aperture. This has been working for me.


    To be honest not much has changed before the functionality of Itunes an Imovie accessing Aperture was working. All I can put it down to is that i have been exporting projects to new libraries and moving to external drives and then deleting these projects from my main library. I needed to do this to free up space on my internal HD.


    I will try the Ipod Photo Cache folder suggestion, but I still can't get my head around the fact that another account on the same machine works fine.

  • Frank Caggiano Level 7 (25,715 points)

    So what exactly do you see  when you are in the edia browser in the account that is not seeing the Aplerture library?


    Are there no images at all, old images, images from a different library?

  • Afcla Level 1 (0 points)



    If I go into an application and do a file open, I can see all my Imovie files, all my Itunes media, but for photos all i get is Iphoto option and no aperture for the account where the Aperture library is not found.


    So it isnt as if there are no photos I don't even get to see Aperture as an option

  • Ernie Stamper Level 8 (37,545 points)

    The sharing of photos for some purposes can only work with one Library at a time, whether Aperture or iPhoto.  This is different than with the Media Browser, where more than one library can be seen.  There is a file (iPod Photo Cache) that is singular in it ability to reference a library.  This controls such things as sharing to an Apple TV, or iTunes in my experience.


    Your creation of different libraries is involved in what you have experienced.



  • Frank Caggiano Level 7 (25,715 points)

    So in the primary user account (the one with the problems) if you open Aperture does the shared library open by default?


    If not, if you double click the shared library does Aperture open?

  • Afcla Level 1 (0 points)



    Aperture seems to work fine. when opening Aperture it opens the last library file used.

  • Thomas Emmerich Level 4 (3,485 points)

    Share previews with iLife and iWork needs to be enabled in Aperture's preferences to be able to see Aperture images in the media browser. If you deleted the Aperture .plist file it should have defaulted to enabled. But check it anyway.

    Screen Shot 2013-03-15 at 2.32.01 PM.png

  • Afcla Level 1 (0 points)


    Thanks. This setting is correct.

  • Afcla Level 1 (0 points)

    Some additional information. So in Imovie when I go to the photo browser option to add photos to my movie project i dont even see an option for aperature. On the other account that is working correctly I do.


    This is strange

Previous 1 2 Next