Previous 1 2 Next 23 Replies Latest reply: Dec 28, 2013 8:01 AM by rmaruzzi Go to original post
  • Frank Caggiano Level 7 Level 7

    Try this. In the account that is not working create a new empty library and import a few images into it.


    How try looking at iMovie (or whatever else is having problems) and see if you can see Aperture.

  • Afcla Level 1 Level 1



    I have tried this aswell without luck. To me it has to be something broken with the OS undertanding Aperature exists, when I cant even have media browser or iMovie doesn't even give an Aperature option.

  • Ernie Stamper Level 8 Level 8

    On my rMBP, I have not rarely used iMovie.  On this laptop I have numerous specialized Aperture Libraries, although at any time I can connect it to a clone of my "alpha" 1.4 TB Library.


    I just played around on it to see what would be presented by the Camera Icon in iMovie's media browser.  Only the most recently opened Aperture library was presented, and no other.  Open a different library, and that, and only that second library would be available.  (Btw, the Aperture option was at the top, and I had to scroll up to see it.


    I am as yet unclear about your reports and which Aperture Library has most recently been opened with Aperture.  Can you shed more light on that, please?



  • Frank Caggiano Level 7 Level 7

    Afcla wrote:




    I have tried this aswell without luck. To me it has to be something broken with the OS undertanding Aperature exists, when I cant even have media browser or iMovie doesn't even give an Aperature option.

    It is possible it is in the OS but not likely, the reason being it works from the other account. This strongly suggests it is something in the environment of the non-working account. If it was in the OS you would expect that it would not work from any account.


    That you wrote that just before this stop working you were exporting and making new libraries in the account that is now not working further indicates that something got messed up for this account.


    Lets try some basic stuff. If you open mail and create a new message then click the paper clip icon in the upper right corner of the message

    Screen Shot 2013-03-17 at 14.17.52 .png

    then in the finder thst opens scroll down to the Media section, then click Photos


    Screen Shot 2013-03-17 at 14.18.05 .png

    What do you see? This is what I get:


    Screen Shot 2013-03-17 at 14.18.20 .png


    A screen shot of your results would help.



  • Afcla Level 1 Level 1



    Going back to basics makes sense. here is a screenshot from my system using the account that isnt working. No aperture ir even photo booth


    Screen Shot 2013-03-18 at 9.03.25 PM.png

  • Afcla Level 1 Level 1



    Further I took a screen shot from the account that is working correctly and I get the following


    Screen Shot 2013-03-18 at 10.16.38 PM.png

  • Frank Caggiano Level 7 Level 7

    One last clarification. When you created the new library in the non-working account to test this out you created under your home folder right,? Not on the volume or folder you are using to share the other library.

  • NotchJ Level 1 Level 1

    I have the exact same problem as described in this post.  But with some background and additional information.


    First of all, the reason I'm doing this is that I have a family with individual login accounts.  But they all want to be able to open and edit the same "family" Aperture library.   (Using the latest versions of Mountain Lion. iPhoto 11, and Aperture 3.x)


    The solution to this is to move the Aperture library to /Users/Shared/Pictures and then create a symbolic link in each user's home Pictures folder for Aperture and iPhoto.  For example:


    ln -s /Users/Shared/Pictures/Aperture\ Library.aplibrary ~/Pictures/Aperture\ Library

    ln -s /Users/Shared/Pictures/Aperture\ Library.aplibrary ~/Pictures/iPhoto\ Library


    Repeat for each user, add a bunch of permissions via a chmod command and have the users select the symbolic link upon startup of Aperture & iTunes using Option key.


    Now this solves the original issue just fine.  Everyone can open and use the Aperture library.


    But I run into the problem described by the OP for all users.  iTunes (or Screensaver for that matter) can't find/read the Aperture Library.  But iTunes can be set to select photos from iPhoto in which case it does traverse the link and can show events just fine.  Just doesn't work if I select Aperture.


    So either the problem is due shared apps not being able to traverse the symbolic link (alias), or it's due to the Aperture library being in a shared location and not under the home folder???  I can't work out which.  I've tried all of the recommendations in this thread and others.


    Any suggestions/solutions?  Thanks.



  • rmaruzzi Level 1 Level 1

    Hi Notchj,


    I'm experiencing exactly what you described in the latter portion of your post.

    I have a lage Aperture library (1+TB) parked on and external Thunderbolt drive.


    No Apple app - Desktop Wallpaper, Mail or iTunes can now access the library properly. iTunes reads the Projects hierarchy almost perfectly, but then no photos get visualized on my Apple TV. Same sw, hw and WiFi config, and the much smaller iPhoto library becomes accessible from the Apple TV instantaneously.


    I guess they are size and location the two factors generating this bug.


    Many thanks, Stefano

Previous 1 2 Next