Previous 1 2 Next 18 Replies Latest reply: Nov 5, 2013 8:49 AM by WhyGuy
WhyGuy Level 1 Level 1 (5 points)

Hi.

 

I've been using an external drive for Time Machine for some time and I want to erase the contents of the drive and reformat it.

 

When I try to erase the drive using Disk Utilty, something I've done many times on many drives over the years, the Erase Tab is greyed out. 

 

I suspect it might have somehting to do with me encrypting the backup but I can't figure it out. I've also exluded it as a backup drive inside Time Machine Preferences.

 

Any ideas?

  • Shootist007 Level 6 Level 6 (16,645 points)

    Select the Drive Name, IE the Top Level entry for that external drive then the Partition Tab and repartition as One Partition.

     

    Could be TM is actively accessing the drive so first turn Off TM.

  • ds store Level 7 Level 7 (30,315 points)

    Apple just preventing ignorant users from messing up their backup drive.

     

    TimeMachine has special permissions but I think it can be deleted if you hold option key boot from a 10.6 disk or command r boot from 10.7/10.8 Recovery HD partition and use that Disk Utility instead of the one in your OS X Utilities folder, according to Pondini

     

    http://pondini.org/TM/12.html

     

     

    Consider bootable clones, they are on a order of a magnitude better in many ways to TimeMachine.

     

    Most commonly used backup methods

  • WhyGuy Level 1 Level 1 (5 points)

    Thank you both for the suggestions.  I had already tried the partition tab but it won't let me alter them at all. And I tried booting into Disk Utility using Command R but it still ghotsed out the Erase and Partion options on the top level time machine drive. See attached screenshot. 

     

    Screen Shot 2013-03-13 at 11.28.09 AM.png

    Also note than another firewire drive on this Mac doesn't have this issue.  Only the encrypted TIme Machine drive and only the top level of the drive, not the sub level.

     

    I don't get it.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Are you on a Macbook Pro Notebook or a Mac Pro Desktop system?

     

    Those drives look to be Internal drives not externals and that is not possible on a MBP notebook. 2 drive yes but 3 physical drives in a Mac notebook, No Way.

     

    Is there also a version of OS X installed on that TM drive? As I would think that the BOOT drive would always show at the top of that list and secondary physical drives below the Boot drive.

     

    Also the TM drive does not have a Drive Manufacturers name or the size listed, which is very odd also. Even if it is designated as a TM backup disk it should still have a manufacturers name and the total size of the drive listed just like the other 2 Physical drives and your External drive.

     

    Now I see it a Logic Volume Group. That is the problem and or Reason you don't get any options. You must first break apart the volume group to actually access the physical disks.

     

     

    One Tip.

    Never ever use and internal disk as a TM backup drive, and along with that never a Volume Group as a TM backup drive.

  • WhyGuy Level 1 Level 1 (5 points)

    I'm on a MacBook Pro with a 60 GB SSD as my boot drive and a 500 GB Hard Drive in my old optical bay as my data/home folder drive.

     

    I have no idea why Time Machine is showing up as an internal drive.  Good job on noticing that.  I can't explain it.  And yes, you're right, the manufacturer usually has its name in the top level followed by the name I choose as the sub drive.  Again, I don't know how this happened.

     

    I don;t know what a Logic Volume Group is, either... Sorry.

  • Shootist007 Level 6 Level 6 (16,645 points)

    A Logical Volume Group is a combination of 2 or more physical disks or partitions on different Physical disk made to look like one physical drive. So more then likely you are using one partition on both the SSD and the Hitachi disk combined into that Volume Group.

     

    How and when that was created only you would know or whoever set that system up like that. What you have now, IMHO, is a Cluster Fark and should be wiped out and done differently

  • ds store Level 7 Level 7 (30,315 points)

    I know a method using Linux that would work for sure to erase that disk.

     

    Remove all other drives

     

    If you have a Mac with a Superdrive, then burn a ISO of Parted Magic to disk

     

    http://partedmagic.com/doku.php?id=downloads

     

    1. Insert a blank disc.
    2. Start Disk Utility.
    3. From the File menu, choose Open Disk Image and select the ISO to be burned.
    4. In the list of volumes, you will now see an item representing the ISO file. Select it.
    5. Click the Burn button and follow the instructions.

     

    Next you will need to boot from the disk, hold the option key down with the Parted Magic disk inside while booting, it will give a list of options eventually and Parted Magic disk will be there, click the arrow to boot from it.

     

    Leave the screen alone and it should boot into RAM and spit out the disk, so prepare for it.

     

    What you want is GParted, that will do a number on unlocking the drive and reformatting it, thus you can later access it in Disk Utility and format it as you wish.

     

     

    If your Mac doesn't have a Superdrive, then your going to need to use a Windows machine, BootCamp or Windows ina virtual machine to download PenDrive Linux, which you can install Parted Magic onto a USB thumb drive and then use that to option boot the Mac with.

     

    You also can install Linux Mint into a virtual machine in OS X and use GParted there to unlock  the drive.

     

     

    I'll have to mess around with this later to get a better set of instructions, but one would think there would be a Apple method to do so. Surprised Pondini didn't know, perhaps this is a glitch doing it.

     

    So it's a Filevault encrypted TimeMachine backup? Oh well.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Sorry I didn't read that you had encrypted the TM backup. Are all your drives encrypted? If so you will need to disable that before you can do anything.

  • WhyGuy Level 1 Level 1 (5 points)

    Thanks for the explanation of a Logical Volume Group.  That is indeed what's happend  (See atached screen shot) but I have absolutely no idea how.

     

    Screen Shot 2013-03-15 at 2.40.50 PM.png

    Screen Shot 2013-03-15 at 2.40.53 PM.png

     

    And to clarify, my Time Machine drive is encrypted through Time Machine Preferences only.  My main Macintosh HD (SSD and HDD in this case) are not.  I don't have File Vault on at all.  I also have tried using Disk Utilty to erase the drive, both with and without entering (or unlocking) the Encryption password.  It makes no differnce.

     

    I also booted into the Recovery HD as well as a backup clone of myMac HD using Super Duper yet wasn't able to access the drive at all.  I think I'm going to have to take everything into my Apple Store and see what they can make of it all.

     

    Thanks DS Store for the help but I don't have access to any of the options you suggested (no Super Drive, No other PC, no VM's) .

     

    Cheers.

  • Shootist007 Level 6 Level 6 (16,645 points)

    If you have a Clone of your Boot drive/partition and you have externals large enough or enought of them I suggest you backup, IE COPY, all your data to those external.

     

    Then you can use the Online Internet Recovery system to Completely erase and or re-partition all of your physical drives in your system and start fresh.

     

    That is possible if you have any Mac computer that originally came from Apple with either Lion or Mt Lion Pre-Installed on it.

     

    If it is a older or even slightly older Mac that came with Snow Leopard or Leopard you can use the original system disc to do the same thing. OS X, any version, will boot from an External DVD drive connected by USB, you don't need to have an internal DVD for OS X to boot from an external DVD drive.

     

    All that Apple will do is either completely erase ALL DRIVES in your system and reinstall the originally included version of OS X or they Will Say NO we will not work on it as it has been modified in a way Apple does not approve of because of the second HDD in the optical bay.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Also in the future, IE as soon as you get this straightened out, do not store TM backups on any internal drive/disk. you should always use an external drive for that whether connected by USB, Firewire, Thunderbolt or a Networked NAS system like an Apple Time Capsule.

     

    Storing TM backups on an internal drive/disk is just asking for trouble if the system should fail in some way.

  • WhyGuy Level 1 Level 1 (5 points)

    That's whats's so strange.  The TIme Machine backup is external.  I don't know why it has an internal disk icon. 

     

    I have a dual slot OWC Firewire External Drive enclosure with a 1 TB physical disk alloctaed to time machine and a second 500 GB physcial drive (in the same external firewire enclousre) for my redundant bootable clone backup using Super Duper.

  • ds store Level 7 Level 7 (30,315 points)

    WhyGuy wrote:

     

    I don't know why it has an internal disk icon. 

     

    The generic default is the internal looking graphic likely as it doesn't store information in plain to use a graphic like a external drive icon, which would be stored on it to identify different drives and makes.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Then it must be the enclosure you are using those 2 drives in. It setup some type of logical storage volume between those 2 physical disks installed in side of it.

    As to the drive icon this is a Firewire enclosure and Mac OS X may use the generic disk icon for FW connected drives. FW is also seen as a network resource as it shows up in both Mac and Windows in the network setting area.

    WhyGuy wrote:

     

    That's whats's so strange.  The TIme Machine backup is external.  I don't know why it has an internal disk icon. 

     

    I have a dual slot OWC Firewire External Drive enclosure with a 1 TB physical disk alloctaed to time machine and a second 500 GB physcial drive (in the same external firewire enclousre) for my redundant bootable clone backup using Super Duper.

Previous 1 2 Next